Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Catalyst 4500 password reset doesn't work

I was sent a 4506 switch from another office with a Supervisor Engine II+. I've never touched a Cisco switch before and the password is unknown. I followed the Cisco document on how to reset the password, which is necessary in order to reset the entire unit to the factory defaults.

When I get to step 4 they instruct you to "make sure" the configuration register is 0x2142 but mine is 0x2141. They don't indicate what to do if the value isn't 0x2142! It seems like the only way to change it is if you have the password, which of course I don't have.

All I want to do is reset the entire switch to the factory defaults. If there is any way to do this without the password then that would be fine with me, but the Cisco manuals seem to indicate that you must have the password.

Thanks in advance.


Re: Catalyst 4500 password reset doesn't work

Indeed I am missing an option in the document, the one to not load the config upon boot.

Try entering confreg 0x2142 on step 2, this skips the rest of the dialog and will take you directly to step 3. Then proceed as described.



New Member

Re: Catalyst 4500 password reset doesn't work

Thanks, but confreg 0x2142 replies with "usage: confreg".

I tried ConfReg=0x2142 and it replies "error: "ConfReg" can not be set directly. Use confreg command to set it.

Can you think of anything else?

New Member

Re: Catalyst 4500 password reset doesn't work


Just replace Ox2142 with 0x32 and then check it

your problem will solve


Re: Catalyst 4500 password reset doesn't work


To achieve the confreg value of 0x2142 instead of 0x2141 in you case just follow the procedure you have used and in step 2 in addition to answer "yes" (ie. y) to the question: enable "ignore system config info? y/n [n]:" y, please also answer "yes" (ie. put y) to the question "change the boot characteristics? y/n [n]:" y. The system should come with the prompt like this: change the boot characteristics? y/n [n]: y

enter to boot:

0 = ROM Monitor

1 = the boot helper image

2-15 = boot system


and here you should input "2".

Then you should be O.K. Personally I believe that 0x2101 is O.K. as well provided you have valid image in the system flash (In the case of 0x2101 the system will load the first image as contrasted to 0x2102 when system will load the image specified by BOOT variable).

I hope my English makes sense.

Best regards,


New Member

Re: Catalyst 4500 password reset doesn't work

Thanks everyone for all the help. The more I read the manuals I came to realize that there probably isn't even a password on my system. I'd type "enable" and it would go to the # prompt without asking for a password. I didn't realize that the "enable" command was actually giving me the elevated privileges I needed to reset the unit. As I mentioned I've never worked with a Cisco switch before so I don't really know what I'm doing (and the manuals assume you already know a lot of the details).

I've managed to reset the switch to the factory defaults and was able to reset the VLAN information. The incomplete Cisco docs mention that the config-register and boot system settings are not cleared to the factory defaults. Unfortunately they don't bother explaining how to actually reset the unit completely to the factory defaults. But I'll post that as another message since it's off the topic of this one.