Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CatOS - setting portvlancost back to default

I inherited these switches with portvlancosts specified. I would like to

set spantree portvlancost 5/1 cost 3099

I would like to set these to the default 19 - easy enough. But I also don't want this line to appear in the config any more like it does you fire up a new catos switch.

I tried

"clear spantree portvlancost 5/1 cost"

but that's giving me

"Usage: clear spantree portvlancost <mod/port> <preferred_vlans>

(preferred_vlans = 1..1005,1025..4094)"

Anyone got the secret?

8 REPLIES

Re: CatOS - setting portvlancost back to default

If 5/1 belongs to VLAN 10,

then issue the command :

clear spantree portvlancost 5/1 10

Hope this helps.

New Member

Re: CatOS - setting portvlancost back to default

Thanks for the reply and idea to try. But the line is still in the config. Hmm.

Note from config:

set spantree portvlancost 2/7 cost 19

set vlan 300 2/2-48

So the cost is 19 and the port 2/7 in this instance is on vlan 300.

I run:

c4006-1> (enable) clear spantree portvlancost 2/7 300

Port 2/7 VLAN 1-1005,1025-4094 have path cost 19.

But alas show config shows the line is still there.

sho config

(blah blah..)

set spantree portvlancost 2/7 cost 19

Purple

Re: CatOS - setting portvlancost back to default

Did you try entering it without the "cost" statement at the end , that may default it .

"clear spantree portvlancost 5/1

New Member

Re: CatOS - setting portvlancost back to default

Leaving off cost catos prompts me for preferred vlans..

c4006-1> (enable) clear spantree portvlancost 2/7

Usage: clear spantree portvlancost

(preferred_vlans = 1..1005,1025..4094)

Re: CatOS - setting portvlancost back to default

can you try saving your running-config to startup ?

New Member

Re: CatOS - setting portvlancost back to default

This is catos. No copy run start here.

Re: CatOS - setting portvlancost back to default

If you take a brand new switch and do show config all, what do the portvlancost look like?

Kevin Dorrell

Luxembourg

Re: CatOS - setting portvlancost back to default

If you run set spantree uplinkfast disable on a switch, the UplinkFast feature is disabled, but the switch priority and port cost values are not reset to the factory defaults. To reset the values to the factory defaults, enter the clear spantree uplinkfast command.

http://www.cisco.com/en/US/docs/switches/lan/catalyst4000/7.5/command/reference/set_s_z.html#wp1024720

389
Views
0
Helpful
8
Replies
CreatePlease login to create content