Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CBWFQ on Catalyst 3750 switches.

Dear All,

At presently I am using Catalyst 3750 switch as a layer 3 switch with switch ports as a routed ports with an ip address configured on them. Now when i tried to configure CBWFQ on the switch it was accepting the commands for Class-map, policy-map but not service-policy command on the interface. I am using advanced IP services IOS.

My question to team is whether Catalyst 3750 supports queuing on its routed interfaces or not? if it supports then kindly suggest me how can i achieve this?

Thanks

Mangesh A. Bhende

8 REPLIES

Re: CBWFQ on Catalyst 3750 switches.

Hi

"In software releases earlier than Cisco IOS

Release 12.2(25)SE, policy maps can be configured only on physical ports.

In Cisco IOS Release 12.2(25)SE or later, policy maps can be configured on physical ports or on SVIs".

I hope this helps.

Best regards.

Massimiliano.

Community Member

Re: CBWFQ on Catalyst 3750 switches.

Hi,

actually i am using 12.2(35)and still not working and there are no commands to configure set bandwidth percent on per class basis.

Please help.

Thanks

Mangesh A. Bhende

Community Member

Re: CBWFQ on Catalyst 3750 switches.

actually my 3570 switch configuration is as below.

access-list 101 permit ip host 10.10.10.1 host 10.10.20.1

!

class-map limit

match access-group 101

!

policy-map limit

class limit

bandwidth percent 30

!

int gi 1/0/1

no switch-port

ip address 10.10.x.1 255.255.255.0

service-policy output limit

I am unable to add service policy ont he gi 1/0/1 interface. Please help me in understanding whether switch supports this or not. If yes plz help me in doing so.

Re: CBWFQ on Catalyst 3750 switches.

The 3750 switches do not support service policy input command

Narayan

Community Member

Re: CBWFQ on Catalyst 3750 switches.

Hi

What about service policy output to configure CBWFQ? also what about rate limit functionality?

Thanks

Mangesh A. Bhende

Re: CBWFQ on Catalyst 3750 switches.

Mangesh....

Sorry i was wrong.. Actually you cannot configure service policy output command on a 3750 as it is not supported. If you try you will get an error

Warning: Assigning a policy map to the output side of an interface not supported

Service-policy input is supported and it is possible to do policing on it

Here is a sample config from one og our switches

class-map match-all voice_MP

match access-group name Voice_Traffic

class-map match-all data_MP

match access-group name Data_Traffic

class-map match-all singal_MP

match access-group name Voice_Signal

!

!

policy-map Mphasis_Traffic

class voice_MP

set dscp ef

class singal_MP

set dscp cs3

class data_MP

set dscp cs2

class class-default

set dscp default

interface GigabitEthernet1/0/1

description " To AT&T router 1 "

no switchport

ip address x.x.x.x 255.255.255.252

service-policy input Mphasis_Traffic

ip ospf authentication message-digest

ip ospf message-digest-key 10 md5 7 xxxxxxxx

ip ospf network point-to-point

speed 100

duplex full

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_35_se/configuration/guide/swqos.html#wp1044737

HTH

Narayan

Community Member

Re: CBWFQ on Catalyst 3750 switches.

Hi Narayan,

Thanks and Yes we can set the DSCP vlaues to incomming traffic and wanted to know like can i perform policing (rate limiting)or CBWFQ on these 3750 switches?. Because i configured for rate limiting using rate limit command on the interface and it took the command but is not working.

like if i execute sh int gi 1/0/1 rate-limit command it doesnt shows any change or dropped packet statistics.

Thanks

Mangesh A. Bhende

Community Member

Re: CBWFQ on Catalyst 3750 switches.

You need to use output queue shaping on the egress queues to simulate policing. Ie:

srr-queue bandwidth shape 0 0 0 120

That will limit queue 4 to 1/120 of the bandwidth of the port. You then use marking to mark the traffic to the DSCP values that will fall into that queue.

1152
Views
0
Helpful
8
Replies
CreatePlease to create content