Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CCME and VOIP.MS "this number has not yet been assigned" outbound call failure

                   Hello I have been trying to get this working all day.  I am using a 2800 ISR router with voice capabilities.  I am trying to use Voip.ms for over a sip trunk to make calls but i get a voice message that says "this number has not yet been assigned, please contact technical support" everytime i dial an external number.  I am registered to their server, it seems.  From the debugging it looks like the server is trying to register my individual extensions and failing the calls comig from those extensions.  What should i do?  please help.

here is the debug information:  thanks in advance

 

SIP Call events tracing is enabled
dhcpRouter#
Jan  5 06:15:46.379: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER
Jan  5 06:15:46.379: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:184.75.215.106:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK539B3
From: <sip:3000@184.75.215.106>;tag=21D624-BC8
To: <sip:3000@184.75.215.106>
Date: Sun, 05 Jan 2014 06:15:46 GMT
Call-ID: 5D7492FB-750311E3-80048DCA-1BEC8FC1
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1388902546
CSeq: 17 REGISTER
Contact: <sip:3000@67.244.22.49:5060>
Expires:  200
Content-Length: 0


Jan  5 06:15:46.403: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER
Jan  5 06:15:46.403: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:184.75.215.106:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK5422D3
From: <sip:3001@184.75.215.106>;tag=21D63C-1BA2
To: <sip:3001@184.75.215.106>
Date: Sun, 05 Jan 2014 06:15:46 GMT
Call-ID: 5D783C83-750311E3-80058DCA-1BEC8FC1
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1388902546
CSeq: 17 REGISTER
Contact: <sip:3001@67.244.22.49:5060>
Expires:  200
Content-Length: 0


Jan  5 06:15:46.419: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER
Jan  5 06:15:46.419: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:184.75.215.106:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK553E4
From: <sip:777@184.75.215.106>;tag=21D64C-2213
To: <sip:777@184.75.215.106>
Date: Sun, 05 Jan 2014 06:15:46 GMT
Call-ID: 5D7B49E4-750311E3-80068DCA-1BEC8FC1
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1388902546
CSeq: 17 REGISTER
Contact: <sip:777@67.244.22.49:5060>
Expires:  200
Content-Length: 0


Jan  5 06:15:46.447: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK539B3;received=67.244.22.49;rpo
rt=55401
From: <sip:3000@184.75.215.106>;tag=21D624-BC8
To: <sip:3000@184.75.215.106>;tag=as4e8ebebc
Call-ID: 5D7492FB-750311E3-80048DCA-1BEC8FC1
CSeq: 17 REGISTER
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="toronto.voip.ms", nonce="6ad3e8b3
"
Content-Length: 0


Jan  5 06:15:46.447: //74/000000000000/SIP/Error/sipSPIHandleAuthChallenge: Erro
r getting credentials
Jan  5 06:15:46.447: //74/000000000000/SIP/Error/ccsip_api_register_result_ind:
Message Code Class 4xx Method Code 100 received for REGISTER
Jan  5 06:15:46.471: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK5422D3;received=67.244.22.49;rp
ort=55401
From: <sip:3001@184.75.215.106>;tag=21D63C-1BA2
To: <sip:3001@184.75.215.106>;tag=as1e0507bb
Call-ID: 5D783C83-750311E3-80058DCA-1BEC8FC1
CSeq: 17 REGISTER
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="toronto.voip.ms", nonce="787132a6
"
Content-Length: 0


Jan  5 06:15:46.471: //75/000000000000/SIP/Error/sipSPIHandleAuthChallenge: Erro
r getting credentials
Jan  5 06:15:46.471: //75/000000000000/SIP/Error/ccsip_api_register_result_ind:
Message Code Class 4xx Method Code 100 received for REGISTER
Jan  5 06:15:46.487: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK553E4;received=67.244.22.49;rpo
rt=55401
From: <sip:777@184.75.215.106>;tag=21D64C-2213
To: <sip:777@184.75.215.106>;tag=as64f12544
Call-ID: 5D7B49E4-750311E3-80068DCA-1BEC8FC1
CSeq: 17 REGISTER
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="toronto.voip.ms", nonce="38da5d17
"
Content-Length: 0


Jan  5 06:15:46.487: //76/000000000000/SIP/Error/sipSPIHandleAuthChallenge: Erro
r getting credentials
Jan  5 06:15:46.487: //76/000000000000/SIP/Error/ccsip_api_register_result_ind:
Message Code Class 4xx Method Code 100 received for REGISTER
Jan  5 06:16:04.039: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_CC_CALL_SETUP
Jan  5 06:16:04.039: //78/AE5649BB8016/SIP/Error/sipSPI_ipip_set_history_info_he
ader: Not SIP2SIP mode
Jan  5 06:16:04.039: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_DNS_RESOLVE
Jan  5 06:16:04.495: //78/AE5649BB8016/SIP/Error/sipSPI_ipip_set_history_info_he
ader: Not SIP2SIP mode
SIP: (78) Group (a= group line) attribute, level 65535 instance 1 not found.
Jan  5 06:16:04.495: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:6478571234@toronto2.voip.ms:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK56225E
From: <sip:3001@184.75.215.106>;tag=221CE8-970
To: <sip:6478571234@toronto2.voip.ms>
Date: Sun, 05 Jan 2014 06:16:04 GMT
Call-ID: B0A9FE32-750711E3-801B8DCA-1BEC8FC1@67.244.22.49
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 2924890555-1963397603-2148961738-468488129
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIF
Y, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1388902564
Contact: <sip:3001@67.244.22.49:5060>
Expires: 180
Allow-Events: telephone-event
P-Preferred-Identity: <sip:3001@67.244.22.49>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 247

v=0
o=CiscoSystemsSIP-GW-UserAgent 5289 1466 IN IP4 67.244.22.49
s=SIP Call
c=IN IP4 67.244.22.49
t=0 0
m=audio 16640 RTP/AVP 0 101
c=IN IP4 67.244.22.49
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Jan  5 06:16:04.575: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK56225E;received=67.244.22.49;rp
ort=61743
From: <sip:3001@184.75.215.106>;tag=221CE8-970
To: <sip:6478574786@toronto2.voip.ms>
Call-ID: B0A9FE32-750711E3-801B8DCA-1BEC8FC1@67.244.22.49
CSeq: 101 INVITE
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
Session-Expires: 1800;refresher=uas
Contact: <sip:6478571234@184.75.215.114:5060>
Content-Length: 0


Jan  5 06:16:04.603: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK56225E;received=67.244.22.49;rp
ort=61743
From: <sip:3001@184.75.215.106>;tag=221CE8-970
To: <sip:6478571234>;tag=as1273359b
Call-ID: B0A9FE32-750711E3-801B8DCA-1BEC8FC1@67.244.22.49
CSeq: 101 INVITE
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
Session-Expires: 1800;refresher=uas
Contact: <sip:6478571234@184.75.215.114:5060>
Content-Type: application/sdp
Require: timer
Content-Length: 227

v=0
o=root 1146195306 1146195306 IN IP4 184.75.215.114
s=voip.ms
c=IN IP4 184.75.215.114
t=0 0
m=audio 12238 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=sendrecv

Jan  5 06:16:04.607: //78/AE5649BB8016/SIP/Error/sipSPIProcessNotifyCallInfoHead
er: Call-Info header with for Unsolicited Notify Absent,Disabling Unsolicited No
tifies
SIP: Attribute mid, level 1 instance 1 not found.
Jan  5 06:16:04.611: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:6478574786@184.75.215.114:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK571076
From: <sip:3001@184.75.215.106>;tag=221CE8-970
To: <sip:6478571234@toronto2.voip.ms>;tag=as1273359b
Date: Sun, 05 Jan 2014 06:16:04 GMT
Call-ID: B0A9FE32-750711E3-801B8DCA-1BEC8FC1@67.244.22.49
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0


Jan  5 06:16:10.087: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_CC_CALL_DISCONNECT
Jan  5 06:16:10.095: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
BYE sip:6478574786@184.75.215.114:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK5810E1
From: <sip:3001@184.75.215.106>;tag=221CE8-970
To: <sip:6478571234@toronto2.voip.ms>;tag=as1273359b
Date: Sun, 05 Jan 2014 06:16:04 GMT
Call-ID: B0A9FE32-750711E3-801B8DCA-1BEC8FC1@67.244.22.49
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
P-Preferred-Identity: <sip:3001@67.244.22.49>
Timestamp: 1388902570
CSeq: 102 BYE
Reason: Q.850;cause=16
Content-Length: 0


Jan  5 06:16:10.167: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK5810E1;received=67.244.22.49;rp
ort=61743
From: <sip:3001@184.75.215.106>;tag=221CE8-970
To: <sip:6478571234@toronto2.voip.ms>;tag=as1273359b
Call-ID: B0A9FE32-750711E3-801B8DCA-1BEC8FC1@67.244.22.49
CSeq: 102 BYE
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
Content-Length: 0


Jan  5 06:16:25.363: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f
rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER
Jan  5 06:16:25.363: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:184.75.215.106:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK59174
From: <sip:164479@184.75.215.106>;tag=226E6C-EAF
To: <sip:164479@184.75.215.106>
Date: Sun, 05 Jan 2014 06:16:25 GMT
Call-ID: 5C2C3512-750311E3-80028DCA-1BEC8FC1
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1388902585
CSeq: 24 REGISTER
Contact: <sip:164479@67.244.22.49:5060>
Expires:  200
Content-Length: 0


Jan  5 06:16:25.435: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK59174;received=67.244.22.49;rpo
rt=55401
From: <sip:164479@184.75.215.106>;tag=226E6C-EAF
To: <sip:164479@184.75.215.106>;tag=as10a00006
Call-ID: 5C2C3512-750311E3-80028DCA-1BEC8FC1
CSeq: 24 REGISTER
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="toronto.voip.ms", nonce="74baf3bc
"
Content-Length: 0


Jan  5 06:16:25.439: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:184.75.215.106:5060 SIP/2.0
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK5A15E5
From: <sip:164479@184.75.215.106>;tag=226E6C-EAF
To: <sip:164479@184.75.215.106>
Date: Sun, 05 Jan 2014 06:16:25 GMT
Call-ID: 5C2C3512-750311E3-80028DCA-1BEC8FC1
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1388902585
CSeq: 25 REGISTER
Contact: <sip:164479@67.244.22.49:5060>
Expires: 200
Authorization: Digest username="164479",realm="toronto.voip.ms",uri="sip:184.75.
215.106:5060",response="75c9d2d3fd90bc5fb51cebaa8fbf6212",nonce="74baf3bc",algor
ithm=MD5
Content-Length: 0


Jan  5 06:16:25.507: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 67.244.22.49:5060;branch=z9hG4bK5A15E5;received=67.244.22.49;rp
ort=55401
From: <sip:164479@184.75.215.106>;tag=226E6C-EAF
To: <sip:164479@184.75.215.106>;tag=as10a00006
Call-ID: 5C2C3512-750311E3-80028DCA-1BEC8FC1
CSeq: 25 REGISTER
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS
H
Supported: replaces, timer
Expires: 200
Contact: <sip:164479@67.244.22.49:5060>;expires=200
Date: Sun, 05 Jan 2014 06:24:47 GMT
Content-Length: 0

11 REPLIES
New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Update: Since the last posting.  I have contacted the voip.ms support.  As per their request i created a sub-account and configured only one dial-peer as opposed to multiple dial-peers.  They also suggested that i use .T digit manipulation method instead of the 10 digit digit manipulation i am used to.  It is still not working.  By now i am very frustrated.  Someone please help.

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Hello Nadir,

I may be able to assist. Please post or attach your 'show run' from the ISR 2800 you are using. Also, please post your 'show version'.

Thank you.

Jordan E

Cranbrook, BC

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Hi Jellasoncisco, Thanks a lot for repplying.  I am still having trouble.  Here is the info you requested.


dhcpRouter# show ver
Cisco IOS Software, 2800 Software (C2800NM-IPVOICE_IVS-M), Version 12.4(24)T2, R
ELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 19-Oct-09 17:38 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T7, RELEASE SOFTWARE (fc1)

dhcpRouter uptime is 18 hours, 13 minutes
System returned to ROM by reload at 00:36:40 zone Sun Jan 5 2014
System restarted at 00:38:49 Ontario Sun Jan 5 2014
System image file is "flash:c2800nm-ipvoice_ivs-mz.124-24.T2.bin"

Cisco 2821 (revision 53.51) with 249856K/12288K bytes of memory.
Processor board ID FTX0930A0DJ
2 Gigabit Ethernet interfaces
1 Channelized/Clear T1/PRI port
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
125440K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2142

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

encapsulation dot1Q 20

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

no cdp enable

!

interface GigabitEthernet0/1

ip address dhcp

ip nat outside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

no cdp enable

!

router rip

version 2

network 192.168.0.0

network 192.168.1.0

network 192.168.3.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 76.244.129.55

ip route 0.0.0.0 0.0.0.0 76.244.128.1

ip route 0.0.0.0 0.0.0.0 76.244.128.2

ip route 0.0.0.0 0.0.0.0 192.168.3.1

!

!

no ip http server

ip nat inside source list NAT_ADDRESSES interface GigabitEthernet0/1 overload

!

ip access-list extended NAT_ADDRESSES

permit ip 192.168.1.0 0.0.0.255 any

permit ip 192.168.3.0 0.0.0.255 any

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:1

output attenuation 0

echo-cancel coverage 64

!

!

!

!

!

dial-peer voice 1 voip

incoming called-number [2-9]..[2-9]......

dtmf-relay rtp-nte

no vad

!

dial-peer voice 777 voip

description TELEPHONY OFFICE-LINX

destination-pattern 777

session protocol sipv2

session target ipv4:192.168.1.21

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

fax rate disable

fax protocol pass-through g711ulaw

no vad

!

dial-peer voice 2 voip

preference 1

destination-pattern .T

session protocol sipv2

session target dns:toronto2.voip.ms

session transport udp

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

sip-ua

credentials username 164479_1234 password 7 01120D500C0A0D5B76 realm toronto.vo

ip.ms

authentication username 164479_1234 password 7 050A0D5B764D455D4E realm toronto

.voip.ms

mwi-server ipv4:192.168.1.21 expires 3600 port 5060 transport udp

registrar ipv4:184.75.215.106 expires 200

registrar ipv4:184.75.215.114 expires 3600 secondary

sip-server ipv4:184.75.215.106

host-registrar

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 20

max-dn 50

ip source-address 192.168.0.2 port 2000

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 1

number 3000

call-forward busy 777

call-forward noan 777 timeout 18

!

!

ephone-dn 2

number 3001

!

!

ephone-dn 5

number 777

!

!

ephone 1

mac-address 0011.2111.6AF4

!

!

!

ephone 2

mac-address 001A.2FE7.A4DB

button 1:1

!

!

!

ephone 3

mac-address 001A.E2BC.A32D

button 1:2

!

!

banner motd ^CC

Do not Log in^C

!

line con 0

line aux 0

line vty 0 4

exec-timeout 0 0

password ciscolove

logging synchronous

login

transport input telnet

line vty 5 15

exec-timeout 0 0

password ciscolove

logging synchronous

login

!

scheduler allocate 20000 1000

ntp master 1

ntp server 64.73.32.135

end

Ethernet interfaces

1 Channelized/Clear T1/PRI port

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

125440K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2142

dhcpRouter#

 

 

 

 

 

 

 

 

 

 

 

 

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Hi Nadir,

I looked over your configuration. I have a couple questions.

1) Are you testing the call out from phones that are registered to this ISR 2821?

2) If not, are you testing from phones connected on the other router listed as OFFICE-LINX?

3) When dialling out are you using an exit digit like "9" then your outgoing number? Please provide an example of a test number you are dialling that fails.

Thank you,

Jordan E

Cranbrook, BC

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Hello JellaSonCisco, How are you doing?  following are the answers to the questions

1) I am testing the calls from extensions configuared from the cisco 2800 router.  Thats the only router in the network.  The extensions are configured with the ephone-dn command in the router.( ie: ephone-dn 1 and ephone-dn 2).

2) Office-linx is a Voice mail and Collaboration services Server, i am sip trunking to that for voice mail and IVR.

3)i am not using an exit digit.  i am dialing straight 10 digits to my cell phone ( ie 6478571234)

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Still having issues.  I rebooted the router a  few times since my last update.  Really not sure what i am supposed to do right now.

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Hello Nadir,

I believe your issue may be related to the registration of your extension numbers and possible needing a domain in your configuration. Please adjust your configuration as per the below bold items and test. Please advise how it goes. Thanks. Jordan

ephone-dn 1

number 3000 no-reg both

call-forward busy 777

call-forward noan 777 timeout 18

!

!

ephone-dn 2

number 3001 no-reg both

New Member

CCME and VOIP.MS "this number has not yet been assigned" outboun

Hello Jellasoncisco, I have made the changes that you have suggested.  Stilll no go.  Do i need to configure a translation pattern?  do I need to get an incoming DID before it will work.  I am understanding why this is not working.  I dont have any sip bindings, actually my router doesnt even support dial-peer based bindings.  Anyways i am pasting the traces.  let me know what you think.  Thanks again.

Jan 9 02:51:32.295: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK2698126B;received=111.244.22.49;

rport=52249

From: <3000>;tag=E8A47C4-486

To: <>6471234567@toronto2.voip.ms>

Call-ID: C78EC292-780F11E3-81C6D3B5-3EBB58A@111.244.22.49

CSeq: 101 INVITE

Server: voip.ms

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS

H

Supported: replaces, timer

Session-Expires: 1800;refresher=uas

Contact: <6471234567>

Content-Length: 0

 

Jan 9 02:51:32.331: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK2698126B;received=111.244.22.49;

rport=52249

From: <3000>;tag=E8A47C4-486

To: <>6471234567@toronto2.voip.ms>;tag=as52f9246a

Call-ID: C78EC292-780F11E3-81C6D3B5-3EBB58A@111.244.22.49

CSeq: 101 INVITE

Server: voip.ms

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS

H

Supported: replaces, timer

Session-Expires: 1800;refresher=uas

Contact: <6471234567>

Content-Type: application/sdp

Require: timer

Content-Length: 227

v=0

o=root 2031959569 2031959569 IN IP4 184.75.215.114

s=voip.ms

c=IN IP4 184.75.215.114

t=0 0

m=audio 10496 RTP/AVP 0 101

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=sendrecv

Jan 9 02:51:32.331: //5538/C57B260D81C1/SIP/Error/sipSPIProcessNotifyCallInfoHe

ader: Call-Info header with for Unsolicited Notify Absent,Disabling Unsolicited

Notifies

SIP: Attribute mid, level 1 instance 1 not found.

Jan 9 02:51:32.339: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

ACK sip:6471234567@184.75.215.114:5060 SIP/2.0

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK261119D9

From: <3000>;tag=E8A47C4-486

To: <>6471234567@toronto2.voip.ms>;tag=as52f9246a

Date: Thu, 09 Jan 2014 02:51:32 GMT

Call-ID: C78EC292-780F11E3-81C6D3B5-3EBB58A@111.244.22.49

Max-Forwards: 70

CSeq: 101 ACK

Allow-Events: telephone-event

Content-Length: 0

 

Jan 9 02:51:36.539: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f

rom SIP SPI : SIPSPI_EV_CC_CALL_DISCONNECT

Jan 9 02:51:36.547: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

BYE sip:6471234567@184.75.215.114:5060 SIP/2.0

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269A84F

From: <3000>;tag=E8A47C4-486

To: <>6471234567@toronto2.voip.ms>;tag=as52f9246a

Date: Thu, 09 Jan 2014 02:51:32 GMT

Call-ID: C78EC292-780F11E3-81C6D3B5-3EBB58A@111.244.22.49

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

P-Preferred-Identity: <3000>

Timestamp: 1389235896

CSeq: 102 BYE

Reason: Q.850;cause=16

Content-Length: 0

 

Jan 9 02:51:36.935: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269A84F;received=111.244.22.49;r

port=52249

From: <3000>;tag=E8A47C4-486

To: <>6471234567@toronto2.voip.ms>;tag=as52f9246a

Call-ID: C78EC292-780F11E3-81C6D3B5-3EBB58A@111.244.22.49

CSeq: 102 BYE

Server: voip.ms

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS

H

Supported: replaces, timer

Content-Length: 0

 

 

Jan 9 02:51:51.623: %IPPHONE-6-REG_ALARM: 25: Name=SEP001AE2BCA32D Load=8.1(2.0

) Last=Initialized

Jan 9 02:51:51.627: %IPPHONE-6-REGISTER: ephone-3:SEP001AE2BCA32D IP:192.168.0.

15 Socket:1 DeviceType:Phone has registered.

Jan 9 02:52:19.931: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f

rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER

Jan 9 02:52:19.931: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

REGISTER sip:184.75.215.106:5060 SIP/2.0

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269B463

From: <164479_1234>;tag=E8B0224-2175

To: <164479_1234>

Date: Thu, 09 Jan 2014 02:52:19 GMT

Call-ID: 4CC161112-766411E3-8002D3B5-3EBB58A

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1389235939

CSeq: 2302 REGISTER

Contact: <164479_1234>

Expires: 200

Content-Length: 0

 

Jan 9 02:52:19.1115: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 401 Unauthorized

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269B463;received=111.244.22.49;r

port=56461

From: <164479_1234>;tag=E8B0224-2175

To: <164479_1234>;tag=as07088196

Call-ID: 4CC161112-766411E3-8002D3B5-3EBB58A

CSeq: 2302 REGISTER

Server: voip.ms

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS

H

Supported: replaces, timer

WWW-Authenticate: Digest algorithm=MD5, realm="toronto.voip.ms", nonce="5231e5d0

"

Content-Length: 0

 

Jan 9 02:52:19.1119: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

REGISTER sip:184.75.215.106:5060 SIP/2.0

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269C2CB

From: <164479_1234>;tag=E8B0224-2175

To: <164479_1234>

Date: Thu, 09 Jan 2014 02:52:19 GMT

Call-ID: 4CC161112-766411E3-8002D3B5-3EBB58A

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1389235939

CSeq: 2303 REGISTER

Contact: <164479_1234>

Expires: 200

Authorization: Digest username="164479_1234",realm="toronto.voip.ms",uri="sip:18

4.75.215.106:5060",response="05dbc605846b46f6ea2779ad23f8c118",nonce="5231e5d0",

algorithm=MD5

Content-Length: 0

 

Jan 9 02:52:20.079: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269C2CB;received=111.244.22.49;r

port=56461

From: <164479_1234>;tag=E8B0224-2175

To: <164479_1234>;tag=as07088196

Call-ID: 4CC161112-766411E3-8002D3B5-3EBB58A

CSeq: 2303 REGISTER

Server: voip.ms

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS

H

Supported: replaces, timer

Expires: 200

Contact: <164479_1234>;expires=200

Date: Thu, 09 Jan 2014 03:00:45 GMT

Content-Length: 0

 

Jan 9 02:52:59.315: //-1/xxxxxxxxxxxx/SIP/Event/sipSPIEventInfo: Queued event f

rom SIP SPI : SIPSPI_EV_OUTBOUND_REGISTER

Jan 9 02:52:59.315: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

REGISTER sip:184.75.215.114:5060 SIP/2.0

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269DADF

From: <164479_1234>;tag=E8B9BFC-2008

To: <164479_1234>

Date: Thu, 09 Jan 2014 02:52:59 GMT

Call-ID: 4CC2A1E1-766411E3-8003D3B5-3EBB58A

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1389235979

CSeq: 1023 REGISTER

Contact: <164479_1234>

Expires: 3600

Content-Length: 0

 

Jan 9 02:52:59.379: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 401 Unauthorized

Via: SIP/2.0/UDP 111.244.22.49:5060;branch=z9hG4bK269DADF;received=111.244.22.49;r

port=52249

From: <164479_1234>;tag=E8B9BFC-2008

To: <164479_1234>;tag=as7ccab778

Call-ID: 4CC2A1E1-766411E3-8003D3B5-3EBB58A

CSeq: 1023 REGISTER

Server: voip.ms

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLIS

H

Supported: replaces, timer

WWW-Authenticate: Digest algorithm=MD5, realm="toronto2.voip.ms", nonce="0d13920

8"

New Member

Did you find a solution to

Did you find a solution to this? I'm facing the same problem.

New Member

Re: Did you find a solution to

I know this is *way* late to the game, but having run into this issue and not found a resolution elsewhere, I figured I'd post to help the next person.

For me, calls would actually work for about a minute after my 2821 had registered with voip.ms, and if I made a call in that magic window, then I'd get another minute or so's grace, then the default behavior would revert.

Turns out it was my firewall killing off idle UDP sessions. I use pfsense, where the default timeout for UDP states is ~60 seconds. Increasing this to a few seconds above the expires value for the registrar in sip-ua fixed my issue

1294
Views
0
Helpful
11
Replies
CreatePlease to create content