Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CCNA Basi question....

Hi guys,

I know this is an easy question but i've had a brain dead moment and can't for the life of me seem to think of the answer:

I'm running a Catalyst 3550 in a lab environment and i've put in the following config:

switch(config)#int loopback0

switch(config-if)#ip address 172.100.16.1 255.255.240.0

switch(config-if)#no shut

line protocol on int loop0, changed to up

switch(config)#int loopback1

switch(config-if)#ip address 172.100.17.2 255.255.240.0

and then the following message comes up

172.100.16.0 overlaps with Loopback0

Now i know that they're both on the same subnet but i can't think why it's not allowing me to configure it. I know i'm missing something completely obvious - but... any help would be appreciated

10 REPLIES

Re: CCNA Basi question....

You can't have two interfaces (phy or logical) in the same subnet. Assign each a /32 subnet mask and it will work.

HTH and please rate.

Community Member

Re: CCNA Basi question....

You cannot configure two interfaces on the same router/switch in the same subnet.

Loopback0 and Loopback1 should be configured in different subnet.

you can use /32 or /24 or anything subnet mask that makes belong to different subnets:

switch(config)#int l0

switch(config-if)#ip address 172.100.16.1 255.255.255.0

switch(config-if)#int l1

switch(config-if)#ip address 172.100.17.2 255.255.255.0

Community Member

Re: CCNA Basi question....

That's excellent, thanks. I want to support the rating scheme but all that i see is reply and email this message. How do i rate posts? Also does that mean if i wanted to configure all 24/48 ports on a single switch they would all have to be in different subnets?

Re: CCNA Basi question....

Look for Rate This Post to the right :-)

You can configure the switch to support VLANs. Type 'show vlan; and it will show you what VLANs are configured and what ports are in which VLAN.

To create a new vlan:

Switch(config)# vlan 5

Switch(config-vlan)#exit

If you want to add a port to VLAN 5:

Switch(config)#interface fa0/1

Switch(config-if)#switchport access vlan 5

Look at the VLANs again (show vlan) and you should now see vlan 5 with port fa0/1 as a member. Now if you wanted the switch to be the layer 3 gateway you would configure a vlan interface (SVI). You must have a layer 3 image on the switch to do this.

Switch(config)# interface vlan 5

Switch(config-if)#ip address 192.168.5.254 255.255.255.0

HTH

Community Member

Re: CCNA Basi question....

I know that this sounds stupid but "rate this post" doesn't appear on my web-page. I've even enrolled one of my colleagues to come and have a look with me (to make sure i'm not going blind!) - it's just not there! All i see at the bottom is reply and email this message, the right of the screen is just blank. Please help - i think you deserve to be rated :)

Community Member

Re: CCNA Basi question....

You said:

if you wanted the switch to be the layer 3 gateway you would configure a vlan interface (SVI). You must have a layer 3 image on the switch to do this.

Is this just enabling the pc's on vlan 5 to communicate with each other without accessing the router or has it got a higher purpose? I thought that they'd be able to ping each other anyway as they're all in the same vlan.

Re: CCNA Basi question....

If you multiple PC's in the same VLAN (lets say vlan 5) they can ping each other without the gateway configured. Let's say you add another vlan (lets say vlan 6) and you want the PC's on VLAN 5 to talk to the PCs on VLAN 6, then you would have to configure the gateway on the switch for the PC's. It just provides a way for the PCs to get off their local LAN (vlan 5) and be able to talk to devices on other LANs (such as vlan 6). Does that make sense?

Community Member

Re: CCNA Basi question....

I wish i could rate you!! Every thing that you say and the way you explain it makes perfect sense. I'm making you a favourite!! Oh wait up, there's no favourite button either.....

Community Member

Re: CCNA Basi question....

I wish i could rate you!! Every thing that you say and the way you explain it makes perfect sense. I'm making you a favourite!! Oh wait up, there's no favourite button either.....

Does this mean though that i would have to then place an access list on the relevant router (if for example there were more than one vlan on the switch) if i wanted to only enable vlan's 5 and 6 to communicate but not vlan 7 or would i just not set the ip address on the switch as the default gateway. This would then mean that vlan 7 is not communicating through layer 3 switching and would have to pass traffic through the router. Correct?

Re: CCNA Basi question....

If you did not want vlan 7 to talk to vlan 5 & 6 ,but you did want to allow it to vlan 9, then you would need the access-list. If vlan 7 never need to talk to any other vlan, then you would not need to configure a gateway for that vlan. Layer 3 switching (the SVI) is the router! When we create that layer 3 SVI interface, were enabling a virtual routing interface. If we create 5 vlans with 5 SVI's, we've create 5 virtual routing interfaces. It's just like if we had a router that had 5 ethernet interfaces. As you can see, layer 3 switching is a very cool thing and saves us having to buy lots of routers and router interfaces.

SVI: Switch Virtual Interface

249
Views
20
Helpful
10
Replies
CreatePlease to create content