Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Changing Port-Channel MTU to match jumbo frames

Having an issue on a 3750 stack where we've enabled Jumbo frames for the gigabit interfaces and now I want to configure a WLC5508 to etherchannel to the 3750.  I've gone through and created the Port-Channel interface but I when I add the member Gigabit interfaces, I get a log message that the MTU's are different between the Gi and Po interfaces.  If I check the Gi interfaces I can see the MTU is set to 9000.  The Po interface is set to 1500 MTU.  I've not found a way of increasing this MTU on the Po interface.  Any suggestions?

Everyone's tags (2)
8 REPLIES
VIP Super Bronze

Re: Changing Port-Channel MTU to match jumbo frames

Hi Nathan,

With 3750s the MTU command is global not per interface and you should not need to increase the MTU on the Etherchannel.  After you enable the jumbo frame you need to reboot the switch in order for it to take effect.  Have you already done this.

HTH

Reza

Community Member

Re: Changing Port-Channel MTU to match jumbo frames

Yes, we've already completed the reboot of the switch following the mtu change.

A 'sh system mtu' reports the following:

System MTU size is 1500 bytes
System Jumbo MTU size is 9000 bytes

Re: Changing Port-Channel MTU to match jumbo frames

Yes, we've already completed the reboot of the switch following the mtu change.

A 'sh system mtu' reports the following:

System MTU size is 1500 bytes
System Jumbo MTU size is 9000 bytes

Hi Nathan,

As per the output switch has taken the mtu size for default value 1500 and Jumbo frame vlaue 9000.Gigabit Ethernet ports are not affected by the system mtu command; 10/100 ports are not affected by the system mtu jumbo command. If you do not configure the system mtu jumbo command, the setting of the system mtu command applies to all Gigabit Ethernet interfaces. All Gigabit Ethernet interfaces support jumbo frames up to 9000 bytes

Hope to Help !!

Ganesh.H

VIP Super Bronze

Re: Changing Port-Channel MTU to match jumbo frames

As I mentioned before you do not need to raise the MTU size on the Portchannel itself.  The portchannel MTU will increase when you issue the global command to raise the MTU size.

Have a look at this config from a 3750:

Switch-B#sh sys mtu

System MTU size is 1500 bytes
System Jumbo MTU size is 9000 bytes
Routing MTU size is 1500 bytes
Switch-B#

Switch-B#sh run in po44   
Building configuration...

Current configuration : 113 bytes
!
interface Port-channel44
no switchport
ip vrf forwarding cust-a
ip address 220.220.220.1 255.255.255.0
end

Switch-B#sh run int gi1/0/1
Building configuration...

Current configuration : 122 bytes
!
interface GigabitEthernet1/0/1
no switchport
no ip address
channel-group 44 mode active
spanning-tree portfast
end

Switch-B#sh interfaces po44
Port-channel44 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0023.eb14.2e41 (bia 0023.eb14.2e41)
  Internet address is 220.220.220.1/24
MTU 9000bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/0/1
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     72544 packets input, 7510324 bytes, 0 no buffer
     Received 39478 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 39476 multicast, 0 pause input
     0 input packets with dribble condition detected
     72668 packets output, 7523337 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Switch-B#

HTH

Reza

Community Member

Re: Changing Port-Channel MTU to match jumbo frames

Thanks for the update.  I was guessing that's how things should run.  Here's where I'm at atm:

#sh log

*Jun 22 10:16:30: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/16, changed state to down
*Jun 22 10:16:30: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/17, changed state to down
*Jun 22 10:16:33: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/16, changed state to up
*Jun 22 10:16:33: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/17, changed state to up
*Jun 22 10:16:34: %EC-5-CANNOT_BUNDLE2: Gi3/0/16 is not compatible with Po1 and will be suspended (MTU of Gi3/0/16 is 9000, Po1 is 1500) (Core-SW001-3)
*Jun 22 10:16:34: %EC-5-CANNOT_BUNDLE2: Gi3/0/17 is not compatible with Po1 and will be suspended (MTU of Gi3/0/17 is 9000, Po1 is 1500) (Core-SW001-3)

#sh run int po1:

interface Port-channel1
description WLC PortChannel
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport mode trunk
end

#sh int po1

Port-channel1 is down, line protocol is down (notconnect)
  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
  Description: WLC PortChannel
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Auto-duplex, Auto-speed, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported

#sh run int gi3/0/16

interface GigabitEthernet3/0/16
description WLC Interface
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport mode trunk
channel-group 1 mode on
spanning-tree portfast
end

#sh int gi3/0/16

GigabitEthernet3/0/16 is up, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 0016.4673.6710 (bia 0016.4673.6710)
  Description: WLC Interface
  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

The only thing of note at the moment with this switch is that it's stopped responding to ssh or telnet and we're having to manage the unit via the http interface.  We're trying to establish a reboot time for the switch which may have to come sooner if this might resolve the issue.

Community Member

Re: Changing Port-Channel MTU to match jumbo frames

how'd you go , im having the same issue of not being able to enable jumbo frames on giga port but with a 7200

Community Member

Re: Changing Port-Channel MTU to match jumbo frames

That's all good.

The root issue I'm having though, is that since I've enabled jumbo frames on the gigabit ports, I'm not able to setup a port channel.  The MTU's are different between the Po interface (1500) and the Gi interfaces (9000).  Is there a way to get the Po interface to have and MTU of 9000 and allow me to get the Po interface to be up/up?

Re: Changing Port-Channel MTU to match jumbo frames

Hi,

Following are the consideration and configuring Jumbo frames can be

enabled on interfaces configured for port-channel protocols. The following

are some of the guidelines or restrictions:

  • All the ports in a port-channel must have the same MTU.

  • Changing the MTU of a port-channel interface changes the MTU of all

member ports.

  • If the MTU of a member port cannot be changed to the new value due

to the member port being the blocking port, the port-channel is suspended

.

  • A port cannot join a port-channel if it has a different MTU than the

others in the existing port-channel.

  • If an individual member port's MTU is changed, the port is

suspended.

Hope to help !!

Ganesh.H

Remember to rate the helpful post

18414
Views
5
Helpful
8
Replies
CreatePlease to create content