Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 1721

Ok,  Im new here and somewhat new to Cisco Routers.  I have used them before, but not for an actual live enviornment.  I happen to have the fortune of my workplace giving me a Cisco 1721 for my personal use.  I have a WIC-1ENET card for internet access and a switch with about 10 pcs attached to it.  I am unable to have any PC get on the internet but, can see other Computers perfectly fine.  The router can ping ip addresses and websites.  I am hoping that with the information below, someone can tell me where I configured it incorrectly.  The ISP is a Cable internet provider and the IP address is assigned Dynamicly to me.  I am not sure if the WIC-1ENET card and use cable internet, but it seems to just be a routing issue between the LAN and WAN.    Thank you in advance

C1721>ping google.com
Translating "google.com"...domain server (68.113.206.10) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 74.125.227.51, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms

C1721#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 97.94.208.1 to network 0.0.0.0

     68.0.0.0/32 is subnetted, 1 subnets
S       68.114.37.166 [254/0] via 97.94.208.1, Ethernet0
     97.0.0.0/22 is subnetted, 1 subnets
C       97.94.208.0 is directly connected, Ethernet0
     10.0.0.0/27 is subnetted, 1 subnets
C       10.10.1.0 is directly connected, FastEthernet0
S*   0.0.0.0/0 [254/0] via 97.94.208.1


C1721#sh int eth0
Ethernet0 is up, line protocol is up
  Hardware is PQUICC Ethernet, address is 0004.dd0c.0633 (bia 0004.dd0c.0633)
  Internet address is 97.94.209.XXX/22
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Half-duplex, 10BaseT
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 5000 bits/sec, 11 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4052 packets input, 258910 bytes, 0 no buffer
     Received 4046 broadcasts, 0 runts, 0 giants, 0 throttles
     1 input errors, 0 CRC, 0 frame, 1 overrun, 0 ignored
     0 input packets with dribble condition detected
     84 packets output, 9197 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 1 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out


C1721# sh run
Building configuration...

Current configuration : 1001 bytes
!
! Last configuration change at 12:20:31 CST Sat Nov 13 2010
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C1721
!
boot-start-marker
boot-end-marker
!
enable password *******
!
clock timezone CST -5
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.10.1.2 10.10.1.5
!
ip dhcp pool Default
   network 10.10.1.0 255.255.255.224
   dns-server 68.113.206.10 24.217.0.5
   netbios-name-server 10.10.1.3
   default-router 10.10.1.24
   domain-name Cisco1721
!
no ftp-server write-enable
!
!
!
!
interface Ethernet0
ip address dhcp
full-duplex
!
interface FastEthernet0
ip address 10.10.1.24 255.255.255.224
speed auto
full-duplex
!
ip default-gateway 10.10.1.24
ip classless
ip route 10.10.1.0 255.255.255.224 FastEthernet0
ip http server
!
!
line con 0
line aux 0
line vty 0 4
password ********
login
!
end

C1721#

Everyone's tags (3)
7 REPLIES
Hall of Fame Super Silver

Re: Cisco 1721

David

There are a couple of things that puzzle me in the config that you posted, such as the fact that your show ip route shows a static default route, but there is no static default route in the config. But if it shows up in the routing table, and especially if you are able to ping Google from the router, then it is not a problem.

The big problem is that you are not translating the address of traffic from your inside network as it goes out to the internet. With source addresses in the 10.10.1.0 network you need to translate those addresses as they go to the Internet. The config that you need might look something like this"

interface FastEthernet0

ip nat inside

interface Ethernet0

ip nat outside

access-list 10 permit 10.10.1.0 0.0.0.31

ip nat inside source list 10 interface FastEthernet0 overload

HTH

Rick

Hall of Fame Super Blue

Re: Cisco 1721

David

Just a quick note

ip nat inside source list 10 interface FastEthernet0 overload

think Rick meant to put -

ip nat inside source list 10 interface Ethernet0 overload

Jon

Purple

Re: Cisco 1721

@ richard: he is getting the default route from the DHCP server of ISP, no ?

Regards.

Don't forget to rate helpful posts.
New Member

Re: Cisco 1721

Re: Cisco 1721

Thanks,

~ Raj ~

Hall of Fame Super Silver

Re: Cisco 1721

Jon

Thanks for catching my mistake. I certainly did mean to overload on the outside interface and not on the inside interface. (+5)

It is likely that the router is learning the default route via DHCP. But I would not expect it to show up as a static route if it is dynamically learned. And to get the router to use it in its routing table I would have expected to find something like ip route 0.0.0.0 0.0.0.0 dhcp. But as I said in my original post, the router clearly has successful connectivity and is able to ping resources in the Internet, so obviously the routing question is not the problem.

HTH

Rick

Purple

Re: Cisco 1721

Richard,

I've  just labbed it on another platform  and I got the same static route in the rib when allocating the default-router in dhcp pool.

Regards.

Alain.

Don't forget to rate helpful posts.
Hall of Fame Super Silver

Re: Cisco 1721

Alain

Thanks for giving us independent verification that this does work. And that it does show up in the route table as a static route. (+5)

HTH

Rick

1437
Views
10
Helpful
7
Replies
CreatePlease to create content