Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Cisco 1801/k9 + NAT on the FE0 WAN interface

Hello

I have recently gotten a new 1801 to use at Home to terminate my cable broadband but I cannot seem to get the PCs connected to the switch ports to access the internet.

The NAT configuration I have done is:

WAN interface:

interface FastEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

VLAN interface for the switch:

interface Vlan1

description OLD PRIMARY VLAN

ip address 192.168.1.2 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

NAT config:

ip nat pool NAT_POOL_OLD 192.168.1.10 192.168.1.254 netmask 255.255.255.0

ip nat inside source list 1 pool NAT_POOL_OLD overload

ACL:

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 deny any

Can you see any issues with my NAT config that would stop my users accessing the internet?

I've attached my running config for more info.

Can anyone offer any help?

Thanks

10 REPLIES

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

no ip nat pool NAT_POOL_OLD 192.168.1.10 192.168.1.254 netmask 255.255.255.0

no ip nat inside source list 1 pool NAT_POOL_OLD overload

no access-list 1

access-list 1 deny host 192.168.1.2

access-list 1 permit 192.168.1.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet0 overload

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

Thanks A lot, I have made the changes and I will take it home tonight and try it out.

:)

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

Hi, This didn't work for me, I was trying to figure it out myself and I messed up. So I reloaded the router here is the new config. Can anyone advise what I am missing to get my internet connection working? I have a cable modem attached to the fa0 and a laptop connected to a switch port. I have gotten the Router to assign a DHCP address but I get no action from the internet. Can anyone advise??

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

did you get ip address from dhcp srerver for fastethernet0?

sh ip int brief

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

Hi, no I didn't it says unassigned. What could this mean?

Am I missing a configuration command or is my provider not doing something?

Thanks

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

show the output

"show interface f0"

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

I use an 1803 to terminate my cable modem at home and it works perfectly, when I get home i'll post the interface config.

I use mine with telstra bigpond 30/1 cable with a motorolla surfboard.

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

Thanks.

Output of my show int fa 0 is:

show int fa 0

FastEthernet0 is up, line protocol is up

Hardware is PQ3_TSEC, address is 001d.70f9.b77e (bia 001d.70f9.b77e)

Internet address will be negotiated using DHCP

MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

38 packets output, 8474 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Any ideas? It doesn't lok like its getting an address via dhcp. Am I missing some config? The Int fa 0 config is:

ip address dhcp

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

thats it.

Thanks for your help!

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

what cable modem are you using it with?

New Member

Re: Cisco 1801/k9 + NAT on the FE0 WAN interface

Hi Guys

I have been through a bit old config refresh.

I have managed to get my dhcp to work buy adding the ip dhcp client client-ID fa 0

Command but I still cant access the internet :( I will check what cable modem I have when I get home.

My Show run as it stands is attached. I know the FA0 is shutn down but thats not the prob because I only have that while I'm at work.

If anyone can sugegst why its not working that would be great.

Sirdudley are you able to post your config so i can compare?

Cheers!

722
Views
0
Helpful
10
Replies
CreatePlease to create content