Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 1811 behind Comcast Cable DHCP

Hello all,

I just got Comcast internet with dynamic ip. I am installing cisco 1811 behind the comcast modem. But I cannot send the traffic out. I tried with and w/o BVI option in 1811 but still does not work. Does anyone have any suggestion?

Here are some basical config:

int fas 0

ip add dhcp

ip nat outside

int vlan 1

ip add 192.168.0.1 255.255.255.0

ip nat inside

ip nat inside source route-map NoNat interface fas 0 overload

ip access-list extended NATList

deny ip 192.168.0.0 0.0.0.255 10.0.0.0 0.255.255.255

deny ip 192.168.0.0 0.0.0.255 172.16.0.0 0.15.255.255

deny ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.255.255

permit ip 192.168.0.0 0.0.0.255 any

!

!

route-map nonat permit 10

match ip address NATList

ip route 0.0.0.0 0.0.0.0 FastEthernet0 name DefaultRouteToComcast

I called Comcast; they said the modem only allows one config and they don't know how to config anything behind the modem other than PCs.

Any help will be greatly apprecated!

thanks,

Gene

7 REPLIES
Community Member

Re: Cisco 1811 behind Comcast Cable DHCP

first off. Is the FAS interface getting a DHCP Address from comcast?

Re: Cisco 1811 behind Comcast Cable DHCP

When you plug your PC into the modem, does it get a public or private IP address?

Community Member

Re: Cisco 1811 behind Comcast Cable DHCP

Public Address.

If I use router's fe 0 dhcp, I am getting completed different class of public ip than PC gets.

thanks,

Re: Cisco 1811 behind Comcast Cable DHCP

Once you plug in the router and get an IP, can you ping the default gateway?

Community Member

Re: Cisco 1811 behind Comcast Cable DHCP

Don't know the default gateway if I use router. The ip I am getting is like 24.x.x.x different than the IP I am getting from PC 74.x.x.x. If I hard code the 74.x.x.x and default gateway into router fe interface and setup the default route, then I can ping.

thanks,

Re: Cisco 1811 behind Comcast Cable DHCP

OK, let's move forward and address that later. Can the router ping an internet address like 4.2.2.2? If yes, can the router ping it when you source from the LAN side?

Community Member

Re: Cisco 1811 behind Comcast Cable DHCP

No, cannot even ping anything outside before the extended ping.

801
Views
0
Helpful
7
Replies
CreatePlease to create content