Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

Hello, this is my first post and I have been banging my head against a wall for days trying to figure out this issue. I have a Cisco 1841 running the latest ROMMON 12.4(13r)T5 and IOS ADVIPSERVICESK9-M 15.1(4)M6. Via CLI (I'm studying for CCNA and despise GUIs anyway) I have configured a basic single NAT'd, DHCP setup. Topology: {ISP} --> {Motorola SB6141} --> Fa0/0 {Cisco 1841} Fa0/1 --> {My Mac}. For the internetwork, all connections are Cat5E/Cat6. I know that the 1841 is not a powerful device, but that in ideal situations it should be able to support 38 Mbps or 4.75 MBps.

Situation: When the SB6141 is plugged directly into my Mac, I see the rated throughput of 50/10 Mbps. When the 1841 enters the equation, I only get 1.4 MB/s up and down. What I've tried: SB6141 doesn't have a way of configuring it AFAIK, but the Fa0/0 port it connects to is set to auto speed and auto duplex. A sh int fa0/0 shows that it has negotiated full-duplex and 100Mb/s. Fa0/1 is auto speed and auto duplex and in either topology it negotiates to full-duplex and 100Mb/s. I have tried manually setting both interfaces to full/100 and that made no difference. When a download hits the 1.4 MB/s mark, brief or sustained, the sh cpu process history for the 1841 shows that it is maxing out at 100%. I have OSPF running, but I had the same issue prior to incorporating that. Here is my config:

Elway#sh run

Building configuration...

Current configuration : 2033 bytes

!

! Last configuration change at 21:34:11 UTC Fri Jan 31 2014 by XXX

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Elway

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

dot11 syslog

no ip source-route

!

!

ip dhcp excluded-address 10.0.24.1 10.0.24.50

!

ip dhcp pool mileHIGH

import all

network 10.0.24.0 255.255.255.0

default-router 10.0.24.1

dns-server 75.75.75.75 75.75.76.76

!

!

!

ip cef

ip domain name XXX

ip name-server 75.75.75.75

ip name-server 75.75.76.76

ip name-server 8.8.8.8

no ipv6 cef

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO1841 sn FTX0905W15R

archive

log config

  hidekeys

username XXX privilege 15 secret 4 XXX

!

redundancy

!

!

ip tcp synwait-time 10

!

!

!

!

!

!

!

interface FastEthernet0/0

description Comcast-Link

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip nat outside

ip virtual-reassembly in

no ip route-cache

ip tcp adjust-mss 1452

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

description LAN

ip address 10.0.24.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly in

no ip route-cache

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1/0

no ip address

shutdown

!

router ospf 1

network 10.0.24.0 0.0.0.255 area 0

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

!

ip nat inside source list 1 interface FastEthernet0/0 overload

!

access-list 1 permit 10.0.24.0 0.0.0.255

!

!

!

!

!

!

control-plane

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

login local

line aux 0

line vty 0 4

login local

transport input ssh

line vty 5 15

login local

transport input ssh

!        

scheduler allocate 20000 1000

end

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

Hi,

Try removing all statements from your Fa interfaces except the IP address and NAT statements an see what happens. You can also leave the tcp mss adjust as it only involves the tcp 3-way handshake and shouldn't cause every packet to be inspected.
You need to avoid CPU involvement a such as possible on this platform.

Regards,
Erik

Sent from Cisco Technical Support iPad App

5 REPLIES
New Member

Re: Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

Sounds like you may have mtu issues punting the traffic to CPU. I see you have tcp mss set on the Comcast link. I think what is occurring may be your LAN being 1500MTU and as it hits your WAN the traffic is fragmented to 1452 (something done in CPU).

Have you tried removing that mss setting or changing mtu on your PC to limit fragmentation via your router?

Sent from Cisco Technical Support iPad App

Bronze

Re: Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

Hi,

Try removing all statements from your Fa interfaces except the IP address and NAT statements an see what happens. You can also leave the tcp mss adjust as it only involves the tcp 3-way handshake and shouldn't cause every packet to be inspected.
You need to avoid CPU involvement a such as possible on this platform.

Regards,
Erik

Sent from Cisco Technical Support iPad App

Re: Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

Take ip virtual assembly out. Should be better then.

Sent from Cisco Technical Support iPad App

New Member

Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

Hi Erik,

Thanks for your response. I did as you recommended and slowly pieced things back together. I discovered that the "ip flow" entries on both interfaces were causing packets to go from CEF/fast switched to process switched for some reason, maxing out the CPU. I managed to get the 1841 to handle the rated 60/10Mbps after that - it even maintained close speeds after applying a standard auto secure CBAC (IOS Classic Firewall).

Thanks to everybody for their tips!

Take care,

Jordan

Bronze

Cisco 1841 Max 1.5MB/s between Fa0/0 and Fa0/1

You're welcome

718
Views
10
Helpful
5
Replies