Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

I am really new in this world , I have already read some CCNA BOOKS , but I would like to archive , does NOT work.

I try to create a table with MAC addresses that will distribute a IP ADDRESS.

My DHCP network is OK , but when I add

ARP AAAA.BBBB.CCCC 192.168.1.10 ARPA

it does not work.

Can one of yo guide me ?

Thank you in advance for your help

Best Regards,

Didier

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

you find info here: http://www.cisco.com/en/US/docs/ios/12_0t/12_0t1/feature/guide/Easyip2.html#wp23682

Regards.

Don't forget to rate helpful posts.
10 REPLIES
New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

I was a little bit to fast when I write this in the forum , but I presume you knew what I mean , I mean this :

ARP 192.168.1.10 AAAA.BBBB.CCCC ARPA

I have read on some other forums that I have to add a 1 in front of the MAC address , but this does not change anything.

I have tried to put the IP address in the range of my DHCP POOL and OUT of the RANGE , no change

Is their something that I have to add in my config ?

Thank you again for your help

Best Regards,

Didier.

New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

Can someone tell me what I do wrong ?

I have a NAS SERVER , but instead putting a FIX IP in the NAS , I would like to tell DHCP to use IP 192.168.1.10 when he receive its MAC ADDRESS.

How can I do / solve this ?

Thank You in advance for your help.

Best Regards,

Didier.

Purple

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hi,

You have to create a new pool for this client and if it's a linux machine then

use host command to give the ip address and hardware-address "mac address of client" or  client-id "id of machine" where id= modified mac as you said above.

Regards.

Don't forget to rate helpful posts.
New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

Thank you for this information , do you know where I can find some working example ?

Best Regards,

Didier

Purple

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

you find info here: http://www.cisco.com/en/US/docs/ios/12_0t/12_0t1/feature/guide/Easyip2.html#wp23682

Regards.

Don't forget to rate helpful posts.
New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

Thank You , this is what I was looking for

Best Regards,

Didier.

New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

I am still struggling with this , I have try many things :

Including the FIX IP in the EXCLUDE RAGE

ip dhcp excluded-address 192.168.100.1 192.168.100.99


or changing the IP EXCLUDE RANGE from 192.168.100.99 to 192.168.100.9 , so the FIX IP's are NOT IN the EXCLUDED RANGE , but still it does not work.

The 2 products that I am struggling with are :

A QNAP NAS SERVER (I THINK IT IS RUNNING ON LINUX)

And my MAC BOOK PRO

Both of them receive a IP from the DHCP SERVER and work well , but NOT with the IP that I would like to give them.

MAC BOOK PRO = 192.168.100.20 is 192.168.100.100

QNAP NAS SERVER = 192.168.100.66 is 192.168.100.101

Here bellow the script and DHCP and ARP information :

IP address          Client-ID/     Lease expiration        Type

    Hardware address/

    User name

192.168.100.20      0100.2241.353f.5e       Infinite                Manual

192.168.100.66      0008.9bad.178f          Infinite                Manual

192.168.100.100     0100.2241.353f.5e       Dec 02 2010 03:28 PM    Automatic

192.168.100.101     0100.089b.ad17.8f       Dec 02 2010 03:31 PM    Automatic

ROUTER1841#sh ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  81.164.200.1            0   0030.b8c1.f600  ARPA   FastEthernet0/0
Internet  81.164.201.195          -   0024.c4eb.6600  ARPA   FastEthernet0/0
Internet  81.164.202.42          25   0018.39ce.d5ae  ARPA   FastEthernet0/0
Internet  192.168.10.1            -   0024.c4eb.6600  ARPA   Vlan10
Internet  192.168.20.1            -   0024.c4eb.6600  ARPA   Vlan20
Internet  192.168.30.1            -   0024.c4eb.6600  ARPA   Vlan30
Internet  192.168.40.1            -   0024.c4eb.6600  ARPA   Vlan40
Internet  192.168.100.1           -   0024.c4eb.6601  ARPA   FastEthernet0/1
Internet  192.168.100.10         17   0022.4135.3f5e  ARPA   FastEthernet0/1
Internet  192.168.100.100        13   0022.4135.3f5e  ARPA   FastEthernet0/1
Internet  192.168.100.101         1   0008.9bad.178f  ARPA   FastEthernet0/1

!

! Last configuration change at 15:22:19 gmt+1 Sat Nov 27 2010 by admin

! NVRAM config last updated at 15:19:34 gmt+1 Sat Nov 27 2010 by admin

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ROUTER1841

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable password 7 05080F1C2243

!

aaa new-model

!

!

aaa authentication banner

THIS SYSTEM IS SOLELY FOR USE OF AUTHORISED USERS FOR OFFICIAL PURPOSES

!

!

aaa session-id common

clock timezone gmt+1 1

clock summer-time gmt+2 recurring last Sun Mar 2:00 last Sun Oct 3:00

dot11 syslog

no ip source-route

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.10.1

ip dhcp excluded-address 192.168.20.1

ip dhcp excluded-address 192.168.30.1

ip dhcp excluded-address 192.168.40.1

ip dhcp excluded-address 192.168.100.1 192.168.100.99

!

ip dhcp pool internal

   network 192.168.100.0 255.255.255.0

   default-router 192.168.100.1

   dns-server 192.168.100.1

   lease 5

!

ip dhcp pool vlan10

   import all

   network 192.168.10.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.10.1

   lease 5

!

ip dhcp pool vlan20

   network 192.168.20.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.20.1

   lease 5

!

ip dhcp pool vlan30

   network 192.168.30.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.30.1

!

ip dhcp pool vlan40

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.1

   dns-server 192.168.40.1

!

ip dhcp pool FIX-IP

   host 192.168.100.66 255.255.255.0

   hardware-address 0008.9bad.178f ieee802

   client-name FIX-IP

!

ip dhcp pool TEST

   host 192.168.100.20 255.255.255.0

   hardware-address 0100.2241.353f.5e ieee802

!

!

no ip bootp server

ip domain name dri.be

ip ddns update method DynDNS

HTTP

  add http://dri66:d@members.dyndns.org/nic/update?system=dyndns&hostname=cisco1841.dyndns.info&myip=d@members.dyndns.org/nic/update?system=dyndns&hostname=cisco1841.dyndns.info&myip=

interval maximum 1 0 0 0

interval minimum 1 0 0 0

!

multilink bundle-name authenticated

!

crypto pki trustpoint TP-self-signed-29

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-29

revocation-check none

rsakeypair TP-self-signed-29

!

!

!

username Admin privilege 15 secret

username Homer privilege 15 password

archive

log config

  hidekeys

!

!

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh port 8096 rotary 1

ip ssh version 2

!

!

!

interface FastEthernet0/0

description DMZ

ip ddns update hostname cisco1841.dyndns.info

ip ddns update DynDNS

ip address dhcp

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description INTERNAL$ETH-LAN$

ip address 192.168.100.1 255.255.255.0

no ip proxy-arp

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0/0

switchport access vlan 10

!

interface FastEthernet0/0/1

switchport access vlan 20

!

interface FastEthernet0/0/2

switchport access vlan 30

!

interface FastEthernet0/0/3

switchport access vlan 40

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan30

ip address 192.168.30.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan40

ip address 192.168.40.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

ip http secure-server

ip dns server

ip nat inside source list 101 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.100.10 80 81.164.200.35 8095 extendable

!

access-list 101 permit ip 192.168.100.0 0.0.0.255 any

access-list 101 permit ip 192.168.10.0 0.0.0.255 any

access-list 101 permit ip 192.168.20.0 0.0.0.255 any

access-list 101 permit ip 192.168.30.0 0.0.0.255 any

access-list 101 permit ip 192.168.40.0 0.0.0.255 any

no cdp run

!

!

!

control-plane

!

!

banner exec

WELCOME YOU ARE NOW LOGED IN

banner login

WARNING !!!

IF YOU ARE NOT :

Didier Ribbens

Please Leave NOW !!!

YOUR IP and MAC address will be LOGGED !!!

!

line con 0

speed 115200

line aux 0

line vty 0 4

access-class 5 in

privilege level 15

rotary 1

transport input telnet ssh

line vty 5 15

access-class 5 in

rotary 1

!

scheduler allocate 20000 1000

ntp clock-period 17178455

ntp server 66.27.60.10

end

Purple

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

192.168.100.20      0100.2241.353f.5e       Infinite                Manual
192.168.100.66      0008.9bad.178f          Infinite                Manual
192.168.100.100     0100.2241.353f.5e       Dec 02 2010 03:28 PM    Automatic
192.168.100.101     0100.089b.ad17.8f       Dec 02 2010 03:31 PM    Automatic
ip dhcp excluded-address 192.168.100.1 192.168.100.99
ip dhcp pool FIX-IP
   host 192.168.100.66 255.255.255.0
   hardware-address 0008.9bad.178f ieee802
   client-name FIX-IP
ip dhcp pool TEST
   host 192.168.100.20 255.255.255.0
   hardware-address 0100.2241.353f.5e ieee802

You are excluding from 100.1 to 100.99 which includes your .66 and .20 so just exclude 100.1 and second change your hardware-address for FIX IP

Regards.

Don't forget to rate helpful posts.
New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

Hello,

Just to let you know that the problem is solved

In case someone has the same problem I will explain what I did :

First , like CADETALAIN recommended me I have change the DHCP RANGE.

When this was done , nothing was changed I still have a IP from my DHCP SERVER , but NOT the one that I ask for.

After reading and GOOGLELING , I found some other interesting information :

I changed from HARDWARE-ADDRESS to CLIENT-IDENTIFIER , this did not help yet , but when I moved the DHCP SERVER :

ip dhcp pool internal

   network 192.168.100.0 255.255.255.0

   dns-server 192.168.100.1

   default-router 192.168.100.1

From TOP to bellow the FIX-IP , BOTH MAC / IP where working OK.

Is this a BUG in c1841-spservicesk9-mz.124-15.T12.bin ?

Here bellow a copy of the working MAC to FIX-IP :

Best Regards and thanks to ALL OF YOU for your HELP,

Didier.

ip dhcp excluded-address 192.168.10.1

ip dhcp excluded-address 192.168.20.1

ip dhcp excluded-address 192.168.30.1

ip dhcp excluded-address 192.168.40.1

ip dhcp excluded-address 192.168.100.1

!

ip dhcp pool vlan10

   import all

   network 192.168.10.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.10.1

   lease 5

!

ip dhcp pool vlan20

   network 192.168.20.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.20.1

   lease 5

!

ip dhcp pool vlan30

   network 192.168.30.0 255.255.255.0

   dns-server 8.8.8.8

   default-router 192.168.30.1

!

ip dhcp pool vlan40

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.1

   dns-server 192.168.40.1

!

ip dhcp pool FIX-IP

   host 192.168.100.66 255.255.255.0

  client-identifier 0100.089b.ad17.8f

   client-name FIX-IP

!

ip dhcp pool TEST

   host 192.168.100.20 255.255.255.0

   client-identifier 0100.2241.353f.5e

!

ip dhcp pool internal

   network 192.168.100.0 255.255.255.0

   dns-server 192.168.100.1

   default-router 192.168.100.1

!

!

New Member

Re: CISCO 1841 ROUTER MAC ->IP TABLE ?

PROBLEM IS SOLVED

THANK YOU ALL FOR YOUR GREAT HELP,

Best Regards,

Didier

2324
Views
0
Helpful
10
Replies
CreatePlease to create content