Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 1900 Series SNMP query returns same value on InOctet

Hi, sorry if I post this in the wrong community. Please redirect me to the correct community if this is the wrong one.

I'm developing a SNMP Monitor for my company. I've done it before, and that is why I'm not sure why I have the behavior, and because I'm not a network engineer, I'm not a 100% sure where to go and trouble shoot the problem.

I'm requesting OID 1.3.6.1.2.1.2.2.1.10 (In Octets for an interface) and I receive a value. However, If I request it again 5 seconds later, I get exactly the same value, but 5 seconds later there is movement. If I request it every 10 seconds, there is movement all the time. (I do request the Out Octets as well, and experience the same behavior)

If I log on to the router and I run sh int fastEthernet 0/0/0 the input bytes changes every time time like I expect.

At my previous company I did a similar monitor, and I requested the value every 2 seconds, and it worked fine. Unfortunately I cannot remember the series of the Cisco routers there.

Running Wireshark I see the requests and responses, and the response from the router definitely returns the same value.

I have 3 questions regarding this.

  • Is there a setting or configuration that I can set?
  • Will it be better to use traps instead of query?
  • Is this native to the 1900 series to only update the SNMP agent (forgive me if this is the wrong terminology) like it is doing at the moment.

Any help in any direction will be appreciated. If there is any information that you need that I might have left out, please ask. Like I said, I'm not a network engineer.

Thanks in advance

Everyone's tags (1)
1 REPLY
New Member

I received an answer on this

I received an answer on this question here http://networkengineering.stackexchange.com/questions/14630/cisco-1900-series-router-snmp/14632?noredirect=1#14630

Thanks

 

22
Views
0
Helpful
1
Replies