Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1921 no username password commad

Hi,

I  ahve countered an issue today. I was working on 1921 which is used as  test router in ISP. I have loaded a router with test config with  username & password in running config. After a while i have removed  the username & password with no username---password---- command,  then i logged out of router. But now its not allowing me to login as its  asking username & password while its not taking any  username/password not even cisco/cisco, admin/administrator.

Is  this a behaviour of 1921 as i have not copied the runn to start but i  disconneced from secure putty session when router was in running config  mode. Kindly help.

Regards,

Vishal

  • LAN Switching and Routing
2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

Cisco 1921 no username password commad

Hi,

If you have not saved the config in to the start-up config, you can simply reboot the router.  It will take it back to the original config with user name and password.  You can than try login in.  If you remove the user name and password you need to also remove it under the vty and con0 lines.

HTH

Cisco 1921 no username password commad

You have the router configured to use the local user database, but you have removed all the accounts. Doing that will not disable the configuration for using the local database. What you are experiencing is "normal". Menaing that the router is configured for authentication but there are no valid accounts. Like Reza stated, reboot the router and you'll get the startup config. If the config was saved, you'll have to do a password recovery on it.

2 REPLIES
VIP Super Bronze

Cisco 1921 no username password commad

Hi,

If you have not saved the config in to the start-up config, you can simply reboot the router.  It will take it back to the original config with user name and password.  You can than try login in.  If you remove the user name and password you need to also remove it under the vty and con0 lines.

HTH

Cisco 1921 no username password commad

You have the router configured to use the local user database, but you have removed all the accounts. Doing that will not disable the configuration for using the local database. What you are experiencing is "normal". Menaing that the router is configured for authentication but there are no valid accounts. Like Reza stated, reboot the router and you'll get the startup config. If the config was saved, you'll have to do a password recovery on it.

273
Views
0
Helpful
2
Replies