Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 2600/3640 WIC-2T

Can someone walk me through the steps on how to configure my serial modules on my 2600 and 3640?  Each router has the WIC-2T with two cables connecting them.  I tried to ping one router from the other, but no luck. Serial IP address I just made up, this is my home lab, so if I messed those up some how, please let me know...

Here is the running config for each rotuer:

2610:

Current configuration : 1071 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash

boot-end-marker

!

no logging on

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 192.168.3.1 192.168.3.150

!

ip dhcp pool 192.168.3.0/24

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

half-duplex

!

interface Serial0/0

ip address 10.0.1.2 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

ip classless

ip route 192.168.2.0 255.255.255.0 192.168.3.0

ip route 192.168.2.0 255.255.255.0 10.0.1.0

ip route 192.168.3.0 255.255.255.0 192.168.2.0

ip route 192.168.3.0 255.255.255.0 10.0.1.0

!

!

snmp-server community public RO

snmp-server community private RW

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

3640:

Current configuration : 1950 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.1 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip classless

ip route 192.168.2.0 255.255.255.0 192.168.3.0

ip route 192.168.2.0 255.255.255.0 10.0.1.0

ip route 192.168.3.0 255.255.255.0 192.168.2.0

ip route 192.168.3.0 255.255.255.0 10.0.1.0

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

Cisco 2600/3640 WIC-2T

Ok, encapsulation looks good.  You need to clock the DCE side of the cable.

sh contr se0 will tell you which side is DTE and which side is DTE

On DCE site

inte s0

clock rate 2000000

if this does not work try

clock rate 64000

VIP Super Bronze

Cisco 2600/3640 WIC-2T

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

half-duplex

Is this interface in up and up mode?

sh ip int bri

22 REPLIES
VIP Super Bronze

Re: Cisco 2600/3640 WIC-2T

Are the physical interfaces in up and up mode?  Can you issue this command on both routers and post them here?

"sh ip int bri"

HTH

Community Member

Cisco 2600/3640 WIC-2T

It show the protocol as down, how do I enable it?

2610:

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                192.168.3.1     YES NVRAM  up                    up 

Serial0/0                      10.0.1.2        YES manual up                    down

Serial0/1

3640:

3640-Internet#sh ip int bri

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            68.224.240.31   YES DHCP   up                    up 

Serial0/0                  10.0.1.1        YES manual up                    down

FastEthernet0/1            192.168.2.1     YES NVRAM  up                    up 

Serial0/1                  unassigned      YES NVRAM  administratively down down

Ethernet1/0                unassigned      YES NVRAM  administratively down down

Ethernet1/1                unassigned      YES NVRAM  administratively down down

Ethernet3/0                unassigned      YES NVRAM  administratively down down

Ethernet3/1                unassigned      YES NVRAM  administratively down down

3640-Internet#

VIP Super Bronze

Cisco 2600/3640 WIC-2T

Can you make sure encapsulation is the same for both interfaces?  They should be HDLC by default.  "sh int se0" on both routers

Are you using a serial interface to connect them together? what type cable is that?

HTH

Community Member

Cisco 2600/3640 WIC-2T

I am using two DTE cables to connect the two...

3640:

3640-Internet#show interface serial 0/0

Serial0/0 is up, line protocol is down

  Hardware is DSCC4 Serial

  Internet address is 10.0.1.1/24

  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:00:30

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/2/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1158 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     3 packets output, 72 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 output buffer failures, 0 output buffers swapped out

     2 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

2610:

Router#show interface serial 0/0

Serial0/0 is up, line protocol is down

  Hardware is PowerQUICC Serial

  Internet address is 10.0.1.2/24

  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Keepalive set (10 sec)

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:02:19

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/256 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 1158 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     10 packets output, 240 bytes, 0 underruns

     0 output errors, 0 collisions, 4 interface resets

     0 output buffer failures, 0 output buffers swapped out

     18 carrier transitions

     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

VIP Super Bronze

Cisco 2600/3640 WIC-2T

Ok, encapsulation looks good.  You need to clock the DCE side of the cable.

sh contr se0 will tell you which side is DTE and which side is DTE

On DCE site

inte s0

clock rate 2000000

if this does not work try

clock rate 64000

Community Member

Cisco 2600/3640 WIC-2T

One last question... since there are two ports on the interface card, can I connect the two routers by the two WIC ports?  Would that have any advantage?

VIP Super Bronze

Cisco 2600/3640 WIC-2T

Yes, you can.  Put the other interface in a different subnet.

Would that have any advantage?

Not in this case.  If you had lets say 2 T1 connecting to the same provider, you could bundle the 2 together to get more bandwidth for a total of 3Mb.

1.5x2=3

HTH

VIP Super Bronze

Cisco 2600/3640 WIC-2T

Is it working now?

Please remember to tag your threads and help support "Teachers without Borders"

https://supportforums.cisco.com/community/netpro/idea-center/communityhelpingcommunity

Community Member

Cisco 2600/3640 WIC-2T

Well I jumped the gun, I can ping from the 192.168.3.1 router (2610) to the 192.168.2.1 router (3640), but not form 192.168.2.1 to the 192.168.3.1....any idea?

VIP Super Bronze

Cisco 2600/3640 WIC-2T

On the 2610 you need a static route like this:

ip route 192.168.2.0 255.255.255.0 10.0.1.2

on the 3640 you  need a static route like this:

ip route 192.168.3.0 255.255.255.0 10.0.1.1

Community Member

Cisco 2600/3640 WIC-2T

on the 3640 I get this:

3640-Internet(config)#ip route 192.168.3.0 255.255.255.0 10.0.1.1

%Invalid next hop address (it's this router)

VIP Super Bronze

Cisco 2600/3640 WIC-2T

switch them arounf

On the 2610 you need a static route like this:

ip route 192.168.2.0 255.255.255.0 10.0.1.1

on the 3640 you  need a static route like this:

ip route 192.168.3.0 255.255.255.0 10.0.1.2

Basically on the 2610 you want to point to the serial interface of the 3640

On the 3640 you want to point to the serial interface of the 2610

Community Member

Cisco 2600/3640 WIC-2T

So do I need to configure each port on the WIC card?  Right now, I only have se0/0 configured and not se0/1?  I can ping just fine from the 2600 to the 3640...but no success from 3640 to 2600.

VIP Super Bronze

Cisco 2600/3640 WIC-2T

You only need one serial interface on each router.

but with the static route I provide you. you should be able to ping from both router

if this is for lab use and not production, can you delete all the extra static routes on both routers and test again?

You just need the one I provided you

no ip route 192.168.2.0 255.255.255.0 192.168.3.0

no ip route 192.168.2.0 255.255.255.0 10.0.1.0

no ip route 192.168.3.0 255.255.255.0 192.168.2.0

no ip route 192.168.3.0 255.255.255.0 10.0.1.0

Community Member

Cisco 2600/3640 WIC-2T

I can ping, but get this:

C:\Windows\System32>ping 192.168.3.1

Pinging 192.168.3.1 with 32 bytes of data:

Reply from 10.0.1.2: Destination host unreachable.

Reply from 10.0.1.2: Destination host unreachable.

Reply from 10.0.1.2: Destination host unreachable.

Reply from 10.0.1.2: Destination host unreachable.

Ping statistics for 192.168.3.1:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

VIP Super Bronze

Cisco 2600/3640 WIC-2T

Do you have default gateway configured on the PC?  What is the PC connected to and what is the IP?

Community Member

Re: Cisco 2600/3640 WIC-2T

The default gateway is the 3640 router (192.168.2.1) and the PC is used was 192.168.2.122

Sent from Cisco Technical Support iPad App

VIP Super Bronze

Cisco 2600/3640 WIC-2T

From your PC can you ping 192.168.2.1 if yes

can you ping 10.0.1.1 if yes

can you ping 10.0.1.2 if yes

can you ping 192.168.3.1 ?

do you have static routes I provided you on both routers?

did you delete the extra static routes on both routers?

provide sh run from both routers

Community Member

Cisco 2600/3640 WIC-2T

I can ping everything but the 192.168.3.1, removed all static routes, except the ones you provided....any idea?

Current Show Run of each router:

2610:

Current configuration : 953 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash

boot-end-marker

!

no logging on

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 192.168.3.1 192.168.3.150

!

ip dhcp pool 192.168.3.0/24

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

half-duplex

!

interface Serial0/0

ip address 10.0.1.2 255.255.255.0

clock rate 2000000

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

ip classless

ip route 192.168.2.0 255.255.255.0 10.0.1.1

!

!

snmp-server community public RO

snmp-server community private RW

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

3640:

3640-Internet#show run

Building configuration...

Current configuration : 1812 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

ip address 10.0.1.1 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip route 192.168.3.0 255.255.255.0 10.0.1.2

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

3640-Internet#

VIP Super Bronze

Cisco 2600/3640 WIC-2T

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

half-duplex

Is this interface in up and up mode?

sh ip int bri

VIP Super Bronze

Cisco 2600/3640 WIC-2T

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

can you delete ip nat inside?

Community Member

Cisco 2600/3640 WIC-2T

Some how the cable was disconnected from the e0/0 slot.....thanks for the help, ping works just fine now

1107
Views
0
Helpful
22
Replies
CreatePlease to create content