Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2610 Router addressing/NAT

After installing a second 10 mb ethernet nm-1e module on a 2610 router, the e1/0 connects to my ISP cable modem - while e0/0 connects to my 2924xl switch for internal network.

Question: How should I configure IP addresses on these interfaces?

e1/0 = outside IP address? (given by ISP 65.33.x.x)

e0/0 = internal network IP address of 192.168.15.0/24? Is that it?

I will also need NAT and ACL configured on the router. I do not understand either very well.

3 REPLIES

Re: Cisco 2610 Router addressing/NAT

config will look like this:

int e1/0

desc **** Connected to ISP****

ip address 65.33.x.x 255.255.255.252

no shut

ip nat outside

int e0/0

desc **** Connected to LAN Switch****

ip address 192.168.15.1 255.255.255.0

no shut

ip nat inside

access-list 1 permit 192.168.15.0 0.0.0.255

ip nat inside source-list 1 interface e1/0 overload

ip route 0.0.0.0 0.0.0.0 e1/0

you can use IP addressing scheme for LAN for any of the Class A,B, C range reserved for non-routable addressing scheme, it depends on the number of hosts in your network.

192.168.15.0/24 can accommodate 254 hosts in the network.

hope it helps ... rate if it does ...

New Member

Re: Cisco 2610 Router addressing/NAT

Thanks for the NAT config. I will try it out.

1. I have a Linksys internet phone adapter that will connect on the lan switch. This adapter reqiures 4 UDP port ranges (Udp Port 69, 5060-5065, 10,000-20,000)to work. If ACL does not specifically deny any of these port ranges, do I need not worry about the ports on the router at all?

2. The ouside ISP IP address will change from time to time. Do I need to configure DHCP on the router to accept outside IP from ISP? If so, how do I configure DHCP.

Re: Cisco 2610 Router addressing/NAT

A1. ACL used is just to configure NAT, it's not used to block any traffic. As, that ACL is not applied to router interface, hence not blocking any of the UDP ports mentioned.

A2. if ISP address change, you can config like this:

int e1/0

desc **** Connected to ISP****

ip address negotiated

no shut

ip nat outside

hope it helps .... rate if it does ...

641
Views
4
Helpful
3
Replies
CreatePlease login to create content