Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2611 and Smoothwall Trouble

I am currently running Smoothwall and a Cisco 2611 router on my network.

On my Smoothwall, ifconfig -a is:

eth0 - 192.168.1.1 - green

eth1 - 192.168.5.1 - orange

eth2 - xxx.xx.38.35 - red

On my router, show run is:

fa0/0 192.168.1.1

fa0/1 192.168.2.1

router rip ver2

192.168.1.0

192.168.2.0

ip route (for gateway of last resort) 0.0.0.0 0.0.0.0 192.168.1.1

My smoothwall is using dhcp on all interfaces. I don't think my router is forwarding traffic correctly.

My smoothwall can ping 192.168.1.2(fa0/0) and nothing else past the router.

My router can ping my smoothwall, outside network, internal network...practically, everything.

My internal network can ping 192.168.2.1(fa0/1) and 192.168.1.2(fa0/0), if and only if I assign each node a static ip because nothing can receive an ip through DHCP.

I'm at my wits end with this. Does anyone have a clue??? I hope I provided all the necessary info. By the way, the orange interface on smoothie has nothing on it as of now.

Thanks

3 REPLIES
Silver

Re: Cisco 2611 and Smoothwall Trouble

Matthew,

Does your router Fa0/0 really have the same IP address as your smoothwall eth0?

What device is providing DHCP services? If the smoothwall is, then you will need an ip helper statement on your router's fa0/1 interface pointing to the smoothwall's eth0 ip address.

Something like this:

int fa0/1

ip helper-address 192.168.1.1

If you need more assistance, then please provide the complete interface configuration for your two fast-ethernet interfaces.

HTH

Steve

New Member

Re: Cisco 2611 and Smoothwall Trouble

I checked and router FA0/0 is 192.168.2.1 and smoothwall eth0 is 192.168.1.1

My smoothwall will be providing DHCP services.

I just came across relay agents, but I'm not sure how to do it. I programmed the router with the line that you provided still to no avail.

FA0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

FA0/1

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.1.1

duplex auto

speed auto

router rip

version 2

network 192.168.1.0

network 192.168.2.0

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip http server

ip pim bidir-enable

Hope this helps.

Silver

Re: Cisco 2611 and Smoothwall Trouble

Ensure your DHCP server is handing out the correct information. For instance it should be handing out leases for the 192.168.2.0/24 network, the gateway it hands out should be 192.168.2.1.

I'm not familiar with the Smoothwall, but is there any logging happening there that will help?

Steve

256
Views
0
Helpful
3
Replies