Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2800 Series - Dual ADSL links?

Hi,

In a site we currently have 1 BT provided ADSL link which is currently terminated using their device which I believe is some kind of 2wire device, which is extremely slow due to distance from the Exchange (4Mbps)...

We have a growing number of users here and want to install a second ADSL line from BT to give them increased performance.

We have a Cisco 2800 sat not doing much so I was wondering if I could use this to load balance the link? I know BT do not support MPPP so therefore the maximum any user can get will be the speed of a single link (4Mbps)...

But basically how can this be done..

Can I leave the two BT routers in place and place the Cisco 2800 behind them, or do I need to purchase two ADSL modules for the 2800 and terminate the connection there?

Also once done, what do I need to do regarding actually setting up the load balancing? I have seen this:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

But am unsure as to how relevant it is? I am not sure I understand what the ACL's are being used for? I just want all users on the LAN to load balance out...

Also I am unsure of this statement:

You potentially need to add policy-based routing for specific traffic to ensure that it always uses one ISP connection. Examples of traffic that require this behavior include IPSec VPN clients, VoIP handsets, and any other traffic that use only one of the ISP-connection options to prefer the same IP address, higher speed, or lower latency on the connection.

I do not understand why a established session such as a VPN client, would ever traverse the second ISP connection anyway?

2 REPLIES

Cisco 2800 Series - Dual ADSL links?

Hello,

The link you post is indeed for load balancing, but with OER which is a different story.

I don't know your full topology, but I would propose the following:

- Terminate both provider lines on your 2800; when I say terminate, I mean Layer 3 (IP connectivity)

- If you don't use dynamic routing with your providers (and I assume you don't) just add two default routes like:

ip route 0.0.0.0 0.0.0.0 provider_A_IP

ip route 0.0.0.0 0.0.0.0 provider_B_IP

- On the LAN interface you do NAT if you have private subnet or nothing (just plain routing) if you have public IP addresses.

If this way when a packet arrives on your 2800 will be equal load balanced among the two routes.

If your providers lines are not equals in term of bandwidth you may try this:

http://blog.ioshints.info/2007/02/unequal-load-split-with-static-routes.html

to put more traffic on the line with larger bandwidth.

HTH,

Calin

New Member

Cisco 2800 Series - Dual ADSL links?

Hi Jellyman

We've got a  customer with a router C2811 for his Internet access. It has 4 ADSL  links, with the same ISP. The summary of the configuration is:

ADSL1 - interface ATM0/0/0.1 - fixed ip address

ADSL2 - interface ATM0/1/0.1 - fixed ip address

ADSL3 - interface ATM0/2/0.1 - fixed ip address

ADSL4 - interface ATM0/3/0.1 - fixed ip address

ip cef

ip route 0.0.0.0 0.0.0.0 ATM0/0/0.1

ip route 0.0.0.0 0.0.0.0 ATM0/1/0.1

ip route 0.0.0.0 0.0.0.0 ATM0/2/0.1

ip route 0.0.0.0 0.0.0.0 ATM0/3/0.1

ip nat inside source route-map adsl1 interface ATM0/0/0.1 overload

ip nat inside source route-map adsl2 interface ATM0/1/0.1 overload

ip nat inside source route-map adsl3 interface ATM0/2/0.1 overload

ip nat inside source route-map adsl4 interface ATM0/3/0.1 overload

!

ip access-list extended NAT_1

permit ip 192.168.100.0 0.0.0.255 any

route-map adsl2 permit 10

match ip address NAT_1

match interface ATM0/1/0.1

!

route-map adsl3 permit 10

match ip address NAT_1

match interface ATM0/2/0.1

!

route-map adsl1 permit 10

match ip address NAT_1

match interface ATM0/0/0.1

!

route-map adsl4 permit 10

match ip address NAT_1

match interface ATM0/3/0.1

!

That works for TCP traffic, but we  realized that web browsing was very slow and then we figured out that  the problem was DNS traffic. With wireshark we observed that it was many  more DNS requests than DNS responses.

So we created a default route for all traffic to public DNS servers were routed by the adsl1 and it worked perfectly:

ip route 80.58.0.33 255.255.255.255 ATM0/0/0.1

ip route 80.58.61.250 255.255.255.255 ATM0/0/0.1

ip route 194.224.52.36 255.255.255.255 ATM0/0/0.1

I think that it can be something related to ISP provider but which can be an explanation for that? The rest of traffic is load balanced correctly, why cannot be the same for DNS traffic?

Calin, you maybe have got an explanation for that.

Thank you very much.

437
Views
0
Helpful
2
Replies
CreatePlease to create content