Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2801 Router -- 3Com Switch -- Performance Problems

Good Morning to all of you,

I have a strange problem with our Cisco 2801 Router in a Intranet with 3Com 4200G Switch. The router is connected via F0/0 to the 3Com Switch and via F0/1 to a HP 5304XL. The transfer from F0/1 to F0/0 is fine. 90% network utilization. Transfer the other way provides only 10-20% performance. If I replace 3Com switch with HP I'll get 40-90%. And if I replace HP with a cheap Netgear switch, then I'll get the same as from F0/0 to F0/1, 90%.

Can anybody tell me something on this strange phenomenon? The Cisco IOS is 12.3 .There is only routing activated on the 2801.

thanx a lot.

Seb.

9 REPLIES
Cisco Employee

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

Hello Sebastian,

Not knowing the reason for your particular problem due to the lack of show outputs, the usual reason for performance issues in such an environment is a duplex mismatch.

Unfortunately real environments teach us that auto negotiation will not always succeed. Thus make sure both, the switch port and the router interface are configured to 100 mbps and duplex full.

Can you describe your findings with fixed speed and duplex settings? Do you see retransmissions? Pause frames?

Regards, Martin

New Member

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

Hi,

which outputs do you need?

sh int f0/0 + 0/1 shows that both interfaces are set up to 100 auto and duplex auto.

This works with HP and Netgear fine, both on auto mode. Only 3Com has problems with the router. We also set all ports (servers, switches, router) to 100M full. No change at all. Speed from the server (3Com) to server (HP) is still slow. The other way works fine. (90% of 100Mb)

Cisco Employee

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

Hi,

What happens, if you f.e attach the Netgear between the router and the 3Com switch? I just would like to know, whether is is an "interoperability issue" or the 3Com switch alone causing the issue.

Do you see retransmissions? Any error counters on any router interface or 3Com switch interface?

Regards, Martin

New Member

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

Hi,

srv1 -- 3com -- netgear -- cisco -- hp -- srv2

nothing changes

srv1 -- netgear -- cisco -- hp -- srv2

works fine from both sides

srv1 -- hp -- cisco -- hp -- srv2

works fine from srv2 --> srv1

but little bit slower the other way

srv1 -- 3com -- cisco -- hp -- srv2

the normal config!

works fine from srv2 --> srv1

but slow (10-20%) from srv2 --> srv1

Cisco Employee

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

Hi,

just to make sure I understand:

srv1 -- 3com -- netgear -- cisco -- hp -- srv2

nothing changes

This means "works fine from both sides" or "slow (10-20%)"?

Can you also provide show interface outputs from the router-3Com interface and the respective information from the 3Com for both the interfaces connecting to srv1 and the router?

Is it sure that the srv1 and respective 3Com port are both fixed speed and duplex? And are you seeing pause frames or dropped frames on any of the involved ports?

Regards, Martin

New Member

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

ok, let's check.

srv1 -- netgear -- cisco -- hp -- srv2

this works fine from both sides.

srv1 -- 3com -- cisco -- hp -- srv2

this only from srv2 --> srv1

the other way 10-20%

New Member

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

cisco2801#sh int f0/0

FastEthernet0/0 is up, line protocol is up

Hardware is Gt96k FE, address is 001a.a1f3.ee1a (bia 001a.a1f3.ee1a)

Description: $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$FW_INSIDE$$ETH-LAN$

Internet address is 192.168.4.140/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 2/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1090000 bits/sec, 180 packets/sec

5 minute output rate 155000 bits/sec, 142 packets/sec

12997102 packets input, 2828049833 bytes

Received 1371055 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

12799024 packets output, 71310236 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

this is the interface connected to 3Com Switch.

All speeds are set to "auto", as it is per default.

I also tried several combinations of fixed speeds and duplex, also with the servers.

Nothing changed.

I'll take a look at the 3Com now to provide you more infos.

New Member

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

the configuration of 3Com - Port to Cisco.

Port State Enable[Active] PVID 1

Flow Control Disable Link Type Access

MDI Auto Speed Auto[100]

Duplex Auto[Full] Max MAC Count No Limit

Jumbo Frame Enabled Port Isolate Disabled

Broadcast Suppression 3000(pps)

New Member

Re: Cisco 2801 Router -- 3Com Switch -- Performance Problems

The problem is still valid.

611
Views
15
Helpful
9
Replies