Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Hi There,

I have two switches I am trying to connect a 2950 and a 3350. I have a crossover cable connecting them from fa0/24 to fa0/24 setup as a trunk,

however they won't connect and the port on both switches is down, (e.g no port light coming on on switch)

here is some show commands from both switches.. does anyone know where I am going wrong.. thanks in advance

2950#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Vlan1                      192.168.0.11    YES NVRAM  up                    up

FastEthernet0/1            unassigned      YES unset  up                    up

FastEthernet0/2            unassigned      YES unset  down                  down

FastEthernet0/3            unassigned      YES unset  down                  down

FastEthernet0/4            unassigned      YES unset  down                  down

.......

FastEthernet0/24           unassigned      YES unset  down                  down

2950#sh vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20

                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

1002 fddi  101002     1500  -      -      -        -    -        0      0

1003 tr    101003     1500  -      -      -        -    -        0      0

1004 fdnet 101004     1500  -      -      -        ieee -        0      0

1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type              Ports

------- --------- ----------------- ------------------------------------------

2950#sh run

Building configuration...

Current configuration : 1278 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2950

!

enable secret 5 $1$JKXw$gcYpfOaSQRiQqcCuVF5371

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

switchport mode access

!

interface FastEthernet0/4

......

.....

!

interface FastEthernet0/24

switchport mode access

speed 100

duplex full

!

interface Vlan1

ip address 192.168.0.11 255.255.255.0

!

ip http server

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

login

!

!

end

2950#

3350#sh vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/1, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20

                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24, Gi0/1, Gi0/2

1002 fddi-default                     active

1003 token-ring-default               active

1004 fddinet-default                  active

1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

1002 fddi  101002     1500  -      -      -        -    -        0      0

1003 tr    101003     1500  -      -      -        -    -        0      0

1004 fdnet 101004     1500  -      -      -        ieee -        0      0

1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type              Ports

------- --------- ----------------- ------------------------------------------

3350#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Vlan1                      192.168.0.12    YES NVRAM  up                    up

Vlan200                    unassigned      YES NVRAM  down                  down

FastEthernet0/1            unassigned      YES unset  down                  down

FastEthernet0/2            unassigned      YES unset  up                    up

FastEthernet0/3            unassigned      YES unset  down                  down

.....

......

FastEthernet0/24           unassigned      YES unset  down                  down

GigabitEthernet0/1         unassigned      YES unset  down                  down

GigabitEthernet0/2         unassigned      YES unset  down                  down

3350#sh run

Building configuration...

Current configuration : 1728 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3350

!

enable secret 5 $1$ojzz$X.gjyIj/4JDGAUDXYP5ie1

!

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

switchport mode access

no ip address

!

......

......

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 192.168.0.12 255.255.255.0

!

interface Vlan200

no ip address

!

ip classless

ip http server

!

!

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

login

!

end

3350#

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Cisco 2950 - 3350 Trunking issue - Port not lighting up

I am using are cross over cables and that may be why it is not working....

Without TDR, it's hard to determine.

Loop the cable:  Plug the cable in one port (access) and plug the other end to another port of the same switch (access).  If the ports light up, you have a good cable.  If the ports don't light up, then you've got a bad cable.

10 REPLIES
Cisco Employee

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Hi Jessse,

In 2950, auto-mdix is not enabled by default. Can you try configuring auto-mdix under the interface and check the status?

Thanks & Regards,
Karthick Murugan
CCIE#39285

Thanks & Regards, Karthick Murugan CCIE#39285
New Member

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Hi  Karthick,

I had a look under the interface however I don't appear to have any command for mdix-auto?

2950(config-if)#?

Interface configuration commands:

  arp                 Set arp type (arpa, probe, snap) or timeout

  bandwidth           Set bandwidth informational parameter

  carrier-delay       Specify delay for interface transitions

  cdp                 CDP interface subcommands

  channel-group       Etherchannel/port bundling configuration

  channel-protocol    Select the channel protocol (LACP, PAgP)

  default             Set a command to its defaults

  delay               Specify interface throughput delay

  description         Interface specific description

  dot1x               Interface Config Commands for 802.1x

  down-when-looped    Force looped interface down

  duplex              Configure duplex operation.

  exit                Exit from interface configuration mode

  fair-queue          Enable Fair Queuing on an Interface

  help                Description of the interactive help system

  hold-queue          Set hold queue depth

  ip                  Interface Internet Protocol config commands

  keepalive           Enable keepalive

  lacp                LACP interface subcommands

  load-interval       Specify interval for load calculation for an interface

  logging             Configure logging for interface

  mac-address         Manually set interface MAC address

  macro               Command macro

  mls                 mls interface commands

  mvr                 MVR per port configuration

  no                  Negate a command or set its defaults

  pagp                PAgP interface subcommands

  random-detect       Enable Weighted Random Early Detection (WRED) on an

                      Interface

  rmon                Configure Remote Monitoring on an interface

  shutdown            Shutdown the selected interface

  snmp                Modify SNMP interface parameters

  spanning-tree       Spanning Tree Subsystem

  speed               Configure speed operation.

  storm-control       storm configuration

  switchport          Set switching mode characteristics

  timeout             Define timeout values for this interface

  transmit-interface  Assign a transmit interface to a receive-only interface

  tx-ring-limit       Configure PA level transmit ring limit

  udld                Configure UDLD enabled or disabled and ignore global UDLD

                      setting

2950(config-if)#

Hall of Fame Super Gold

Cisco 2950 - 3350 Trunking issue - Port not lighting up

In 2950, auto-mdix is not enabled by default.

The reason why MDIX is not enabled by default on 2940/2950/2955 & 3550 is because MDIX is NOT SUPPORTED on this platform.  MDIX support started appearing with the release of the 2960, 3750 and 3560 switches.

duplex full

speed 100

Remove these two lines from either switches.

New Member

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Jesse,

Have you tried a straight through cable? Also I would change the 2950's interface FastEthernet0/24 to switchport mode trunk.

New Member

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Ah yes, sorry, I noticed that when I posted, I did change this and both ends are indeed trunks.

I tried removing duplex full / speed 100 on one side and then both sides, this seemed to make no difference

Ive tried a straight through cable and multiple other cables

I'm starting to think that none of the cables I am using are cross over cables and that may be why it is not working....

I have lots of cables from isps etc for connection your modem to pc, but im starting to think  and on closer inspection of the cable that these are all straight through cables. and as these are like devices it should only work with cross over so maybe thats why the ports are failing to light up ?

3350#sh run

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

!

2950#sh run

interface FastEthernet0/24

switchport mode trunk

Hall of Fame Super Gold

Cisco 2950 - 3350 Trunking issue - Port not lighting up

I am using are cross over cables and that may be why it is not working....

Without TDR, it's hard to determine.

Loop the cable:  Plug the cable in one port (access) and plug the other end to another port of the same switch (access).  If the ports light up, you have a good cable.  If the ports don't light up, then you've got a bad cable.

New Member

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Good test, I was wondering... as I could plug my pc into the ports (which proved the ports were fine)

I just tried  looping multiple cables like you said by plugging them into access ports on the same switch and none of them are lighting up...

So from this it appears none of my cables are cross over cables....

ill source one tomorrow and try again.

thanks for your help!

Hall of Fame Super Gold

Re: Cisco 2950 - 3350 Trunking issue - Port not lighting up

I just tried  looping multiple cables

Make sure they are cross-over cables.  MDIX is not supported so you won't get anything if you loop straight-through cables. 

New Member

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Got hold of a cross over cable, worked fine - trunk established.

lesson learnt! - will have to check to make sure im using correct cables in future!

Hall of Fame Super Gold

Cisco 2950 - 3350 Trunking issue - Port not lighting up

Thanks for taking the time to rate our posts. 

4592
Views
5
Helpful
10
Replies
CreatePlease to create content