Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 2950G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port Speed Problem

All,

I have a Cisco 2950G-48-TC-L switch and  a quad port Broadcom NetXtreme Server BCM5715 NIC.

I cannot get the port speed to a full 1 Gig Full duplex. I have both the Cisco and the client's NIC set to AUTO/AUTO for speed / duplex - and the best it can do is 100mbps / full duplex.

If i hard code the Cisco to 1 Gbps / full duplex then the client will loose connectivity/port link.

If i hard code both the Cisco and the client at 1 Gbps / full duplex then the client will also loose connectivity/port link.

If i hard code only the clients NIC, and leave the Cisco at AUTO/AUTO, then the client will also loose connectivity/port link.

Only if i set a lower 10/100mbps OR leave both set to AUTO/AUTO,  does the clients NIC connect to the Cisco switch. But this leaves me at 100mpbs at best..  I need 1Gbps...

This is the tricky part... I have a 1Gbps hub that i have used the current Cat5E cables to connect to the Cisco .. That gives me a full 1Gbps/Full duplex.

If i use the same CAT5E cable and connect the clients BroadCom NetXtreme BCM5715 Nic to the Gig. hub, i also get a 1Gbps/full duplex connection.....

HOWEVER - if i connect the clients NIC to the Ciscos port --- then i only get a 100mbp / full duplex connection... WTF....


I have played around with the duplex / port speed settings and just simply cannot get the Broadcom NetXtreme BCM5715 to connect to the Cisco 2950G-48-TC-L at a rate of 1Gbps/full duplex...

Has any one had experience with this hardware configuration... Can someone please help me out here, im in a pinch to get this working right..

TIA

Drumgod...

Everyone's tags (5)
19 REPLIES
Hall of Fame Super Blue

Re: Cisco 2950G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

djbowling wrote:

All,

I have a Cisco 2950G-48-TC-L switch and  a quad port Broadcom NetXtreme Server BCM5715 NIC.

I cannot get the port speed to a full 1 Gig Full duplex. I have both the Cisco and the client's NIC set to AUTO/AUTO for speed / duplex - and the best it can do is 100mbps / full duplex.

If i hard code the Cisco to 1 Gbps / full duplex then the client will loose connectivity/port link.

If i hard code both the Cisco and the client at 1 Gbps / full duplex then the client will also loose connectivity/port link.

If i hard code only the clients NIC, and leave the Cisco at AUTO/AUTO, then the client will also loose connectivity/port link.

Only if i set a lower 10/100mbps OR leave both set to AUTO/AUTO,  does the clients NIC connect to the Cisco switch. But this leaves me at 100mpbs at best..  I need 1Gbps...

This is the tricky part... I have a 1Gbps hub that i have used the current Cat5E cables to connect to the Cisco .. That gives me a full 1Gbps/Full duplex.

If i use the same CAT5E cable and connect the clients BroadCom NetXtreme BCM5715 Nic to the Gig. hub, i also get a 1Gbps/full duplex connection.....

HOWEVER - if i connect the clients NIC to the Ciscos port --- then i only get a 100mbp / full duplex connection... WTF....


I have played around with the duplex / port speed settings and just simply cannot get the Broadcom NetXtreme BCM5715 to connect to the Cisco 2950G-48-TC-L at a rate of 1Gbps/full duplex...

Has any one had experience with this hardware configuration... Can someone please help me out here, im in a pinch to get this working right..

TIA

Drumgod...

Drumgod

Could you clarify the switch because there is no 2950-48-TC-L but there is a 2960-48-TC-L.  Both switches have 48 10/100 ports and 2Gbps uplinks. So which ports are you using because the non-uplink ports only support 10/100.

Jon

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

Excuse the typo.. Its a Cisco Catalyst 2960G-48-TC-L with 48 Ethernet 10/100/1000 ports, 4 of which are dual-purpose. So the switch does indeed support 1Gbps on all ethernet ports.

The switch i have can be found on this page:

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps6406/product_data_sheet0900aecd80322c0c.html

Its the last item in the table.

I have tried using random ports + the uplink ports. If i plug into my 1Gbps hub, i can get 1gbps connection from all the ethernet ports on the switch - just not when i plug it into my 1Gbps NIC's. Thats when i can only achieve 100Mpbs.

Purple

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

   Are you using a good straight thru cable ? Takes 8 good wires to get gig /\.   It sounds like the MDIX function is trying to compensate for a reversed cable .  Also try on the interface "no mdix-auto "  .

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

I have two of these switches in the same rack. Both are having the same problem. There are 88 cables going to my equipment. All produce the same result. I can use one of the current cables, and connect from the Cisco switch to the Onboard NIC and achieve a full 1Gbps speed. I have even tried CAT6 cables. So the cable does not make senese as the source of the problem.

I have tried the auto MDX function ON/OFF/AUTO and still only able to get 100Mbps speed.... Any other ideas?

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

BUMP...


Still looking for assistance here.

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

Hi

Saw this somewhere on internet - "We discovered that (on our desktop machines, at least) the Broadcom NIC has two programs associated with it, the driver ("Broadcom Gigabit Integrated Controller") and a "Broadcom Management Program". Our problems went away when we removed the Management program from the desktop in question".

Can you try this ? with regards to the cisco switch config - as Jon and others mentioned, it should connect fine if the speed/duplex is negotiating good.. just to troubleshoot, can you directly plug in a laptop with say a broadcom 57xx types gig port and see if you get 1 gbps speed for your connection? We are just trying to isolate things here.

Thanks

Raj

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

I am not running the applets that are delivered with the NIC driver. They are not currently installed.

I did install the applet on a single test system to see if i could manuliplate the settings better from there - however the applet only provides the same advanced settings that can be found within the device manager - only with a pretty GUI..

I do not have a laptop with a Broadcom NIC. Nor do i have any other Broadcom NIC cards other than the problmatic one in this topic..

I can plug the same port of the Cisco (with the same cable) into the onboard NIC and achieve a full 1Gbps speed.

But i can also plug a crossover cable into the Quad port NIC (Port 1 and Port 2) and achieve a full 1Gbps speed. This is with out using the Cisco or any other switch, rather a direct connect to the NIC cards port 1 and port 2...

Im perplexed......

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

Hi

Can you please copy us the "show version" output and the output of "show logs" from the switch ? it looks really vague to me..

Raj

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

I wish i could... These switches are on a government network. I cannot post information from that network onto this website.... I know that make troubleshooting more difficult..

What would i be looking for in the output of those commands? I can run them and look into it..

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

wanted to check the software version running on the switch to check fi there are any open caveats.. show log will give us info

rmation about any errors on the switchport or the entire switch.. "show interface" should show you the speed and duplex in use from the switch side.. all these outputs would help us troubleshooting this issue.. so, did you say, if you connect the broadcom server to any other switch eg 3750, 6500 etc they are recognized on 1 gig uplink ?

Hope this helps

Raj

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

If i connect this broadcom NIC to any other Cisco - i only get 100Mbps speed. I have tried 4 different Cisco switches at this point..

2960G x2

3750G x2

All only produce the 100mbps speed. I have verified that the mentioned switches were previously working at 1Gbps before connecting the AIE NIC. Once i connect the Broadcom/AEI nic - i only get 100Mbps...

Im loking through the logs now to see if i can find anything usefull..

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

Forgot to mention that the IOS was recently upgraded to the lasted version on Ciscos website. 12.1.52 if i remember correctly..

Hall of Fame Super Gold

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

The latest IOS for the 2960 is 12.2(52) and 12.2(53) for the 3750.  If this is symptomatic when you connect to both 2960 and the 3750 then I'd recommend looking at the latest drivers for the server's NIC cards.  There have been reports of old NIC 10/100/1000BaseTx NIC cards who would refuse to talk to Cisco at 1Gb.  Hope this helps.

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

Well... the latest NIC card driver is v12.2.2, and that is what im using. I have also tried the previous driver 11.7.X with the same result.

I am also working with Broadcom's engineers on this issue. I fully believe this problem is with the NIC card driver, but they are pointing the finger at the Cisco switch(s). Dosnt make sense to me the that Cisco products that i can verifiy to work, would be the problem..

I guess i'll let Broadcom take the lead on this issue, and let Cisco off the hook... Thanks for your help everyone.

Hall of Fame Super Gold

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

I don't want go around a dead horse but it's always a network fault.  I had a similar issue with an Intel NIC chip and Intel/HP doesn't want to hear anything and kept blaming Cisco.  It took a Cisco Senior SE to let me know that it's because of the NIC's and the switch (WS-C3524XL-EN) inability to auto-negotiate jitter.  The bad news about it is even in Cisco Release Note was very inadequate.

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

"

If i connect this broadcom NIC to any other Cisco - i only get 100Mbps speed. I have tried 4 different Cisco switches at this point..

2960G x2

3750G x2"

This makes more insight to the issue.. since it doesnt work with most of the gig switches on the network, i think its the NIC card which might be faulty ! Im not really sure about the drivers or other software to make this NIC work, but the cisco side seems good to me !

Regards

Raj

Community Member

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

May i suggest that this network card be publised as incompatiable with the current Cisco 2960G-24-TC-L switch. I think we have verified that this network card is not compatiable. I'd like to see some official documenation stating that fact. Im sure it would help others that might have the same problem.

The NIC is manufactured by broadcom (BCM5715) but sold under the name AEI E1400C...

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

Hi

If the switch is under support contract, you can open a tac, and the cisco personnel would check this against his internal database of issues.. he can infact simulate this in his lab, and check ! not sure how to get this documented, but Cisco TAC is the way to go !

Raj

Bronze

Re: Cisco 2960G-48-TC-L + Broadcom NetXtreme Server BCM5715 Port

I would recommend having a case opened with Cisco TAC.  They have a lot of commands to help figure out what is going on with this.  Take a look at this:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_52_se/command/reference/showplat.html#wp1023013

I wouldn't recommend running these commands without TAC guidance.  They can be disruptive to the network (when not running at 1G speed).

Dan

2500
Views
0
Helpful
19
Replies
CreatePlease to create content