Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2960 & Alcatel

Hi there,

At a college I'm trying to setup a Cisco 2960 to be used on a VLAN 248 tagged on the uplink port that uses Spanning Tree/

Here is the following from the Cisco:

show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk

Gi0/1       248

Port        Vlans allowed and active in management domain

Gi0/1       248

Port        Vlans in spanning tree forwarding state and not pruned

Gi0/1       248

All the FastEthernet ports are the same:

interface FastEthernet0/24

switchport access vlan 248

switchport mode access

!

This is the uplink port:

interface GigabitEthernet0/1

switchport trunk allowed vlan 248

switchport mode trunk

switchport nonegotiate

!

On the Alcatel OS6850-48L the following is setup:

bridge 1x1 248 priority 3287

Vlan 248 802.1q 5/8 "cisco"

I cannot make a change on the Alcatel, I can only adminsiter the Cisco. I was able to get things working fine (as a test) using a Netgear or HP switch instead of the Cisco. However we have a Cisco switches and would not like to have to buy HPs.

Is there a compatible spanning tree protocol to use on the Cisco with the way things are configured on the Alcatel.

I need to stick to standard RSTP (802.1w) ieee standards and not something Cisco proprietary.

Thank you,

Lawrence

Everyone's tags (5)
5 REPLIES
VIP Super Bronze

Cisco 2960 & Alcatel

Hi,

Can you add "switchport trunk encapsulation dot1q" to interface Gi0/1 and test again?

HTH

New Member

Cisco 2960 & Alcatel

Thanks for the quick reply!

That option is unavailable on the switch it seems:

switchport trunk ?

  allowed  Set allowed VLAN characteristics when interface is in trunking mode

  native   Set trunking native characteristics when interface is in trunking mode

  pruning  Set pruning VLAN characteristics when interface is in trunking mode

However it does show that it is doing 802.1q:

show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi0/1       on               802.1q         trunking      1

Is the what "switchport trunk encapsulation dot1q" does?

Lawrence

VIP Super Bronze

Cisco 2960 & Alcatel

Is the what "switchport trunk encapsulation dot1q" does?

Yes, however if I would look closer, I should have seen it in your first post. So, you are already good with .1Q.

Is vlan 248 in up and up mode?

"sh ip int bri vlan 248" will show you that

HTH

New Member

Cisco 2960 & Alcatel

I think the question is about Spanning-Tree, not VLAN tagging, as the two switches both appear to be using the same encapsulation mode (they must be, as neither of them supports any other).

The OP seems to be implying that he is using 802.1w on the Alcatel. He would need to check to be sure, as Alcatel would also support and could be configured for 802.1d or 802.1s.

Try "spanning-tree mode mst" on the Cisco switch. By default it will be pvst+, which the Alcatel would not like.

Alternatively, can you get LACP working between the two?

New Member

Cisco 2960 & Alcatel

I spoke with Cisco today and they said to use: spanning-tree mode rapid-pvst

I'm trying to test if the port is sending packets out properly. They need to be tagged 248. And the switch needs to communicate with the Alcatel's spanning tree.

I added the follow to mirror the port, and it does mirror. However it doesn't show everything. Such as STP sent or received. Nor does it show items tagged.

Code:
monitor session 1 source interface Gi0/1
monitor session 1 destination interface Gi0/2

I tested using a Netgear with mirroring and see lots of traffic from the Alcatel and even some STP from the Cisco (hooked up to the Netgear). So I am wondering why the mirror on the Cisco does not mirror all the traffic.

I'm including my configuration file below (less IPs and passwords):

Code:
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname nsiswitch2-534ne
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
crypto pki trustpoint TP-self-signed-4271168512
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4271168512
revocation-check none
rsakeypair TP-self-signed-4271168512
!
!
crypto pki certificate chain TP-self-signed-4271168512
certificate self-signed 01
REMOVED ALL THE STUFF HERE....
  quit
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
switchport access vlan 248
switchport mode access

ALL THE FastEthernets ARE THE SAME...

interface FastEthernet0/24
switchport access vlan 248
switchport mode access
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 248
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan248
ip address a.b.c.d 255.255.255.0
no ip route-cache
!
ip default-gateway a.b.c.d
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
line vty 0 4
password
login
line vty 5 15
password
login
!
!
monitor session 1 source interface Gi0/1
monitor session 1 destination interface Gi0/2
end

BTW, here is some code that the Alcatel sends out. I only got this when I hooked up a PC to the wall jack.

Code:
Ethernet II, Src: Alcatel-_bf:29:99 (00:e0:b1:bf:29:99), Dst:
Spanning-tree-(for-bridges)_00 (01:80:c2:00:00:00)
802.1Q Virtual LAN, PRI: 6, CFI: 0, ID: 248

Protocol Identifier: Spanning Tree Protocol (0x0000)
Protocol Version Identifier: Rapid Spanning Tree (2)
BPDU Type: Rapid/Multiple Spanning Tree (0x02)
BPDU flags: 0x4e (Agreement, Port Role: Designated, Proposal)
Root Identifier: 0 / 2 / 00:e0:b1:88:1d:40
Root Path Cost: 15
Bridge Identifier: 32768 / 105 / 00:e0:b1:bd:9d:aa

Lawrence
4157
Views
12
Helpful
5
Replies
CreatePlease login to create content