Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2960 and Nortel 9150 not working together

Hi there.  We have 3 Nortel RG 9150 remote PBXs installed at a branch location, and  they have been functioning well for years plugged into 3Com 4500 10/100 switches.  These  switches have a very basic configuration; nothing special.  We are  transitioning over to Cisco 2960 switches with very basic  configurations.  The problem is that when we plug the 9150 into the 2960  switch, the RX light flashes like it should, but the TX light only  flickers intermittently.  We cannot ping it from the switch or local  router.  Everything in this building is in VLAN 1.  I've tried turning  on full duplex on the 9150 and/or hard-setting the speed/duplex on the 2960  switch.  The company that maintains our 9150 sent a guy out who was  completely puzzled by this too.  In some ways this seems too basic to be a problem, but it is. 

The twist on this problem is that the 3Com switch, which the 9150s are plugged into, is connected directly into the Cisco 2960 that I can't make them work on.  Plug them into the 3Com, they work; move them upstream to the Cisco, and they stop, even after I reboot them.

Here are the port configs of the 3Com and Cisco switches.

Cisco

interface FastEthernet0/15

switchport mode access

power inline never

speed 10

duplex full

spanning-tree portfast

interface GigabitEthernet0/1

description \\ Link to 3Com switch //

switchport mode access

3Com

interface Ethernet1/0/4

stp edged-port enable

broadcast-suppression pps 3000

packet-filter inbound link-group 4999 rule 0

interface GigabitEthernet1/0/50

description \\ Link to Cisco switch //

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Cisco 2960 and Nortel 9150 not working together

Hi,

Alright, very good! So I suggest to stick with the last configuration with the voice VLAN set to 1.

A comment: currently, your switch does not trust the priority marking coming from the PBX, and will remark both the CoS and IP DSCP markings to 0. I do not know if you have any QoS policies in place but you should know that the 2960 is currently making all this PBX traffic a best-effort traffic, voiding any priority marking. You may need to tweak the QoS settings in the future.

Best regards,

Peter

15 REPLIES
New Member

Cisco 2960 and Nortel 9150 not working together

Remove your switchport mode access commands from all interfaces and see if you can ping.

Also, are you pinging from the switch or from another device connected DIRECTLY to the 2960?

Thanks,

Sean Brown

http://www.sleepyshark.com

(Please rate if useful)

New Member

Cisco 2960 and Nortel 9150 not working together

I will try these ideas at the next maintenance window I can schedule.  I have tried: pinging from the directly-connected switch, the nearest upstream router, a workstation plugged directly into the switch, and from the 9150 itself.  None work when plugged into the Cisco switch.

New Member

Cisco 2960 and Nortel 9150 not working together

I tried these ideas, and nothing changed. 

Below is the config as it is right now.  I tried the "spanning-tree bpdufilter" enabled and disabled, and that did not make any difference.

interface FastEthernet0/15
power inline never
spanning-tree bpdufilter enable

Purple

Cisco 2960 and Nortel 9150 not working together

   Wild guess here but something to try.  Is it possible  you are not using the correct cable but the 3com  had the auto mdix feature to make it work.  Looking at your config you have hardcoded the port on the 2960 so auto mdix will not work . Only works  when the port is set as auto/auto .   Try setting the port as auto/auto and see what happens .

New Member

Cisco 2960 and Nortel 9150 not working together

I am having a simliar problem with Avaya 4606 phones.  The 4610 and 4620 are not having problems with the 2960S.  I have tried using both POE and non-POE but still no success.

Silver

Cisco 2960 and Nortel 9150 not working together

Hi,

In my view you should:

- add again the "switchport mode access" under your fa0/15 interface as this is default with 3Com 4500 series,

- add again the "spanning-tree portfast" under your fa 0/15 interface as this roughly corresponds to "stp edged-port enable" with 3Com 4500 series,

- leave speed/duplex settings as auto/auto as this is the default settings with 3Com 4500 series (the earlier version of Nortel 9150 used 10Mbps/half duplex and later version used 10Mbps/full duplex).

Will you please post the 3Com 4500 configuration ("display saved-configuration" or "display current-configuration").

Thanks & Regards,

Antonin

New Member

Re: Cisco 2960 and Nortel 9150 not working together

All right.  I found a spare functioning RG9150 in the store room, as well as a spare 3Com 4500, a Cisco 2960-POE, so I have duplicated this in the lab.  The Cisco and the 3Com switches have been wiped and are running as stock a config as I can make, while still duplicating the setup in the field.  To my relief, I can duplicate the problem too.  So, here are the configs:

3Com

<4500>dis cur
#
private-group-id mode standard
#
local-server nas-ip 127.0.0.1 key 3com
#
domain default enable system
#
igmp-snooping enable
#
undo password-control aging enable
undo password-control length enable
password-control login-attempt 3 exceed lock-time 120
#
radius scheme system
#
domain system
#
local-user admin
service-type ssh telnet terminal
level 3
local-user manager
service-type ssh telnet terminal
level 2
local-user monitor
service-type ssh telnet terminal
level 1
#
acl number 4999
rule 0 deny dest 0000-0000-0000 ffff-ffff-ffff
#
vlan 1
igmp-snooping enable
#
interface Vlan-interface1
ip address x.x.50.239 255.255.0.0
#
interface Aux1/0/0
#
interface Ethernet1/0/1
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/2
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/3
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/4
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/5
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/6
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/7
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/8
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/9
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/10
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/11
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/12
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/13
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/14
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/15
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/16
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/17
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/18
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/19
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/20
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/21
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/22
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/23
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface Ethernet1/0/24
stp edged-port enable
broadcast-suppression PPS 3000
priority trust
packet-filter inbound link-group 4999 rule 0
#
interface GigabitEthernet1/0/25
shutdown
#
interface GigabitEthernet1/0/26
#
interface GigabitEthernet1/0/27
#
interface GigabitEthernet1/0/28
shutdown
#
sysname 4500
undo xrn-fabric authentication-mode
#
interface NULL0
#
user-interface aux 0 7
authentication-mode scheme
user-interface vty 0 4
authentication-mode scheme
#
return
<4500>

New Member

Re: Cisco 2960 and Nortel 9150 not working together

Cisco config

Switch#wr t
Building configuration...

Current configuration : 1344 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
desc \\ Workstation //
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5

interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
desc \\ 9150 //
switchport mode access
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address x.x.50.240 255.255.0.0
no ip route-cache

ip http server
ip http secure-server
!
line con 0
line vty 5 15
!
end

New Member

Re: Cisco 2960 and Nortel 9150 not working together

After some flailing around, the problem has been solved, and I am mystified by my fix.  A colleague of mine suggested that I set the port the 9150 is plugged into as a trunk, with the command "switchport mode trunk".  Surpsingly enough, that fixed it.  Now, I ask the group what their ideas are as to why this works.

Cisco Employee

Re: Cisco 2960 and Nortel 9150 not working together

Hello,

The most probable reason is that the 9150 is priority-tagging its frames using 802.1Q tagging, as each 802.1Q tag contains three bits (CoS) bits to express the frame's priority. I assume that the VLAN ID in these frames is either 0 or 1.

Cisco Catalyst 2960 switches accept tagged frames only on trunk ports and on access ports that have a specific voice VLAN configured. Configuring your port as a trunk allowed it to receive tagged frames.

The question is now what should be the most appropriate configuration of your port. Would you mind testing if this configuration also worked?

interface Fa0/13

switchport mode access

switchport access vlan 1

switchport voice vlan dot1p

spanning-tree portfast ! Will be probably added by the previous command automatically

Best regards,

Peter

New Member

Re: Cisco 2960 and Nortel 9150 not working together

No success when I try this.  I applied the commands you suggested, and they must be regarded as default anyway, because a subsequent "show run" shows:

interface FastEthernet0/13

switchport mode access

spanning-tree portfast

However, this works:

interface FastEthernet0/13
switchport mode access
switchport voice vlan 1
spanning-tree portfast

Cisco Employee

Re: Cisco 2960 and Nortel 9150 not working together

Hi,

Alright, very good! So I suggest to stick with the last configuration with the voice VLAN set to 1.

A comment: currently, your switch does not trust the priority marking coming from the PBX, and will remark both the CoS and IP DSCP markings to 0. I do not know if you have any QoS policies in place but you should know that the 2960 is currently making all this PBX traffic a best-effort traffic, voiding any priority marking. You may need to tweak the QoS settings in the future.

Best regards,

Peter

New Member

Re: Cisco 2960 and Nortel 9150 not working together

Peter-

Thanks for the input, and I will have to investigate the CoS and DSCP as I get farther down the road on this project.

Regards,

Brian

New Member

Re: Cisco 2960 and Nortel 9150 not working together

Just for fun, I got into the http device manager and enabled "Recommended system setup" and then I set the port type to "Cisco Phone+Desktop", and that sets the parameters correctly too.

Cisco Employee

Re: Cisco 2960 and Nortel 9150 not working together

Hi Brian,

Yuck, an HTTP device manager I wouldn't trust it a dime... but here, it actually seems to agree with us

Best regards,

Peter

1129
Views
0
Helpful
15
Replies
CreatePlease login to create content