Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 2960 downgrade from 15 to 12 issue

Hello all, I performed on several WS-C2960+24TC-L  a downgrade from 15.0(2)SE6  to 12.2(55)SE9.

When the switch reloads all seems to be ok but the flash are not recognized (unknown file system).

Neither is possible to configure the switch because it is impossible to create the file vlan.dat (flash missing).

Since I've noticed the same behavior over more than dozen switches I decided to post here this issue.

Please notice that the image I used is not corrupted (I used it to update other C2960 with any issue).

Further notice that the switches starts and decompress teh 12.2 image, so the only symptom is that the flash is no longer

recognized as file system. I recovered from this situation deleting the image and recovering via xmodem the original IOS 15.0(2)SE6.

In such a way I was able to recover and to have a fully funcional switches, anyway something sounds bad in my head.

Please let me know if someone had the same issue and if someone had found an explanation to this behavior.

Thank you

 

Regards

 

Denni

5 REPLIES
Cisco Employee

Could you please give me the

Could you please give me the exact image file of both the version?

Share the error message you saw while doing the downgrade?

 

HTH

Inayath

New Member

Hi insharie, I encountered no

Hi insharie, I encountered no error when downgrading. The switches reload correctly and uncompress the image, but if I use the "show flash" command It prompted:

switch#show flash

                      ^  Error

Anyway if I use the dir command there is no flash in the items prompted, there is "unknown file system" instead. Anyway these are the files I used:

c2960-lanbasek9-mz.150-2.SE6.bin

c2960-lanbasek9-mz.122-55.SE9.bin

I've uploaded the show version of a switch after the recovery procedure (upgrade to 15.0.2 through xmodem)

Thanks for your help.

 

 

Cisco Employee

Thanks for the information.I

Thanks for the information.

I did search on this but couldnt found any known issue related to this issue.

 

Is there any way to log a tac case so that we do recreate of the issue and if in case we hapen to see the same issue we can file bug for the same?

HTH

Inayath

New Member

I'm facing exact same issue

I'm facing exact same issue when i try to downgrade from 15.x to 12.2.x. Did anyone manage to find a resolution to this? If yes, I'd appreciate a response.

 

Thanks,

Jayesh

New Member

Has anyone tried to format

Has anyone tried to format flash:?

291
Views
0
Helpful
5
Replies