Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2960 QoS for VoIP DSCP 40

I am trying to put together a config for a 2960 switch (running 12.2(25)SEE3 C2960-LANBASE-M) that will give priority to voice packets which are already marked with DSCP 40 by the VoIP phone systems. I have successfully used Cisco 2950 switches to do this in the past so I want to ensure that my 2960 will do the same job.

There is a 3662 router connected to Fast0/1 that connects off to a number of other sites that run the same model VoIP PBX. The local VoIP PBX connects to Fast0/2. Gig0/2 links down to a Cisco 2950 that has a VoIP analogue phone module.

I have posted the relevant parts of my config file below:-

hostname switch16

!

!

!

mls qos

!

!

!

interface FastEthernet0/1

description To Cisco 3662

switchport mode trunk

srr-queue bandwidth share 30 20 25 25

priority-queue out

mls qos trust dscp

!

interface FastEthernet0/2

description To VoIP phone system

switchport mode trunk

srr-queue bandwidth share 30 20 25 25

priority-queue out

mls qos trust dscp

!

interface FastEthernet0/3

spanning-tree portfast

!

interface FastEthernet0/24

spanning-tree portfast

!

!

interface GigabitEthernet0/2

description To Parts Cisco 2950

switchport mode trunk

srr-queue bandwidth share 30 20 25 25

priority-queue out

mls qos trust dscp

end

Am I doing the right thing by using the priority queue command?

Should I be doing anything to the ingress queues as well?

Any thought / suggestions are gratefully received.

642
Views
0
Helpful
0
Replies
CreatePlease login to create content