Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 2960s sfp module

I am trying to connect fibre into interface g 1/0/49 sfp module and the activity light is on, stable and green but there is no activity. Any suggestions as to how to gain connectivity?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Post the following command

Post the following command outputs: 

 

1.  sh run interface Gi1/0/49;

2.  sh interface Gi1/0/49 status; 

3.  sh interface Gi1/0/49; and

4.  sh interface Gi1/0/49 trunk

5 REPLIES
Hall of Fame Super Gold

Post the following command

Post the following command outputs: 

 

1.  sh run interface Gi1/0/49;

2.  sh interface Gi1/0/49 status; 

3.  sh interface Gi1/0/49; and

4.  sh interface Gi1/0/49 trunk

New Member

sh run int gi 1/0/49Building

sh run int gi 1/0/49
Building configuration...

Current configuration : 121 bytes
!
interface GigabitEthernet1/0/49
 switchport mode access
 switchport nonegotiate
 speed nonegotiate
 no cdp enable
end

sh int gi 1/0/49                                  
GigabitEthernet1/0/49 is down, line protocol is down (notconnect)                                                                 
  Hardware is Gigabit Ethernet, address is c025.5c0c.1431 (bia c025.5c0c.1431)                                                                              
  MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,                                                   
     reliability 255/255, txload 1/255, rxload 1/255                                                    
  Encapsulation ARPA, loopback not set                                      
  Keepalive not set                   
  Auto-duplex, Auto-speed, link type is force-up, media type is 1000BaseLX SFP  
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

sh int gi 1/0/49 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/0/49                     notconnect   1            auto   auto 1000BaseLX SF
P

sh int gi 1/0/49 trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/49    off              802.1q         other         1

Port        Vlans allowed on trunk
Gi1/0/49    none

Port        Vlans allowed and active in management domain
Gi1/0/49    none

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/49    none

Cisco Employee

sh int gi 1/0/49            

sh int gi 1/0/49                                  
GigabitEthernet1/0/49 is down, line protocol is down (notconnect)  >.. Which means either the cable or port is faulty.

 

Kindly check again with the correct cable and try to swap the SFP if cable is fine.(you can also do the testing by connecting back to back SFP ports).

Hall of Fame Super Gold

GigabitEthernet1/0/49 is down

GigabitEthernet1/0/49 is down, line protocol is down (notconnect)      

I agree.  This means Layer 1 is down.  This could mean SFP could be faulty, cable could be faulty, etc.  

interface GigabitEthernet1/0/49
 switchport mode access
 switchport nonegotiate
 speed nonegotiate

These commands don't make sense.  

 

You've got a GLC-LH-SM(D) installed and you've enabled "speed nonegotiate"?  Take this out. 

Next, you've got "switchport nonegotiate" and you've got "switchport mode access"?  You've literally disabled DTP and specified that the link is-and-will-be an access port.  What is the configuration on the other end? 

New Member

Building configuration..

Building configuration...

Current configuration : 4536 bytes
!
! Last configuration change at 08:42:06 UTC Fri Oct 3 2014
! NVRAM config last updated at 09:05:00 UTC Mon Aug 25 2014 by cisco
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!

!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$zBsc$BV3S1zlFSWusjdU2PVkdX/

!
no aaa new-model
clock timezone UTC -4
switch 1 provision ws-c3750g-12s
switch 2 provision ws-c3750g-12s
system mtu routing 1500
ip subnet-zero
!
!
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
errdisable recovery cause gbic-invalid
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
 switchport mode access
 switchport nonegotiate
 speed nonegotiate
 no cdp enable
!
interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!

105
Views
0
Helpful
5
Replies
CreatePlease to create content