Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 3130 G

Here is my configuration. Why is it showing SD

interface Port-channel1

switchport access vlan 21

switchport mode access

switchport nonegotiate

no logging event link-status

no snmp trap link-status

spanning-tree portfast

interface GigabitEthernet1/0/9

switchport access vlan 21

switchport mode access

switchport nonegotiate

no logging event link-status

no snmp trap link-status

spanning-tree portfast

channel-group 1 mode active

interface GigabitEthernet2/0/1

switchport access vlan 21

switchport mode access

switchport nonegotiate

no logging event link-status

no snmp trap link-status

spanning-tree portfast

channel-group 1 mode active

1     Po1 (SD)     LACP       Gi1/0/9(I)   Gi2/0/1(I)

Everyone's tags (2)
19 REPLIES
VIP Super Bronze

Cisco 3130 G

Is the other side of the portchannel configured?

New Member

Cisco 3130 G

Yes.  It is a LinuX server with 4 ports bonded

VIP Super Bronze

Cisco 3130 G

Can you post the folowing?

sh ip int bri gi2/0/1

sh ip int bri gi1/0/9

sh int po1

sh run int po1

sh etherc 1 summ

New Member

Cisco 3130 G

Interface              IP-Address      OK? Method Status                Protocol

GigabitEthernet2/0/1   unassigned      YES unset  up                    up

Interface              IP-Address      OK? Method Status                Protocol

GigabitEthernet1/0/9   unassigned      YES unset  up                    up

Port-channel1 is down, line protocol is down (notconnect)

  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

  Description: rdlab7

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 19w2d, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     3519 packets input, 645764 bytes, 0 no buffer

     Received 1837 broadcasts (617 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 617 multicast, 0 pause input

     0 input packets with dribble condition detected

     30757 packets output, 2733918 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Current configuration : 238 bytes

!

interface Port-channel1

description rdlab7

switchport access vlan 21

switchport mode access

switchport nonegotiate

no logging event link-status

no snmp trap link-status

spanning-tree portfast

spanning-tree bpduguard enable

end

sh etherc 1 summ

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 5

Number of aggregators:           5

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SD)         LACP      Gi1/0/9(I)  Gi2/0/1(I)

VIP Purple

Re: Cisco 3130 G

HI Dukeminus,

Try this command :

The opposite side of the LACP EtherChannel will typically be configured as passive, however it can be active as well.

channel-group 1 mode passive

Interface Gigabitethernet 1/0/9

channel-group 1 mode passive

interface Gigabitethernet 2/0/1

channel-group 1 mode passive

instead of  channel-group 1 mode active on both the switch interafce.

and then see the output of show etherchannel summary

and then wait for 2-3 minutes to see the port channel up.

Regards

Please rate if it helps.

New Member

Cisco 3130 G

still show same

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SD)         LACP      Gi1/0/9(I)  Gi2/0/1(I)

VIP Purple

Cisco 3130 G

Hi,

If still it is not working then can you please try another port channel (5 or 6 or other then 1) and then apply this port channnel to both switch port.

thn show the status.

Regards

Please rate if it helps.

New Member

Cisco 3130 G

still having same problem:

7      Po7(SD)         LACP      Gi1/0/9(I)  Gi2/0/1(I)

VIP Purple

Cisco 3130 G

ok can u paste output :

sh int gig2/0/1

sh int gig1/0/9

sh int po7

let see whats the error is?

Reagards

New Member

Cisco 3130 G

#sh int gig2/0/1

GigabitEthernet2/0/1 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 68bd.abd0.f281 (bia 68bd.abd0.f281)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:37, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 43

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     438963087 packets input, 169783348217 bytes, 0 no buffer

     Received 30420 broadcasts (755 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 755 multicast, 361619089 pause input

     0 input packets with dribble condition detected

     512468790 packets output, 228054130481 bytes, 0 underruns

     0 output errors, 0 collisions, 5 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

#sh int gig1/0/9

GigabitEthernet1/0/9 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 68bd.abd0.ea09 (bia 68bd.abd0.ea09)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 1000 bits/sec, 1 packets/sec

     526 packets input, 101428 bytes, 0 no buffer

     Received 385 broadcasts (307 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 307 multicast, 0 pause input

     0 input packets with dribble condition detected

     59661912 packets output, 4627452589 bytes, 0 underruns

     0 output errors, 0 collisions, 7 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

sh int po7

Port-channel7 is down, line protocol is down (notconnect)

  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

VIP Super Bronze

Cisco 3130 G

The ports are not being added to the portchannel.

Gi1/0/9(I)  Gi2/0/1(I) I is stand-alone

Gi1/0/9(I)  Gi2/0/1(P) P is for bundled

What version of IOS are you running?

New Member

Cisco 3130 G

sh ver

Cisco IOS Software, CBS31X0 Software (CBS31X0-UNIVERSALK9-M), Version 12.2(53)SE1, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Fri 12-Mar-10 16:32 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x02800000

VIP Purple

Cisco 3130 G

HI Duke,

Port Channel this is a PO group to an ESX server?

In which case you will need different channel commands:

"channel-group 28 mode on"

By specfiying active in the channel-group commands your effectively turning LACP negotiation on then expecting ESX to respond  to this and form an LACP based channel.

Unfortuantely up until ESX / ESXi 5.x LACP isn't supported and no negotiation will happen.

However Static Trunking / EtherChannel is supported (IP Hash load-balancing in ESX) in combination with "mode on" static etherchannel.

Basically when you configured a channel-group with the "mode on" command you explictly force trunking without any channel-protocol negotation (PAgP or LACP).

Any questions let me know.

Regards

VIP Purple

Cisco 3130 G

Have u did no shutdown to the port channel????

Regards

New Member

Cisco 3130 G

Yes

New Member

Cisco 3130 G

channel-group 7 mode on

%With PAgP enabled, all ports in the Channel should belong to the same switch

Command rejected (Port-channel7, Gi2/0/1): Invalid etherchnl mode

VIP Purple

Cisco 3130 G

Hi duke,

try to change the duplex/speed  setting  and check.

if still not works then ..may be u can change the switch and then try.

Hope it helps

Regards

Silver

Re: Cisco 3130 G

Hello Duke, Sandeep,

As Sandeep stated it is worth trying with another mode as 'active' where the switch is trying to actively negotiate (with LACP) the establishment of a Portchannel, but the far end server does not understand..

In order to do change to on mode, can you unbound the physical interfaces from the Portchannel, the bound them again in 'on' mode with the following commands ?

interface GigabitEthernet1/0/9

no channel-group 1 mode active

interface GigabitEthernet2/0/1

no channel-group 1 mode active

then,

interface GigabitEthernet1/0/9

channel-group 1 mode on

interface GigabitEthernet2/0/1

channel-group 1 mode on

(Assuming 1 is the Portchannel identiier)

Best regards.

Karim

New Member

Cisco 3130 G

The configuration is still not working. Could it be because the Linux host already has the 4 ports BONDED ??

interface Port-channel7
switchport access vlan 21
switchport mode access
switchport nonegotiate
no logging event link-status
no snmp trap link-status
spanning-tree portfast


interface GigabitEthernet1/0/9
switchport access vlan 21
switchport mode access
switchport nonegotiate
no logging event link-status
no snmp trap link-status
spanning-tree portfast
channel-group 7 mode active


interface GigabitEthernet2/0/1
switchport access vlan 21
switchport mode access
switchport nonegotiate
no logging event link-status
no snmp trap link-status
spanning-tree portfast
channel-group 7 mode active

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

7 Po1(SD) LACP Gi1/0/9(I) Gi2/0/1(I)

1016
Views
0
Helpful
19
Replies