Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 3524-PWR-XL-EN Switch Data and Voice Configuration

We currently own a 3524 switch that I am trying to setup voice and data access to. I configured vlan database and configured switch to use the data and voice vlan. But when I do show vlan those ports are not configured for those vlans. Is there a step I am missing. Here are copies of config. Any help would be greatly appreciated.

 

 

Thanks,

 

DBCW1-WEC-ROOM202#show run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DBCW1-WEC-ROOM202
!
enable secret 5 $1$4xSB$KaYwp8W6tVKytpwWecHWy1
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
 description Uplink to WEC Room 303
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,135,235,1002-1005
 switchport multi vlan 1,135,235
 switchport mode trunk
!
interface FastEthernet0/2
 description Voice-Data Access Port
 switchport access vlan 235
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 135
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 172.16.235.30 255.255.0.0
 no ip directed-broadcast
 no ip route-cache
!
!
line con 0
 password ?????????????
 logging synchronous
 login
 transport input none
 stopbits 1
line vty 0 4
 password ????????????
 logging synchronous
 login
 length 0
line vty 5 15
 password ??????????????
 logging synchronous
 login
 length 0
!
end


DBCW1-WEC-ROOM202#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                Fa0/23, Fa0/24, Gi0/1, Gi0/2
135  voice                            active
235  data                             active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
135  enet  100135     1500  -      -      -        -    -        0      0
235  enet  100235     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0
DBCW1-WEC-ROOM202#

 

 

3 REPLIES
Bronze

Ensure you data/access VLAN

Ensure your data/access VLAN is your native VLAN for the trunk to your phones.  This will ensure traffic on this VLAN is not tagged, which causes the Cisco phone to forward it to the PC port.  I would also add the "allowed VLAN" command to prevent broadcast or potential loops from VLANs not accosiated with the phone or PC from propogating down these ports.  That is more of a best practice / issue avoidance measure, than a requirement. The port specific configuration would look like this:

 

interface FastEthernet0/2
 description Voice-Data Access Port
 switchport access vlan 235
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 235
 switchport trunk allowed vlan 135,235
 switchport mode trunk
 switchport voice vlan 135

 

Cheers,

Pete

New Member

Thanks for the help, does the

Thanks for the help, does the show vlan command have to show the port the data vlan and voice vlan are associated with?

 

 

Thanks,

 

 

Donovan

Bronze

No, this configuration should

No, this configuration should work without it.  Often trunks so not show individual VLANs outside of the native.  Use a "show interface trunk" command to verify your trunks to phones.  You will not see the VLANs in the forwarding state if the port in not up though.  Best of luck Donovan.

 

Cheers,

Pete

88
Views
0
Helpful
3
Replies
CreatePlease login to create content