Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 3550 to 3524

Hello,

I have these 2 switches Cisco 3550 to 3524 as a test lab and I have set the 3550 up as the core\routing.

I want to trunk and talk between them but I cant get them talking, I've followed this:

http://www.ciscopress.com/articles/article.asp?p=29803&seqNum=3

Switch configs are below, 3524:

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100,1002-1005

switchport mode trunk

!

interface VLAN1

no ip directed-broadcast

no ip route-cache

!

interface VLAN5

ip address 10.1.5.10 255.255.255.0 <<<<<<<<<<<<< My Management VLAN

no ip directed-broadcast

no ip route-cache

shutdown

!

!

line con 0

transport input none

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

Switch#

----------------------------------------------------------------------------------------------------------------------------

3550:

bmi-c3550-core#show running-config

Building configuration...

Current configuration : 2675 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname bmi-c3550-core

!

!

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

interface FastEthernet0/1

no switchport

ip address 200.1.1.1 255.255.255.0

!

interface FastEthernet0/2

switchport access vlan 2

switchport mode dynamic desirable

!

interface FastEthernet0/3

switchport access vlan 3

switchport mode dynamic desirable

!

interface FastEthernet0/4

switchport mode dynamic desirable

!

interface FastEthernet0/5

switchport mode dynamic desirable

!

interface FastEthernet0/6

switchport mode dynamic desirable

!

interface FastEthernet0/7

switchport mode dynamic desirable

!

interface FastEthernet0/8

switchport mode dynamic desirable

!

interface FastEthernet0/9

switchport mode dynamic desirable

!

interface FastEthernet0/10

switchport mode dynamic desirable

!

interface FastEthernet0/11

switchport mode dynamic desirable

!

interface FastEthernet0/12

switchport mode dynamic desirable

!

interface FastEthernet0/13

switchport mode dynamic desirable

!

interface FastEthernet0/14

switchport mode dynamic desirable

!

interface FastEthernet0/15

switchport mode dynamic desirable

interface FastEthernet0/16

switchport mode dynamic desirable

!

interface FastEthernet0/17

switchport mode dynamic desirable

!

interface FastEthernet0/18

switchport mode dynamic desirable

!

interface FastEthernet0/19

switchport mode dynamic desirable

!

interface FastEthernet0/20

switchport mode dynamic desirable

!

interface FastEthernet0/21

switchport mode dynamic desirable

!

interface FastEthernet0/22

switchport mode dynamic desirable

!

interface FastEthernet0/23

switchport mode dynamic desirable

!

interface FastEthernet0/24

switchport mode dynamic desirable

!

interface GigabitEthernet0/1

switchport mode dynamic desirable

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 10.1.2.254 255.255.255.0

!

interface Vlan3

ip address 10.1.3.254 255.255.255.0

!

interface Vlan4

ip address 10.1.4.254 255.255.255.0

!

interface Vlan5

ip address 10.1.5.254 255.255.255.0

!

interface Vlan6

ip address 10.1.6.254 255.255.255.0

!

interface Vlan7

ip address 10.1.7.254 255.255.255.0

!

interface Vlan8

ip address 10.1.8.254 255.255.255.0

!

interface Vlan9

ip address 10.1.9.254 255.255.255.0

!

interface Vlan10

ip address 10.1.10.254 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 200.1.1.2

ip http server

!

!

line con 0

line vty 5 15

!

end

-------------------------------------------------------------------------------------

What am I missing?

15 REPLIES
Bronze

Cisco 3550 to 3524

Which interfaces are you connecting together?

New Member

Re: Cisco 3550 to 3524

On int vlan 5 do a "no shut" then you should be able to ping to the other switch interface on vlan5

Sent from Cisco Technical Support iPad App

New Member

Re: Cisco 3550 to 3524

Right i've applied the no shut to vlan 5 on the edge which I cannot ping the edge switch still:

nterface VLAN5

ip address 10.1.5.10 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown

I can now ping all vlans!

any idea still on the switch ip?

Also if I try and ping any default gateway from the core I get this:

Switch#ping 10.1.2.254

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.2.254, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Switch#

New Member

Cisco 3550 to 3524

Hi HGAED,

You don't seem to have a default gateway applied to the 3524, so it gets packets from your PC in the 10.1.2.0/24 network but doesn't know where to send it back.

Give that switch a default gateway of 10.1.5.254 and the 3524 will know where to send the icmp reply.

ip default-gateway 10.1.5.254

HTH

Jonathan S

New Member

Re: Cisco 3550 to 3524

Thanks Jonathan,

I've now applied that command, the output:

Switch#

Switch#ping 10.1.5.254

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.5.254, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Switch#

New Member

Re: Cisco 3550 to 3524

Ok at this point let's make sure it's not a L1 or L2 problem.

Do a show int gi0/2 on both switch to make sure they are both in an up/up state.

Jonathan S

New Member

Re: Cisco 3550 to 3524

3524:

Switch#show int gi0/2

GigabitEthernet0/2 is up, line protocol is up

  Hardware is Gigabit Ethernet, address is 0008.a391.d2da (bia 0008.a391.d2da)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Auto-duplex (Full), 1000Mb/s, media type is CX_GIGASTACK

  output flow-control is off, input flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  GigaStack module(0.2) in GBIC slot. link1 is down, link2 is up

  Last input 00:00:11, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Queueing strategy: fifo

  Output queue 0/40, 0 drops; input queue 0/75, 0 drops

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 3000 bits/sec, 4 packets/sec

     180 packets input, 18037 bytes, 0 no buffer

     Received 57 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 52 multicast, 0 pause input

     3558 packets output, 275150 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

3550:

bmi-c3550-core#show int gi0/2

GigabitEthernet0/2 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 000f.34b3.949a (bia 000f.34b3.949a)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is CX Gigastack

  output flow-control is off, input flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  GigaStack module(0.2) in GBIC slot. link1 is up, link2 is down

  Last input 00:00:00, output 00:00:04, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 4000 bits/sec, 7 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     46120 packets input, 3455979 bytes, 0 no buffer

     Received 44939 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 43134 multicast, 0 pause input

     0 input packets with dribble condition detected

     2750 packets output, 308592 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

bmi-c3550-core#

-----------------------------------------------------------------

From my laptop with static IP 10.1.2.5 I can ping all vlan gateways, from core I can ping laptop fine.

From core I cannot ping 10.1.5.10 which is the VLAN5 and IP of edge switch

Thanks for helping, I'm more a ProCurve man!...

New Member

Cisco 3550 to 3524

Issue "show interface trunk" on both switches, do you see your vlans on the trunk?

New Member

Re: Cisco 3550 to 3524

from 3550:

bmi-c3550-core#show interface trunk

Port        Mode         Encapsulation  Status        Native vlan

Gi0/2       on           802.1q         trunking      1

Port      Vlans allowed on trunk

Gi0/2       1-100

Port        Vlans allowed and active in management domain

Gi0/2       1-8,10

Port        Vlans in spanning tree forwarding state and not pruned

Gi0/2       1-8,10

bmi-c3550-core#

bmi-c3550-core#

from 3524:

When I plum the command into the 3524 I get this:

Switch#show interface trunk

                        ^

% Invalid input detected at '^' marker.

Switch#

New Member

Cisco 3550 to 3524

OK, try this instead on the 3524  show int gi0/2 switchport

New Member

Re: Cisco 3550 to 3524

Done from 3524

Switch#show int gi0/2 switchport

Name: Gi0/2

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: 1-100,1002-1005

Trunking VLANs Active: 1-8,10

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Switch#

-----------------------------------------------------------------------

Interesting from 3524, I cannot ping any gateways or laptop, but the laptop is connected to the 3524 and can ping gateways

New Member

Cisco 3550 to 3524

Try shutting down vlan 1 on the 3524, make sure vlan 5 is enabled and ping again

New Member

Re: Cisco 3550 to 3524

Getting somewhere now, I did have this:

interface VLAN5

ip address 10.1.5.10 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown

ran the no shutdown command on int vlan 5 and its come alive now!

Looks like I can ping everything between switches.

Looking at both switch configs in the top post is there anything else I need todo or any recommended commands?

New Member

Cisco 3550 to 3524

For the 3524,  I would say to assign the user ports to a vlan of your choice using the "switchport access vlan " and still shutdown the interface vlan1.

New Member

Re: Cisco 3550 to 3524

Thanks!

I thought it was harder setting up cisco switches..........

1387
Views
0
Helpful
15
Replies
CreatePlease login to create content