Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 3560 switch wont give DHCP to SAP1602 SAP

I can't seem to get my Cisco 3560 switch to give do DHCP for my SAP 1602 guest network...  No wireless controller.

I will post relevent sections of the configs.

 

 

SAP1602:

ssid avmaguest

!

antenna gain 0

peakdetect

dfs band 3 block

stbc

beamform ofdm

mbssid

channel dfs

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 20

bridge-group 20 subscriber-loop-control

bridge-group 20 spanning-disabled

bridge-group 20 block-unknown-source

no bridge-group 20 source-learning

no bridge-group 20 unicast-flooding

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

 

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface GigabitEthernet0.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 20

bridge-group 20 spanning-disabled

no bridge-group 20 source-learning

!

interface BVI1

mtu 1514

ip address 192.168.1.20 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.253

 

 

 

 

Cisco 3560 Switch:

 

ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.20.1 192.168.20.20

!

ip dhcp pool WIRELESS

import all

network 192.168.20.0 255.255.255.0

dns-server 8.8.8.8

default-router 192.168.20.1

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/1
description 4-11-2 Studio
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,20
switchport mode trunk
spanning-tree portfast

...

interface Vlan1
ip address 192.168.1.10 255.255.255.0
ip helper-address 192.168.1.251

!

interface Vlan20
description Wireless Guest
ip address 192.168.20.1 255.255.255.0
ip access-group 100 in
ip access-group 100 out

!

ip default-gateway 192.168.1.253

ip route 0.0.0.0 0.0.0.0 192.168.1.253

 

 

Everyone's tags (1)
1 REPLY

I'm assuming you mean for

I'm assuming you mean for vlan 20? If so, you have the acls on the svi for vlan20. If you remove those, does it work? If so, can you post your acl?

HTH, John *** Please rate all useful posts ***
48
Views
0
Helpful
1
Replies
CreatePlease to create content