Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 3620 and Internet access

I have a Cisco 3620 router and I am trying to get internet access. My isp is comcast. All modem lights seem to be operational. But I do not have internet access. I can ping anything other then the router and I am on a home network.

I have attached a config file. Please note I am a novice with cisco routers.

Everyone's tags (3)
47 REPLIES
Purple

Cisco 3620 and Internet access

Hi,

you've got no default route on the router, is your modem in bridged mode because you put a public IP on your interface facing the modem ? or is it also routing?

in first case then ip route 0.0.0.0 0.0.0.0 x.x.x.x where x.x.x.x is ISP default gateway

in second case then ip route 0.0.0.0 0.0.0.0 x.x.x.x where x.x.x.x is the ip address of the modem and change the ip address on the interface of the router or let the router get its ip address and default route from the modem with the command  ip address dhcp

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Alain,

Thanks for your reply.

As I mentioned I'm a novice, so I am not sure were to make these chances.

Where you state first and second case do I change them under the inter e0/0 and e0/1 or enter them under the ip domain-name XXYYZZ.com section?

And I'm not sure about the bridged or routing question.

Ray

Purple

Cisco 3620 and Internet access

Hi,

the default route is configured in global config mode.

were you connected to this modem before connecting the router? Is this ADSL or Cable modem ?

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Its a cable modem.

were you connected to this modem before connecting the router? No, I edit and save my config and reboot the router and connect to the modem.

I added in the ip address to the modem, for the second case. Still no internet.

The ISP default gateway I can not find.

New Member

Cisco 3620 and Internet access

OK I found what I needed and still no internet access.

Purple

Cisco 3620 and Internet access

Hi,

can you do this:

enable

config t

access-list 199 permit icmp any any

logging buffered debug

logging buffered 10000

no service timestamp debug

do debug ip pack detail 199

do debug arp

do ping 8.8.8.8 rep 2

do sh log

Post the output here.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Alain,

When I type in do debug ip pack detail 199 I get invalid input at the do debug.

When I type do ? all I get back is <0-9>.<0-9> ver number. I guess my IOS does not support this function.

My IOS version is 12.2<13b>M2

Ray

Purple

Cisco 3620 and Internet access

Hi,

so go back int0  privileged mode( ctrl Z) and type the corresponding command without the do keyword.

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Sorry to ask this one, but what is the command to copy the log file?

Purple

Cisco 3620 and Internet access

Hi,

just type sh log in privileged mode and copy-paste the output.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: Cisco 3620 and Internet access

OK, I have attached the log file and an update config file.

Purple

Cisco 3620 and Internet access

Hi,

I think you should try this config:

http://www.cisco.com/en/US/tech/tk86/tk89/technologies_configuration_example09186a0080094be1.shtml

get rid of your   static default routes then use this config and let us know if you can ping 8.8.8.8 from the router then try from the PC and finally test a ping to www.google.com from the host.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Alain,

Can I just copy that config to my router or just edit my config?

New Member

Cisco 3620 and Internet access

I edited the config file to duplicate as much as I could. I changed the two name servers, but still used the internal range of 192.168.3.x. I removed the static routes as you mentioned. Saved and rebooted router and all pings failed both from the router and pc.

From the pc the ping returns"Reply from 192.168.3.1: Destination host unreachable." when I ping 8.8.8.8. And from the router it also fils when I ping any of the name servers.

Purple

Cisco 3620 and Internet access

Hi,

can you post your config and the output of:

-sh ip int br

-sh ip route

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: Cisco 3620 and Internet access

Here is the requested info. And thanks for your time and patience.

sh ip int br

Interface                      IP-Address              OK? Method Status        Protocol

Ethernet0/0                    192.168.3.1         YES NVRAM  up            up

Ethernet0/1                    unassigned              YES DHCP   up               up

Tunnel1                        unassigned              YES NVRAM  up           down

sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.3.0/24 is directly connected, Ethernet0/0

Purple

Cisco 3620 and Internet access

Hi,

you didn't receive a dhcp address from the ISP on eth0/1 and you didn't configure a defaulr route as explaine in the Cisco doc I posted before.

enable debug for dhcp in privileged mode: debug dhcp detail

renew the IP with the privileged command renew dhcp

Post the output of the log.

Regards.

Alain

Don't forget to rate helpful posts.
Bronze

Cisco 3620 and Internet access

Hi

You mention comcast, is that satellite connection?

Eugen

New Member

Re: Cisco 3620 and Internet access

eugen,

No it's cable with a cable modem. Ray

New Member

Re: Cisco 3620 and Internet access

Alain,

Ok I added in the ip route as:

ip route 0.0.0.0 0.0.0.0 192.168.100.1

This is my comcast default gateway address.  It does work as I can log into it.

I attached the debug file and the renew dhcp command did not work. Did you mean the dos ipconfig /release command?

Ray

Bronze

Cisco 3620 and Internet access

Hi Ray,

I found this posts, it may help you with your problem

http://forums.techarena.in/networking-security/1181169.htm

Eugen

New Member

Cisco 3620 and Internet access

Eugen,

Tried that and no difference. The Ipconfig command relates more to the local pc then to the cable modem ip. I also tried to reset the ip to the cable modem using the reset button on the rear of the it but I still windup the same ip address.

Thanks Ray.

Purple

Cisco 3620 and Internet access

Hi,

Can you try this:

-connect PC directly to modem

-ipconfig/all to see default-gateway

-plug the pc to router and do a ipconfig/release and ipconfig/renew

-change the mac address of the router interface you're going to connect to cable modem to the mac of the pc with interface command: mac-address xxxx.xxxx.xxxx

-connect router to cable modem with the interface command ip address dhcp

-renew the lease with dhcp renew ethernet x/x in privileged mode

-add a default route pointing to next-hop found in the first ipconfig/all: ip route 0.0.0.0 0.0.0.0 x.x.x.x

let us know and post the output of ipconfig/all when connected to modem then when connected to router

as well as:

sh ip int br | exc una

sh int ethernet x/x | i bia

sh ip route static

then also provide results from a ping on router to:

-the next-hop in the static route

-if before succeeds then  to  8.8.8.8

-if success then to 8.8.8.8 sourcing from LAN:  ping  8.8.8.8 so x.x.x.x

Let us know.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Alain,

-connect PC directly to modem(done)

-ipconfig/all to see default-gateway(done DW=192.168.100.1, note this has always been the DW)

-plug the pc to router and do a ipconfig/release and ipconfig/renew(done)

-change  the mac address of the router interface you're going to connect to  cable modem to the mac of the pc with interface command: mac-address xxxx.xxxx.xxxx (do you mean the pc mac? if yes then done)

-connect router to cable modem with the interface command ip address dhcp (e0/1 is connected the the cable modem, so run the ip address dhcp from there?)

-renew the lease with dhcp renew ethernet x/x in privileged mode(this command does not work where stated)

-add a default route pointing to next-hop found in the first ipconfig/all: ip route 0.0.0.0 0.0.0.0 x.x.x.x(x.x.x.x is set to the DW mentioned above)

Thanks Ray

Purple

Cisco 3620 and Internet access

Hi Ray,

Raymond Rio a écrit:

Alain,

-connect PC directly to modem(done)

-ipconfig/all to see default-gateway(done DW=192.168.100.1, note this has always been the DW)

-plug the pc to router and do a ipconfig/release and ipconfig/renew(done)

-change  the mac address of the router interface you're going to connect to  cable modem to the mac of the pc with interface command: mac-address xxxx.xxxx.xxxx (do you mean the pc mac? if yes then done)

Yes

-connect router to cable modem with the interface command ip address dhcp (e0/1 is connected the the cable modem, so run the ip address dhcp from there?)  

Yes


-renew the lease with dhcp renew ethernet x/x in privileged mode(this command does not work where stated)

enable

# dhcp renew e0/1

-add a default route pointing to next-hop found in the first ipconfig/all: ip route 0.0.0.0 0.0.0.0 x.x.x.x(x.x.x.x is set to the DW mentioned above)

Thanks Ray

But you didn't post the outputs and were you able to ping 8.8.8.8 from PC when connected with PC to modem?

What is the exact model of modem?

Post the outputs I asked above please.

If it worked with PC can you clear arp cache of PC with arp -d * then ping 8.8.8.8 while sniffing the interface with wireshark and upload the capture file

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 3620 and Internet access

Ok when I'm connect pc to cable modem I can ping 8.8.8.8 successfully. But when connected to router it does not ping, or for matter anyother ip address. I have made no other changes to the config file other then the mac address change.

Modem is RCA digital broadband , model dcm425.

Outputs

ccefl#sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                192.168.3.1     YES NVRAM  up                    up

Ethernet0/1                unassigned      YES DHCP   up                    up

Tunnel1                    unassigned      YES NVRAM  up                    down

ccefl#

ccefl#sh int ethernet 0/1

Ethernet0/1 is up, line protocol is up

  Hardware is AmdP2, address is 000b.46cc.8fc2 (bia 000b.46cc.8fc2)

  Description: exit

  Internet address will be negotiated using DHCP

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:03, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 19000 bits/sec, 37 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     11808 packets input, 735758 bytes, 0 no buffer

     Received 11808 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     111 packets output, 21726 bytes, 0 underruns

     50 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     50 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

ccefl#

ccefl#sh ip route static

ccefl#        (note it returns just a blank line)

cefl#ping 192.168.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

ccefl#ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Purple

Cisco 3620 and Internet access

Hi,

1)

ccefl#sh int ethernet 0/1

Ethernet0/1 is up, line protocol is up

  Hardware is AmdP2, address is 000b.46cc.8fc2 (bia 000b.46cc.8fc2)

You didn't change the MAC address because otherwise it would be different from the Burned-In address(bia)

2)

Ethernet0/1                unassigned      YES DHCP   up                    up

You have no IP on the interface so the following is normal:

cefl#ping 192.168.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

3)

ccefl#sh ip route static

ccefl#        (note it returns just a blank line)

You have no default route because you have no ip address on the interface

Regards.

Alain

Don't forget to rate helpful posts.
Bronze

Cisco 3620 and Internet access

Hi,

The modem "knows" when you connect a PC or a router to it. That's why you cannot get an ip from it, because it recognize it by mac address.

First you need to connect PC to router and give ip on same subnet, then check your arp cache and write down the PC mac address, then use the commands Alain have suggested to change your mac on the interface that will connect to modem.

Eugen

New Member

Re: Cisco 3620 and Internet access

Gents,

I have attached the wireshark output file, a screen shot of the arp -a file and a recent config file.

Still fails to connect to internet.

interface Ethernet0/0

mac-address 000b.46cc.8fc1     (This is the mac addr of the E0/0 interface card)

ip address 192.168.3.1 255.255.255.0

ip nat inside

no ip route-cache

no ip mroute-cache

full-duplex

no cdp enable

!

interface Ethernet0/1

description exit

mac-address 0006.5b77.89b5     (This is the mac addr of the of my PC.)

ip address 192.168.100.1 255.255.255.0

ip nat outside

no ip route-cache

no ip mroute-cache

full-duplex

no cdp enable

List of mac addr:

000b.46cc.8fc1 = E0/0

000b.46cc.8fc2 = E0/1

0006.5b77.89b5 = PC

0011.e398.dcc6 = modem

2338
Views
0
Helpful
47
Replies
CreatePlease to create content