Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cisco 3640 router

i upgrade from a 2611 to a 3640 router. I am trying to get my home network on the internet. I have tried to configure the router and setup nat overload, but i can't get to the internet. I can ping both nics on the router and i can pping my switch

e0/0

ip 192.168.1.1 255.255.255.0

description Internal

no shutdown

ip nat inside

e0/1

ip dhcp

description Internet

no shutdown

ip nat outside

ip access-list standard 1

permit 192.168.1.0 0.0.0.255

ip nat inside source list 1 interface ethernet0/1

ip route 0.0.0.0 0.0.0.0 ethernet0/1

3 REPLIES
Silver

Re: cisco 3640 router

can you ping an IP address in internet: for example an external DNS?

can you paste the show ip route?

Hall of Fame Super Silver

Re: cisco 3640 router

Richard

The first thing that I would like to verify is whether your router is communicating with the provider router and whether your router is being assigned an IP address on interface ethernet0/1. If it is not then obviously this is the main problem and you need to resolve it.

If the interface is being assigned an IP address then I agree that the next thing to verify is whether the router can ping some Internet resource. Perhaps an external DNS server would be a good target. And ping by address rather than by name so that DNS resolution is removed as a potential variable.

I am guessing that the ping may fail. If the ping does fail then I would suggest that the problem may be in the static default route. You have configured this:

ip route 0.0.0.0 0.0.0.0 ethernet0/1

but configuring a static route pointing at an interface requires that the router ARP for every remote address to which it is attempting to forward. And to succeed it is dependent on the provider enabling proxy arp. I am guessing that the provider is perhaps not enabling proxy arp. I would suggest that you change your static default route to this;

ip route 0.0.0.0 0.0.0.0 dhcp

If the ping does succeed, or if changing the static default route does not resolve the problem then we will need some additional information. Please post the output of show ip interface brief and of show ip route. It might also be helpful if you would post the entire router config.

HTH

Rick

New Member

Re: cisco 3640 router

Richard,

Add "overload" to your nat statement as follows:

ip nat inside source list 1 interface ethernet0/1 overload

Keith

Co-Founder LinuxDynasty

http://www.linuxdynasty.org

http://www.linuxdynasty.com

220
Views
0
Helpful
3
Replies
CreatePlease to create content