Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 3650 QoS

Hello -

I am configuring an interface on a 3650 switch for a device that is being moved from a 3550 switch.  I found that some commands that were configured on the 3550 interface are not available on the 3650:

 mls qos trust device cisco-phone
 mls qos trust dscp

 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0

From 3550 interface config:

 switchport access vlan 100
 switchport trunk encapsulation dot1q
 switchport mode access
 duplex full
 speed 100
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust device cisco-phone
 mls qos trust dscp
 auto qos voip cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable

From 3650 interface config:

 switchport access vlan 100
 switchport mode access
 speed 100
 duplex full
 trust device cisco-phone
 auto qos voip cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
 service-policy input AutoQos-4.0-CiscoPhone-Input-Policy
 service-policy output AutoQos-4.0-Output-Policy
 

MLS commands do not appear to be available on the 3650 switch.  Am I losing functionally on the 3650 or is the a way to enable the use of these commands?

Any advice on this issue is appreciated. 

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Hi, You will not find the

Hi,

 

You will not find the same commands on the 3650 since this is IOS-XE software and it uses the MQC qos model therefore it works different.

This means that instead of using certain global configurations, auto-QoS applied to any interface on a switch configures several global class maps and policy maps, reason why you see an input/output policy map on the interface configuration. You should not be losing the functionality of the auto qos.

Here is a link that covers the auto qos on 3650 switches:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3650/saoftware/release/3se/qos/configuration_guide/b_qos_3se_3650_cg/b_qos_3se_3650_cg_chapter_011.html

 

Hope this helps.

 

5 REPLIES
Silver

Hi, You will not find the

Hi,

 

You will not find the same commands on the 3650 since this is IOS-XE software and it uses the MQC qos model therefore it works different.

This means that instead of using certain global configurations, auto-QoS applied to any interface on a switch configures several global class maps and policy maps, reason why you see an input/output policy map on the interface configuration. You should not be losing the functionality of the auto qos.

Here is a link that covers the auto qos on 3650 switches:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3650/saoftware/release/3se/qos/configuration_guide/b_qos_3se_3650_cg/b_qos_3se_3650_cg_chapter_011.html

 

Hope this helps.

 

Community Member
VIP Purple
Community Member

Re: Hi, You will not find the

Awesome!  Thanks!

VIP Purple

Re: Hi, You will not find the

I have it applied on my 3650s here below , I just use auto qos trust dscp as the Cisco phones mark at the source this will cover everything that sets its DSCP value , it will be bundled into one of teh classes below , but anything EF or AF41 will get priority for voice and video traffic

It will auto generate the class maps and apply service policy to the interfaces like blow
interface GigabitEthernet1/0/9
switchport access vlan 164
switchport voice vlan 196
auto qos trust dscp
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
ip dhcp snooping limit rate 7


!
class-map match-any AutoQos-4.0-Output-Multimedia-Conf-Queue
match dscp af41 af42 af43
match cos 4
class-map match-any AutoQos-4.0-Output-Bulk-Data-Queue
match dscp af11 af12 af13
match cos 1
class-map match-any AutoQos-4.0-Output-Priority-Queue
match dscp cs4 cs5 ef
match cos 5
class-map match-any AutoQos-4.0-Output-Multimedia-Strm-Queue
match dscp af31 af32 af33
class-map match-any non-client-nrt-class
class-map match-any AutoQos-4.0-Output-Trans-Data-Queue
match dscp af21 af22 af23
match cos 2
class-map match-any AutoQos-4.0-Output-Scavenger-Queue
match dscp cs1
class-map match-any AutoQos-4.0-Output-Control-Mgmt-Queue
match dscp cs2 cs3 cs6 cs7
match cos 3
!
policy-map port_child_policy
class non-client-nrt-class
bandwidth remaining ratio 10
policy-map AutoQos-4.0-Output-Policy
class AutoQos-4.0-Output-Priority-Queue
priority level 1 percent 30
class AutoQos-4.0-Output-Control-Mgmt-Queue
bandwidth remaining percent 10
queue-limit dscp cs2 percent 80
queue-limit dscp cs3 percent 90
queue-limit dscp cs6 percent 100
queue-limit dscp cs7 percent 100
queue-buffers ratio 10
class AutoQos-4.0-Output-Multimedia-Conf-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class AutoQos-4.0-Output-Trans-Data-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class AutoQos-4.0-Output-Bulk-Data-Queue
bandwidth remaining percent 4
queue-buffers ratio 10
class AutoQos-4.0-Output-Scavenger-Queue
bandwidth remaining percent 1
queue-buffers ratio 10
class AutoQos-4.0-Output-Multimedia-Strm-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class class-default
bandwidth remaining percent 25
queue-buffers ratio 25
policy-map AutoQos-4.0-Trust-Cos-Input-Policy
class class-default
set cos cos table AutoQos-4.0-Trust-Cos-Table
policy-map AutoQos-4.0-Trust-Dscp-Input-Policy
class class-default
set dscp dscp table AutoQos-4.0-Trust-Dscp-Table

4052
Views
0
Helpful
5
Replies
CreatePlease to create content