Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

CISCO-3750: OSPF over ip unnumbered interface

Hi Expert,

This is the first time I am working on OSPF and IP unnumbered interfaces.

My task is to bring-up OSPF adjacency between two CISCO-3750 switches connected back-to-back via IP unnumbered interfaces. I am using loopback interface to borrow the IP addresses for unnumbered interfaces on both the CISCO switches. After trying so many times, OSPF is not at all coming up over unnumbered interfaces though when tried with numbered interface it was fine.

I am pasting here complete running-config. Please help me in troubleshooting the issue:

Here is brief set-up info:

   R1(Gi1/0/19)-------------------(Gi1/0/19)R

Swicth R1:

===========

Current configuration : 2129 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

switch 1 provision ws-c3750g-24ts-1u

system mtu routing 1500

ip subnet-zero

ip routing

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

interface Loopback1

ip address 10.10.10.10 255.255.255.0

!

interface GigabitEthernet1/0/1

shutdown

!

interface GigabitEthernet1/0/2

shutdown

!

interface GigabitEthernet1/0/3

shutdown

!

interface GigabitEthernet1/0/4

shutdown

!

interface GigabitEthernet1/0/5

shutdown

!

interface GigabitEthernet1/0/6

shutdown

!

interface GigabitEthernet1/0/7

shutdown

!

interface GigabitEthernet1/0/8

shutdown

!

interface GigabitEthernet1/0/9

shutdown

!

interface GigabitEthernet1/0/10

shutdown

!

interface GigabitEthernet1/0/11

shutdown

!

interface GigabitEthernet1/0/12

shutdown

!

interface GigabitEthernet1/0/13

shutdown

!

interface GigabitEthernet1/0/14

shutdown

!

interface GigabitEthernet1/0/15

shutdown

!

interface GigabitEthernet1/0/16

shutdown

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

shutdown

!

interface GigabitEthernet1/0/19

no switchport

ip unnumbered Loopback1

ip ospf network point-to-point

!

interface GigabitEthernet1/0/20

shutdown

!

interface GigabitEthernet1/0/21

shutdown

!

interface GigabitEthernet1/0/22

shutdown

!

interface GigabitEthernet1/0/23

shutdown

!

interface GigabitEthernet1/0/24

shutdown

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface Vlan1

no ip address

shutdown

!

router ospf 100

router-id 100.100.100.100

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

!

ip classless

ip route 20.20.20.20 255.255.255.255 GigabitEthernet1/0/19

ip http server

ip http secure-server

!

!

!

control-plane

!

!

line con 0

line vty 5 15

!

!

monitor session 1 source interface Gi1/0/19

monitor session 1 destination interface Gi1/0/17

end

===

Switch#show ip interface brief | include Up

Switch#show ip interface brief | include up

GigabitEthernet1/0/17     unassigned        YES unset  up                     down

GigabitEthernet1/0/19    10.10.10.10         YES manual up                    up

Loopback1                    10.10.10.10         YES manual up                    up

==================================================

Switch R2:

==================

Switch#sho run

Switch#sho running-config

Building configuration...

Current configuration : 2079 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

!

!

no aaa new-model

switch 1 provision ws-c3750g-24t

system mtu routing 1500

authentication mac-move permit

ip subnet-zero

ip routing

!

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

interface Loopback1

ip address 20.20.20.20 255.255.255.0

!

interface GigabitEthernet1/0/1

shutdown

!

interface GigabitEthernet1/0/2

shutdown

!

interface GigabitEthernet1/0/3

shutdown

!

interface GigabitEthernet1/0/4

shutdown

!

interface GigabitEthernet1/0/5

shutdown

!

interface GigabitEthernet1/0/6

shutdown

!

interface GigabitEthernet1/0/7

shutdown

!

interface GigabitEthernet1/0/8

shutdown

!

interface GigabitEthernet1/0/9

shutdown

!

interface GigabitEthernet1/0/10

shutdown

!

interface GigabitEthernet1/0/11

shutdown

!

interface GigabitEthernet1/0/12

shutdown

!

interface GigabitEthernet1/0/13

shutdown

!

interface GigabitEthernet1/0/14

shutdown

!

interface GigabitEthernet1/0/15

shutdown

!

interface GigabitEthernet1/0/16

shutdown

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

shutdown

!

interface GigabitEthernet1/0/19

no switchport

ip unnumbered Loopback1

ip ospf network point-to-point

!

interface GigabitEthernet1/0/20

shutdown

!

interface GigabitEthernet1/0/21

shutdown

!

interface GigabitEthernet1/0/22

shutdown

!

interface GigabitEthernet1/0/23

shutdown

!

interface GigabitEthernet1/0/24

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 100

router-id 200.200.200.200

log-adjacency-changes

network 20.20.20.0 0.0.0.255 area 0

!

ip classless

ip route 10.10.10.10 255.255.255.255 GigabitEthernet1/0/19

ip http server

ip http secure-server

!

!

ip sla enable reaction-alerts

!

!

!

line con 0

line vty 5 15

!

!

monitor session 1 source interface Gi1/0/19

monitor session 1 destination interface Gi1/0/17

end

====================

Switch#sho ip interface brief | include up

GigabitEthernet1/0/17      unassigned      YES unset  up                    down

GigabitEthernet1/0/19     20.20.20.20      YES manual up                    up

Loopback1                     20.20.20.20      YES manual up                    up

====================================

Thanks a lot in advance for your reply!!

Regards,

Abhi

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: CISCO-3750: OSPF over ip unnumbered interface

Hi Abhi,

the ip unnumbered command does not work on multiaccess-interfaces like Ethernet (even when you configure it as OSPF point-to-point):

Understanding and Configuring the ip unnumbered Command

Cisco IOS IP Addressing Services Command Reference#ip unnumberd

HTH

Rolf

[EDIT]:

... apparently with the exception of high-end platforms like the 6k's:

Command History

(...)

12.2(18)SXF: This command was modified to support Ethernet physical interfaces and switched virtual interfaces (SVIs).

3 REPLIES

Re: CISCO-3750: OSPF over ip unnumbered interface

Hi Abhi,

the ip unnumbered command does not work on multiaccess-interfaces like Ethernet (even when you configure it as OSPF point-to-point):

Understanding and Configuring the ip unnumbered Command

Cisco IOS IP Addressing Services Command Reference#ip unnumberd

HTH

Rolf

[EDIT]:

... apparently with the exception of high-end platforms like the 6k's:

Command History

(...)

12.2(18)SXF: This command was modified to support Ethernet physical interfaces and switched virtual interfaces (SVIs).

New Member

CISCO-3750: OSPF over ip unnumbered interface

Hi Rolf,

Thanks a lot for your reply. It was indeed very helpful.

My CISCO 3750 box has following image:

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 24    WS-C3750G-24T      12.2(52)SE            C3750-IPSERVICESK9-M

So I can conclude that IP unnumbered will not be supported on this platform since it does not support serial ports.

I have CISCO 6503 box also with me.

Could you please confirm if feature would be supported on 6503 ethernet ports or not?

Regards,

Abhi

Re: CISCO-3750: OSPF over ip unnumbered interface

Hi Abhi,

you're welcome. Thanks for rating & marking as answered!

I have CISCO 6503 box also with me.

Could you please confirm if feature would be supported on 6503 ethernet ports or not?

Have a look at the Release Notes:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/release/notes/features.html#wp2800031

"New Software Features in Release 12.2(18)SXF2

...

Support with Supervisor Engine 2 for these features, which are already supported with other Supervisor Engines: 

...

- IP unnumbered for VLAN-SVI interfaces

...

-VLANs over IP unnumbered sub-interfaces"

I have to say I've never done this so far on a c6500 but I think you can rely on the RN.

HTH

Rolf

1626
Views
0
Helpful
3
Replies
CreatePlease to create content