Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

Cisco 3750 with VoIP Sample QoS config

Hi All,

I am adding about 100 VoIP phones to the 3750 switches. Because of lack of patches, the phones will shared the same VLANs with some PCs. I was wondering if there any type of QoS i can implement for the phones on the switch. Will I gain anything from QoS since both devices share the same VLAN? Or should I just leave it as default if there are no gains to implementing QoS?

Thanks much,

11 REPLIES
Hall of Fame Super Blue

Re: Cisco 3750 with VoIP Sample QoS config

etienne.mbuyi wrote:

Hi All,

I am adding about 100 VoIP phones to the 3750 switches. Because of lack of patches, the phones will shared the same VLANs with some PCs. I was wondering if there any type of QoS i can implement for the phones on the switch. Will I gain anything from QoS since both devices share the same VLAN? Or should I just leave it as default if there are no gains to implementing QoS?

Thanks much,

Etienne

The 3750 supports 2 queues on ingress, one of which is a priority queue. If you can identify the ports being used by VOIP you could assign this traffic to the priority queue on ingress. So yes it could well be worth doing -

3750 Ingress queueing

Jon

Bronze

Re: Cisco 3750 with VoIP Sample QoS config

Thanks Jon,

This will take some readings and understanding as it is the first time I am dealing with QoS. I will make to let you know how it works out.

Thanks again,

Bronze

Re: Cisco 3750 with VoIP Sample QoS config

Jon,

Because the phones have two ethernet ports, I opted to use:

switchport access

switchport access vlan 148 (where vlan148 is for pc data)

switchport voice vlan151 (for the phone)

Would you recommend using mls qos trust cos?

Hall of Fame Super Blue

Re: Cisco 3750 with VoIP Sample QoS config

etienne.mbuyi wrote:

Jon,

Because the phones have two ethernet ports, I opted to use:

switchport access

switchport access vlan 148 (where vlan148 is for pc data)

switchport voice vlan151 (for the phone)

Would you recommend using mls qos trust cos?

Etienne

If the phones are correctly marking the voice and signalling packets with CoS then yes. If they are marking them with the correct DSCP markings then you could simply trust DSCP which would mean not having to rewrite the DSCP value at any stage.

It shouldn't matter but one thing to be aware is to check the cos-to-DSCP map on your 3750. If the phones are marking the voice traffic with CoS 5 then you need to make sure that is mapped to DSCP 46 and not 40 as some maps do. Also be aware that not all makes of phone mark voice to CoS 5 eg. Nortel sometimes mark voice traffic as CoS 6.

Jon

Bronze

Re: Cisco 3750 with VoIP Sample QoS config

Jon,

The problem that I am having is that the vendor does not seem to know much about the phones. The phones are Polycom SoundPoint IP335. The reseller could not tell me much about Cos and DSCP. So I found something on Polycom web site that only mentions:

QoS Support – IEEE 802.1p/Q tagging (VLAN), Layer 3

TOS and DSCP

So I sent this info to the reseller and what I got was and I quote below:

"I tried consulting our tier 2 department about the ToS and DSCP values but I was told that we do not have specific values for that.

I was advised that as long as the ports on the router are triggered for the RingCentral service, it should be ok. The ports are 5060-5090 and 16384-16482 UDP. Also, you just have to set priority on the QoS for the RingCentral service as well."

I am going to give Polycom a call and hope to get better info from them.

Hall of Fame Super Blue

Re: Cisco 3750 with VoIP Sample QoS config

Etienne

I was advised that as long as the ports on the router are triggered for the RingCentral service, it should be ok. The ports are 5060-5090 and 16384-16482 UDP. Also, you just have to set priority on the QoS for the RingCentral service as well."

I am going to give Polycom a call and hope to get better info from them.

Okay, so it looks like those ports are for the voice traffic although you would need to confirm. Basically what you need from them is  -

1) what ports are used for the voice traffic itself

2) what ports are used for voice signalling

once you have these you can use an acl in your QOS config to match this traffic and mark it to the correct CoS/DSCP value.

Jon

Bronze

Re: Cisco 3750 with VoIP Sample QoS config

Hi Jon,

I opted to use the config below but what i noticed a lot of outdiscard on the switchports...

mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos

interface FastEthernet1/0/1
description Etienne
switchport access vlan 148
switchport mode access
switchport voice vlan 151
mls qos trust cos
spanning-tree portfast

#sh int fa1/0/1 count er

Port        Align-Err     FCS-Err    Xmit-Err     Rcv-Err  UnderSize  OutDiscards
Fa1/0/1             0           0           0           0          0          215

Port      Single-Col  Multi-Col   Late-Col  Excess-Col  Carri-Sen      Runts     Giants
Fa1/0/1            0          0          0           0          0          0          0

I get the discards even though the phone is not being used and the pc connected to is just idle. The drops are on all of the interfaces. Should i be concerned?

Thanks,

Hall of Fame Super Gold

Re: Cisco 3750 with VoIP Sample QoS config

I think you will find that in reality, no QoS configuration is necessary, and thiugns works perfectly good being left at the default.

Bronze

Re: Cisco 3750 with VoIP Sample QoS config

Thanks Paolo...I opted to use it because of lack of patches and phones and workstations have to share switchport. I will setup few ports without the command "mls qos trust cos" and see if there is any difference.

Hall of Fame Super Gold

Re: Cisco 3750 with VoIP Sample QoS config

--

Bronze

Re: Cisco 3750 with VoIP Sample QoS config

Weird...no errors for the past 45 minutes..I wonder what could of triggered them...i will keep my eyes on it...the switches are two 3750 stack.

3629
Views
0
Helpful
11
Replies
CreatePlease to create content