Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cisco 3750e inter vlan routing

I was just wondering if the Cisco 3750e is able to carry out inter vlan routing with ipbasek9-mz.122-55.SE image. Layer 2, is so how do I achieve this?

My old Switch used to work which did IP routing (L3) but since I have this new one I have failed so far to get it working for my voice lab.

My Set-up

  • Cisco RVS400 which connects me to the outside world and which is also at the minute doing the Inter Vlan Routing
  • Cisco 3750e with ipbasek9-mz.122-55.SE image
  • LAN IP addresses - 192.168.0
  • VOIP address 10.50.50.x
  • VLAN 1 for Data
  • VLAN 3 for Voice

At the moment I have to put static IP address on my lab phones because the RVS4000 has not configuration option for an IP helper.

Thanks for you time

Martyn

7 REPLIES
New Member

cisco 3750e inter vlan routing

Hi,

You can do InterVlan routing on cisco 3750e IP Base image, but you would need IP services IOS for OSPF, Multicasr routing, PBR etc.

Regards,

Pawan Sharma

http://www.ebrahma.com

Purple

cisco 3750e inter vlan routing

Hi,

for inter-vlan routing on the 3750:

1) configure the vlans on the switch and configure ports for auxiliary vlan or as trunk carrying both vlans

2) configure ipv4 unicast routing with the global config mode ip routing command

3) configure SVI for each VLAN and assign proper ip address:

eg:

int vlan 1

desc data vlan

ip address x.x.x.x

int vlan 3

descr voice vlan

  ip address x.x.x.x

4) configure a static default route pointing to your RVS400 router:

   ip route 0.0.0.0 0.0.0.0 x.x.x.x  where x.x.x.x is ip address of RVS400 interface connected to 3750

5) make the interface going to RVS400  a trunk:

    interface x/x

    switchport mode trunk

    switchport trunk allowed vlan 1,3

    switchport nonegotiate

6) do the same on RVS400- look in user guide how to achieve this( look for tagged port)

7) your devices must have the ip address of respective vlan interface as default gateway

Note: you can use the 3750 as dhcp server

Regards.

Alain

Don't forget to rate helpful posts.
New Member

cisco 3750e inter vlan routing

Thanks both for you replies, my Licence will not allow IP Routing.

#show lic

Index 1 Feature: ipservices

        Period left: 0  minute  0  second

Index 2 Feature: ipbase

        Period left: 0  minute  0  second

Index 3 Feature: lanbase

        Period left: Life time

        License Type: Permanent

        License State: Active, In Use

        License Priority: Medium

        License Count: Non-Counted

OK something strange going on at the minute which I hope you can help with.

RVS IP Address 192.168.3.254

SW IP Address 192.168.3.253

3750 switch is connected to my RVS4000 and uses this for its default gateway, so from the switch I can ping the outside world.

Switch#ping 194.168.4.100

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 194.168.4.100, timeout is 2 seconds:

!!!!!

1st problem

From my PC I can browse the net as long as my Gateway address on my PC is that of the RVS4000, as soon as I change my IP address to 192.168.3.253 I can not longer browse the net.

I have two VLAN's set-up

Vlan1                  192.168.3.253

Vlan3                  10.50.50.253

I can ping both IP address from my ACS server of which the address is 192.168.3.201 which shows that the Inter VLAN Routing is working.

2nd Problem

IP Helper is now working briefly, with that I mean that the phones carry out a DHCP discovery and are presented back with the correct information, but because they can not see my TFTP server they just reboot again, here an extended ping.

Switch#ping 192.168.3.201 source 10.50.50.253

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.3.202, timeout is 2 seconds:

Packet sent with a source address of 10.50.50.253

.....

Below is my config which I think is OK.

vtp mode transparent

!

vlan internal allocation policy ascending

!

vlan 3

name voip

!

interface GigabitEthernet1/0/30

description ***IP PHONE***

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan 3

switchport port-security maximum 2

switchport port-security aging time 1

switchport port-security violation protect

speed 100

duplex full

spanning-tree portfast

!

interface GigabitEthernet1/0/45

description *****ACS*****

switchport mode access

switchport voice vlan 3

switchport port-security maximum 2

switchport port-security aging time 1

switchport port-security violation protect

speed 100

duplex full

spanning-tree portfast

!

interface GigabitEthernet1/0/48

description *****UPLINK TO RVS4000*****

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

srr-queue bandwidth share 1 30 35 5

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

!

interface Vlan1

description *****DATA*****

ip address 192.168.3.253 255.255.255.0

!

interface Vlan3

description *****VOICE*****

ip address 10.50.50.253 255.255.255.0

ip helper-address 192.168.3.201

!

ip default-gateway 192.168.3.254

RVS4000

Port 1 connected to Swithport 24

Mode Untagged

Hope you can help me out here as its driving me a little inssane.

Thanks

Martyn

VIP Super Bronze

cisco 3750e inter vlan routing

RVS IP Address 192.168.3.254

SW IP Address 192.168.3.253

That is correct. 192.168.3.254 is the router's IP address and should be your PC's and phones default gateway.  The 3750 is just a layer-2 switch and IP 192.168.3.253 will server as management IP address so you can use it to telnet or SSH to it.  You really don't need to have any SVI on the 3750 for the voice network since you are using it as a layer-2 device.

Since you have 2 vlans definded on your 3750. (vlan 1 and vlan 3), you need to trunk the link between it and RVS.

HTH

New Member

cisco 3750e inter vlan routing

Thanks, the reason I cretated the SVI is becasue the RVS can not do any DHCP relaying so I can not get my option 150 for the TFTP server.

I guess there is no way around this then?

Martyn

VIP Super Bronze

Re: cisco 3750e inter vlan routing

Martyn,

Your DHCP relaying has to be deployed on your router and not the switch.  Unfortunately, I don't know anything about this RVS device to tell you if option 150 can be deployed on it or not.   From your first post you are running and IP base image and layer-3 is divinely supported.  from your next post I (sh lice) I see you are running

so, no layer-3 supported with this image.  If you can upgrade to an IP base image, you can also swap the function of each device by making the 3750 layer-3 and RVS layer-2.  Again, I don't know if this is possible with RVS device or not.

HTH

New Member

cisco 3750e inter vlan routing

Many thnaks for you help, as its a lab I will just assign IP's on the phones.

Thanks again

Martyn

853
Views
5
Helpful
7
Replies