Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 3825 DHCP issue

I need assistance with the following issue I have at one of my sites. I have a Cisco 3825 Voice gateway with Wan connectivity to our main network. Connected to the Voice Gateway is my Cisco 3750 PoE stack. The issue that I have is that I get DHCP IP addresses for the phones and the PC's struggle to obtain IP Addresses. It keeps on saying "Acquiring IP address". The 3825 is configured to provide the PC's with IP Addresses. Some of the PC's are able to get IP addresses and others get stuck on the Acquiring IP Address.

If we add static IP Addresses to the PC's it works, but this is not the way we want it to work.

We have wiped the 3750 stack and set it up again. We have done the same with the 3825 and we still have the same problem.

I am attaching the configuration of the 3750 stack and the 3825 router.

4 REPLIES
VIP Super Bronze

Re: Cisco 3825 DHCP issue

According to your conifg below, the mask for the interface is /27 but for the DHCP scope is /26 Can you make both the same mask and test again?

ip dhcp pool CCOFBLMC_Infrastructure

  network 10.80.108.64 255.255.255.192

   default-router 10.80.108.126

   dns-server 10.89.5.13 10.33.0.5

   domain-name fnb.co.za

   netbios-name-server 10.119.5.13 10.32.255.242

interface GigabitEthernet0/0.7

description CCOFBLMC_Infrastructure

encapsulation dot1Q 7

ip address 10.80.108.126 255.255.255.224

ip flow ingress

no ip route-cache

service-policy input QOS_MARKING_IN

service-policy output COS_MARKING_OUT

HTH

New Member

Re: Cisco 3825 DHCP issue

Hi There

I have fixed it as per below. The main issue though is the Data Vlan. It seems that the PC's are getting IP addresses but on the network config it keeps on saying Acquiring IP Address.

ip dhcp pool CCOFBLMC_Infrastructure
   network 10.80.108.64 255.255.255.192
   default-router 10.80.108.126
   dns-server 10.89.5.13 10.33.0.5
   domain-name fnb.co.za
   netbios-name-server 10.119.5.13 10.32.255.242

interface GigabitEthernet0/0.7
description CCOFBLMC_Infrastructure
encapsulation dot1Q 7
ip address 10.80.108.126 255.255.255.192
ip flow ingress
no ip route-cache
service-policy input QOS_MARKING_IN
service-policy output COS_MARKING_OUT
!

Data Vlan

ip dhcp pool CCOFBLMC_Data

   network 10.80.108.128 255.255.255.128

   default-router 10.80.108.254

   domain-name fnb.co.za

   dns-server 10.89.5.13 10.33.0.5

   netbios-name-server 10.119.5.13 10.32.255.242

   lease 0 12

!

interface GigabitEthernet0/0.3

description CCOFBLMC_Data

encapsulation dot1Q 3

ip address 10.80.108.254 255.255.255.128

ip flow ingress

no ip route-cache

service-policy input QOS_MARKING_IN

service-policy output COS_MARKING_OUT

!

Silver

Cisco 3825 DHCP issue

Hi,

You have configured more windows terminal ports (within vlan 3) at your Cat3750 stack than your dhcp pool address space can assign. So if you have really lot of PCs connected at the same time your address space may be exhausted. In addition to that I would also specify 10.80.108.254 as ip dhcp excluded address.

Best regards,

Antonin 

New Member

Cisco 3825 DHCP issue

You could try checking the IP conflicts (show ip dhcp conflict). If you have conflicts listed, once an entry is listed in the conflict log the Cisco device will never try to hand out that IP again eventually exhausting your dhcp pool.  If this is the issue you can clear the log (clear ip dhcp conflict *) or disable it all together (no ip dhcp conflict logging). 

Hope this helps.

James

866
Views
0
Helpful
4
Replies