Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 3845 router reloading

HI Experts ,

I am running cisco 3845 router in my site with ios :c3845-advsecurityk9-mz.124-15.T10.bin . My router gets rebooted randomly .

I am getting the below logs in the console .

*Nov 10 13:13:54.409: %TRACKING-5-STATE: 2 interface Gi0/0 line-protocol Up->Down

*Nov 10 13:13:56.373: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down

*Nov 10 13:13:56.373: %HSRP-5-STATECHANGE: GigabitEthernet0/0 Grp 5 state Active -> Init

*Nov 10 13:13:56.373: %HSRP-5-STATECHANGE: GigabitEthernet0/1 Grp 4 state Active -> Speak

*Nov 10 13:13:56.373: %RF_INTERDEV-4-RELOAD: % RF induced self-reload

Please find the interface configurations ,

interface GigabitEthernet0/0

description *** Towards ASA ***

ip address 10.10.3.114 255.255.255.248

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip flow ingress

duplex auto

speed auto

media-type rj45

standby delay reload 120

standby 5 ip 10.10.3.117

standby 5 priority 105

standby 5 preempt

standby 5 track GigabitEthernet0/1

no mop enabled

!

interface GigabitEthernet0/1

description *** Towards WAN Router  ***

ip address 192.168.10.2 255.255.255.240

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip flow ingress

duplex auto

speed auto

media-type rj45

standby delay reload 120

standby 4 ip 192.168.10.1

standby 4 priority 105

standby 4 preempt

standby 4 name VPN

standby 4 track GigabitEthernet0/0

no mop enabled

crypto map OVB

!

can anyone please let me know the reason for the reload .

Regards

Angus

3 REPLIES
Cisco Employee

Cisco 3845 router reloading

Hi Angus,

Can you check for crashinfo files in flash: and also attach following commands:

- show ver

- show log

- show stack

Nik

New Member

Re: Cisco 3845 router reloading

Hi Nikholay ,

Thanks for you response

Please find the attached logs asked by you . I donot have the show log output because once the router reloadsall the previous logs will be deleted .

The issue is that the router randomly hangs , while hanging we are not able to access the console or the telnet access .

While the router hangs data transfer is happening without any issues .

Regards

Angus

Cisco Employee

Cisco 3845 router reloading

Hi Angus,

According to documentation:

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_white_paper0900aecd80278edf.shtml

What your are experiencing is not a bug and it is considered as a limitation or behavior

of this feature:

" When one of the interfaces of an active router goes down, the standby router takes over

as active and handles all the operations. However, the previous active

router undergoes a reload and eventually stabilizes as the standby router (if the priority

of the router is at or below that of the current active router)."

That is why after the Gi0/0 went down  the active router reloaded:

*Nov 10 13:13:54.409: %TRACKING-5-STATE: 2 interface Gi0/0 line-protocol Up->Down

%RF_INTERDEV-4-RELOAD: % RF induced self-reload

I guess that port was your IPC link. The IPC link is where the hello packets of both routers are passed.

If you shutdown the interface of the router or the port of the switch where the interface

is connected, the active router would not receive hello packets and

standby router would take the state of being active causing the active router to reload."

Also, this is "normal" when the Routers are connected back to back:

" Routers must be connected using a hub or a switch. If routers are

connected back to back, any time the active router reloads, the standby router also

reloads. This arrangement defeats the purpose of IPsec HA."

This is also documented as DDTS:

CSCee37674

IPsec HA router reloads when HSRP i/f goes down

The HA router reloads due to a 'RF induced reload' whenever the

crypto+hsrp interface is shut down. This is documented as expected behavior.

If you shutdown the interface of the router or the port of the switch

where the interface is connected, the active router would not receive hello packets and

standby router would take the state of being active causing the active router to reload.

So what you see is expected upon the IPC link going down. If you want to avoid it try to have your hello passing through L2 hub or switch.

Hope this helps,

Nik

1427
Views
5
Helpful
3
Replies
CreatePlease login to create content