Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 4948 IOS Upgrade Problem

Hello All

I tried to upgrade my 4948 but I did not realized that system kept the corrupted file

In rommon

File size Checksum File name


13040273 bytes (0xc6fa91) 0x610a023a cat4000-i9k91s-mz.122-25.EWA14.bin

0 bytes (0x0) 0x0001 vlan.dat

10256384 bytes (0x9c8000) 0xbe96c3df cat4000-i9k91s-mz.122-25.EWA14.bin(i


Total space = 60817408 bytes, Available = 37520364 bytes

That is why I could not open in autoboot If I could delete or rename the file I could boot it from that file by the way I tried to open from tftp but switch's ports are not enable it does not see my laptop looks like it is disabled somewhow



New Member

Re: Cisco 4948 IOS Upgrade Problem

After I connect my laptop to mgmt port

I have a message

" Established physical link 100MB Full Duplex

Network layer connectivity may take a few seconds" but still no connection b/w my laptop and switch.

Ip info is

MAC Address : 00-22-90-30-c1-7f

IP Address :

Netmask :

Gateway :

TftpServer :

Main Memory : 256 MBytes

New Member

Re: Cisco 4948 IOS Upgrade Problem


pretty sure I may be able to help as we've just recently purchased 4948.

We noticed that rather than delete the IOS files, they are marked as "D" for some reason in the bootflash:/

There is a probably a neater way of doing this, but you can 'clean' the bootflash:/ with a "format bootflash". This will remove all files from the bootflash: though so make a backup of anything you want via TFTP server.

Then download a new, clean IOS image to the bootflash: via TFTP and update the "boot system ...." in the config and the config-register and reload.

let me know if you are not sure how to get the above done.


New Member

Re: Cisco 4948 IOS Upgrade Problem

Thanks for the messages but,

Formay bootflash is not a command in rommon mode.I can not boot the switch it can not boot itsself look both images are the same but one of them is corrupted.During autoboot it hangs that is why I have to interrupt the boot to rommon mode.In rommon mode there is no command like delete or format

So that is why I could not delete or format the switch.On the other hand I gave IP address to router .2 to laptop even there is a physical connection I can not ping each other.So I can not use tftp boot option

I really got stuck here

4948 is going to make me regret to bought it if I could not solve it



Re: Cisco 4948 IOS Upgrade Problem

as u mentioned in first message, is there any rename file. U can try to rename and then boot from right image.

If rename is not an option then boot from TFTP server and i am attaching a file which explain the procedure to set TFTP first and then boot from TFTP server.

Hope u able to solve it very soon

New Member

Re: Cisco 4948 IOS Upgrade Problem


Where is the file you attached ?


Re: Cisco 4948 IOS Upgrade Problem

forgot to attch file

New Member

Re: Cisco 4948 IOS Upgrade Problem

could you please send it to as a pdf file not a zip please

New Member

Re: Cisco 4948 IOS Upgrade Problem

I read some post that the mgt interface can only really used when the switch is in rommon mode.

We were able to set network parameters with the "set interface " and transferred the image over via TFTP.

You don't need a gateway set if the TFTP server is in the same network as the switch, but this shouldn't cause you not to have a connection.

Can you ping from either side?

CreatePlease login to create content