Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 851 DDNS

Hi,

Having trouble with DDNS on the Cisco 851, trying to get it to connect with my own DDNS server which works fine with the software client so I'm trying to get it to work with a Cisco router.

Here are some of the relevant bits of the config:

ip name-server a.b.c.d

ip ddns update method pindyn

HTTP

  add http://blah%40myregistereddomain.co.uk:password@myddnserverip/nic/update?hostname=<h>&myip=<a>

interval maximum 0 0 1 0

I had to use %40 in my username for the @ otherwise I would get a host failure. If I tried to do this or the equivalent for the question mark I'd get a wrong syntax error in my debug so I used control v before entering the @ after the password and for the ? after update.

interface FastEthernet4

ip ddns update myddnshostname.co.uk

ip ddns update pindyn

The output of the debug ip ddns update command is:

*Jun  8 09:42:01.975: DYNDNSUPD: Adding DNS mapping for myddnshostname.co.uk <=> my.dynamic.ip.address

*Jun  8 09:42:01.975: HTTPDNS: Update add called for supporttest.pindyn.co.uk <=> my.dynamic.ip.address

*Jun  8 09:42:01.975: HTTPDNSUPD: Session ID = 0x20

*Jun  8 09:42:01.975: HTTPDNSUPD: URL = 'http://blah%40myregistereddomain.co.uk:password@myddnsserver/nic/update?hostname=myddnshostname.co.uk&myip=my.dynamic.ip.address'

*Jun  8 09:42:01.975: HTTPDNSUPD: Sending request

*Jun  8 09:42:01.995: HTTPDNSUPD: Response for update myddnshostanme.co.uk <=> my.dynamic.ip.address

*Jun  8 09:42:01.995: HTTPDNSUPD: DATA START

911

*Jun  8 09:42:01.995: HTTPDNSUPD: DATA END, Status is Response data recieved, successfully

*Jun  8 09:42:01.995: HTTPDNSUPD: Call returned SUCCESS for update myddnshostanme.co.uk <=> my.dynamic.ip.address

*Jun  8 09:42:01.995: DYNDNSUPD: Another update completed (outstanding=0, total=0)

*Jun  8 09:42:01.999: HTTPDNSUPD: Clearing all session 32 info

On my DDNS server httpd accesslogs I see the router connecting and getting a 200 repsonse which I believe is normal and if I copy and paste the url into my browser it updates fine.,

Does anyone know what the "911" means after the Data Start command as I rthink this may help with the fix?

Thanks

Everyone's tags (3)
3 REPLIES
New Member

Cisco 851 DDNS

Hi,

Problem fixed with a firmware update

Cisco 851 DDNS

What software version worked for you?

Warm regards, Ramraj Sivagnanam Sivajanam Technical Specialist/Service Delivery Manager – Managed Service Department
New Member

Cisco 851 DDNS

c850-advsecurityk9-mz.124-15.T7.bin

462
Views
5
Helpful
3
Replies
CreatePlease login to create content