cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
659
Views
0
Helpful
5
Replies

Cisco 871 PPPoE problem

robert.crisan
Level 1
Level 1

I have a cisco 871 router and I am not able to make a pppoe connection with ISP.

Config:
Building configuration...

Current configuration : 2043 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname home_gateway
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$G3f1$Le8WUWVfpRAUnS0wfIJDA0
!
no aaa new-model
!
!

!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool AP
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1 
!
!
no ip domain lookup
ip domain name limelite
!
multilink bundle-name authenticated
!
!
username admin password 0 cisco
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 switchport access vlan 100
!
interface FastEthernet1
 switchport access vlan 100
!
interface FastEthernet2
 switchport access vlan 100
!
interface FastEthernet3
 switchport access vlan 200
!
interface FastEthernet4
 description Link to WAN
 no ip address
 ip nat outside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan200
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Dialer1
 description ISP DialIn
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname xxx
 ppp chap password 0 xxx
 ppp pap sent-username xxx password 0 xxx
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 10.0.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
 login local
 no modem enable
line aux 0
line vty 0 4
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000

!
webvpn cef
end

home_gateway#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    up      
FastEthernet1              unassigned      YES unset  up                    down    
FastEthernet2              unassigned      YES unset  up                    down    
FastEthernet3              unassigned      YES unset  up                    down    
FastEthernet4              unassigned      YES manual up                    up      
Vlan1                      unassigned      YES NVRAM  up                    down    
NVI0                       unassigned      NO  unset  up                    up      
Vlan100                    192.168.2.1     YES NVRAM  up                    up      
Vlan200                    10.0.0.1        YES NVRAM  up                    down    
Dialer1                    188.25.128.187  YES IPCP   up                    up      
Virtual-Access1            unassigned      YES unset  up                    up 

 

I am able to get an ip address. But cannot ping into internet.


home_gateway#ping 8.8.8.8 source vlan 100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1 
.....
Success rate is 0 percent (0/5)
home_gateway#traceroute 8.8.8.8 source vlan 100

Type escape sequence to abort.
Tracing the route to 8.8.8.8

  1  *  *  * 
  2  *  * 

Nat translations are making.

home_gateway#sh ip nat tra
Pro Inside global         Inside local          Outside local         Outside global
icmp 188.25.128.187:3     192.168.2.1:3         8.8.8.8:3             8.8.8.8:3
udp 188.25.128.187:49166  192.168.2.1:49166     8.8.8.8:33434         8.8.8.8:33434
udp 188.25.128.187:49167  192.168.2.1:49167     8.8.8.8:33435         8.8.8.8:33435
udp 188.25.128.187:49168  192.168.2.1:49168     8.8.8.8:33436         8.8.8.8:33436
udp 188.25.128.187:49169  192.168.2.1:49169     8.8.8.8:33437         8.8.8.8:33437
tcp 188.25.128.187:54211  192.168.2.10:54211    81.161.59.31:80       81.161.59.31:80
tcp 188.25.128.187:54212  192.168.2.10:54212    54.208.162.210:80     54.208.162.210:80
tcp 188.25.128.187:54221  192.168.2.10:54221    81.161.59.31:80       81.161.59.31:80
tcp 188.25.128.187:54222  192.168.2.10:54222    54.236.215.239:80     54.236.215.239:80
udp 188.25.128.187:56128  192.168.2.10:56128    5.14.64.48:40572      5.14.64.48:40572
udp 188.25.128.187:56128  192.168.2.10:56128    79.117.219.236:24111  79.117.219.236:24111
udp 188.25.128.187:56128  192.168.2.10:56128    86.125.250.226:60404  86.125.250.226:60404
udp 188.25.128.187:56128  192.168.2.10:56128    188.24.8.159:17835    188.24.8.159:17835
home_gateway#

home_gateway#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C    192.168.2.0/24 is directly connected, Vlan100
S*   0.0.0.0/0 is directly connected, Dialer1

Any suggestions for what can be the problem?

5 Replies 5

johnlloyd_13
Level 9
Level 9

hi,

looks like a default route problem.

could you try:

no ip route 0.0.0.0 0.0.0.0 dialer1

int dialer1
ppp ipcp route default
ppp ipcp dns request accept

 

bounce the WAN and monitor:

int f4

shut

no shut

 

 

Hello,

Thank you for the answer!

I have tried.

The static route it's not recieved. I have only the connected links in the routing table.

home_gateway#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C    192.168.2.0/24 is directly connected, Vlan100

Try to sh, no sh the fa4 interface. I also gave a router electrical reset. No result..

hi,

 

i re-checked your config, could you add: ip routing in global config.

make a shut/no shut on the WAN but this time on dialer1 interface.

put back the static route ip route 0.0.0.0 0.0.0.0 dialer1 if still not working.

hello,

 

Still is not working. Ip routing is activated by default and ip classless too in 12.4 ios version.

I have deleted the dialer interface and reconfig it. Then tried first with the ppp ipcp route default, but still not receiving the default route. 

I have been putting back the static route with dialer 1 exit interface.


interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp pap sent-username bb1011991 password 7 005D45505D03535659761C
 ppp ipcp dns request
 ppp ipcp route default

interface FastEthernet4
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1

All the same, I recieve Ip address.

gateway#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    up      
FastEthernet1              unassigned      YES unset  up                    down    
FastEthernet2              unassigned      YES unset  up                    down    
FastEthernet3              unassigned      YES unset  up                    down    
FastEthernet4              unassigned      YES manual up                    up      
Vlan1                      unassigned      YES NVRAM  administratively down down    
NVI0                       unassigned      NO  unset  up                    up      
Vlan100                    192.168.2.1     YES NVRAM  up                    up      
Vlan200                    10.0.0.1        YES NVRAM  up                    down    
Dialer1                    188.27.188.38   YES IPCP   up                    up      
Virtual-Access1            unassigned      YES unset  up                    up      

 

I have debuged ip routing and ppp packet, this is what I got.

Ppp packet

gateway#ping 8.8.8.8 source vlan 100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1 

*Mar 15 19:31:37.634: Vi1 LCP: O ECHOREQ [Open] id 11 len 12 magic 0x1F9E0BC9
*Mar 15 19:31:37.634: Vi1 LCP-FS: I ECHOREP [Open] id 11 len 12 magic 0xE49B3E1C
*Mar 15 19:31:37.634: Vi1 LCP-FS: Received id 11, sent id 11, line up
*Mar 15 19:31:38.558: Vi1 PPP: O pkt type 0x0021, datagramsize 102.
*Mar 15 19:31:40.558: Vi1 PPP: O pkt type 0x0021, datagramsize 102.
*Mar 15 19:31:42.558: Vi1 PPP: O pkt type 0x0021, datagramsize 102.
*Mar 15 19:31:44.558: Vi1 PPP: O pkt type 0x0021, datagramsize 102.
*Mar 15 19:31:46.558: Vi1 PPP: O pkt type 0x0021, datagramsize 102.
Success rate is 0 percent (0/5)

Ip routing

*Mar 15 19:32:08.114: IP-Static:  0.0.0.0 0.0.0.0 Dialer1 Path = 1, route table no change, recursive flag clear
*Mar 15 19:33:06.961: IP: s=192.168.2.1 (local), d=8.8.8.8 (Dialer1), len 100, sending.
*Mar 15 19:33:08.113: RT: NET-RED 0.0.0.0/0

 

 

At a debug ip icmp, I recieve a lot of messages like this, without doing anything on the router:

gateway#
*Mar 16 15:51:49.580: ICMP: dst (188.27.166.205) port unreachable sent to 62.33.49.10
gateway#
*Mar 16 15:51:51.608: ICMP: dst (188.27.166.205) port unreachable sent to 5.228.115.236
gateway#
*Mar 16 15:51:52.772: ICMP: dst (188.27.166.205) port unreachable sent to 62.33.49.10
*Mar 16 15:51:53.392: ICMP: dst (188.27.166.205) port unreachable sent to 62.85.40.90
gateway#
*Mar 16 15:51:55.172: ICMP: dst (188.27.166.205) port unreachable sent to 91.142.9.213
*Mar 16 15:51:55.760: ICMP: dst (188.27.166.205) port unreachable sent to 31.147.78.226
gateway#
*Mar 16 15:51:56.440: ICMP: dst (188.27.166.205) port unreachable sent to 31.28.50.36
gateway#
*Mar 16 15:51:57.488: ICMP: dst (188.27.166.205) port unreachable sent to 93.138.134.23
gateway#
*Mar 16 15:51:59.032: ICMP: dst (188.27.166.205) port unreachable sent to 62.33.49.10
gateway#
*Mar 16 15:52:01.260: ICMP: dst (188.27.166.205) port unreachable sent to 178.223.220.212
gateway#
*Mar 16 15:52:02.720: ICMP: dst (188.27.166.205) port unreachable sent to 62.85.40.90
gateway#
*Mar 16 15:52:04.516: ICMP: dst (188.27.166.205) port unreachable sent to 178.223.220.212
*Mar 16 15:52:05.312: ICMP: dst (188.27.166.205) port unreachable sent to 5.15.21.74
gateway#
*Mar 16 15:52:06.584: ICMP: dst (188.27.166.205) port unreachable sent to 176.215.40.179
gateway#
*Mar 16 15:52:08.040: ICMP: dst (188.27.166.205) port unreachable sent to 92.100.97.79
*Mar 16 15:52:08.212: RT: NET-RED 0.0.0.0/0
gateway#
*Mar 16 15:52:09.864: ICMP: dst (188.27.166.205) port unreachable sent to 176.215.40.179
*Mar 16 15:52:10.752: ICMP: dst (188.27.166.205) port unreachable sent to 178.223.220.212
gateway#
*Mar 16 15:52:11.340: ICMP: dst (188.27.166.205) port unreachable sent to 92.100.97.79
*Mar 16 15:52:12.292: ICMP: dst (188.27.166.205) port unreachable sent to 62.65.194.60
gateway#
gateway#
*Mar 16 15:52:12.964: ICMP: dst (188.27.166.205) port unreachable sent to 87.56.113.203
*Mar 16 15:52:13.772: ICMP: dst (188.27.166.205) port unreachable sent to 78.51.79.26

 

Can anyone know what could be the problem?

Review Cisco Networking products for a $25 gift card