Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 877 trun 2 vlan

I need to connect 2 vlan on a Cisco router VLAN 877 and the second does not connect to anything. PING only to itself, being one who hangs on a switch where there is another router with an IP in the range of VLAN 2. VLAN 1 works well.

interface FastEthernet0

!

interface FastEthernet1

switchport access vlan 2

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 143.104.1.41 255.255.0.0

ip access-group no-inet in

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1368

ip policy route-map red-143109

crypto ipsec client ezvpn vpn inside

hold-queue 100 out

!

interface Vlan2

ip address 10.104.1.41 255.255.0.0

ip flow ingress

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1368

!

Everyone's tags (3)
5 REPLIES
Silver

Cisco 877 trun 2 vlan

Hello Facundo Cesar.

Regarding to the problem description, I was wondering about the configuration on the Switch interface connected to the Cisco877 Fa1...Could you please post the interface configuration of the connected switch ? Is it a trunk ?

As you can ping internally I suppose the VLAN 2 interface status is up/up

In fact I am thinking it could maybe be due to a STP port type  mismatch between Fa1 of the Cisco877 and the connected switch interface...I have been facing this issue in the past.

What is the output of  Cisco877# show spanning-tree interface FastEthernet 1 ?

If it is something like => Port 2 (FastEthernet1) of VLAN2 is broken (Port Type Mismatch) this is the issue.

If not we will have to continue the investigations :-(

Kind regards :-)

Karim

New Member

Cisco 877 trun 2 vlan

PING VLAN2 Response.

show spanning-tree

     Port 1 (F0) Vlan1 Forwarding

     Port 2 (F1) VLAN2 Forwarding

show vlans

     No Virtual LANS configured

show vlans-switch

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0, Fa2, Fa3

2    RedNueva                         active    Fa1

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

What may be happening is you have to build a trunking on Switch 2960 which hangs 877. But in 1710 I have no problem.

Re: Cisco 877 trun 2 vlan

Hi,

Do you have a L2 VLAN created on your 877?

Router(config)#vlan 2

Kindly post your running config, show vlan-switch brief and show ip interface brief output.

Sent from Cisco Technical Support iPhone App

New Member

Cisco 877 trun 2 vlan

PING VLAN2 Response.

show spanning-tree

Port 1 (F0) Vlan1 Forwarding

Port 2 (F1) VLAN2 Forwarding

show vlans

No Virtual LANS configured

show vlans-switch

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0, Fa2, Fa3

2 RedNueva active Fa1

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

What may be happening is you have to build a trunking on Switch 2960 which hangs 877. But in 1710 I have no problem.

New Member

Re: Cisco 877 trun 2 vlan

PING VLAN2 Response.

show spanning-tree

Port 1 (F0) Vlan1 Forwarding

Port 2 (F1) VLAN2 Forwarding

show vlans

No Virtual LANS configured

show vlans-switch

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0, Fa2, Fa3

2 RedNueva active Fa1

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

What may be happening is you have to build a trunking on Switch 2960 which hangs 877. But in 1710 I have no problem.

2399
Views
0
Helpful
5
Replies