Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 877w DHCP and routing problem

Hi guys, I am studying my ccna and have had a cisco 3725 router set up at home for a while but wanted wireless back in my house and so swapped for 877w.

There is no wireless covered in the ccna so I am kinda learning this as i go.

I am with BT (in the UK) and have a fibre modem and so have eventually figuried out how to connect using VDSL and am able to ping websites from the command line...

however I have 2 problems.

1.. I have set up DHCP (wrong obviously) and supposed to be running NAT inside but when i plug my laptop into one of the FE ports it does not pick up an IP address. (I have checked adapter settings.

The WAN connection is in VLAN1 and my Internal Access ports are in VLAN2. and I assigned my internal vlan with a dhcp pool but nothing is happening.

i know i must have messed up but dont know where.

and 2...

If i set my laptop IP manually, I can ping the VLAN Ip address but still cannot get off my network...what am i missing to be able to route between these 2 vlans?

thanks in advance..

here is my config, in full since I am not sure what the issue is. (p.s wireless isnt set up yet.)

hostname Router

!

boot-start-marker

dot11 syslog

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool DHCPSERVER

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1 255.255.255.0

dns-server 212.159.13.49 212.159.13.50

!

ip dhcp pool DSL_DHCP

import all

dns-server 212.159.13.49 212.159.13.50

default-router 192.168.1.1

!

!

ip name-server 212.159.13.49

ip name-server 212.159.13.50

!

!

!

!

!

archive

log config

hidekeys

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0

switchport access vlan 2

speed 100

pppoe enable group global

pppoe-client dial-pool-number 10

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

description INTERNAL NETWORK

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan2

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

pppoe enable group global

pppoe-client dial-pool-number 10

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 10

ppp authentication chap callin

ppp chap hostname @@@@@@@@@@

ppp chap password 0 @@@@@@@@

!

router rip

version 2

network 192.168.1.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer1 overload

!

ip access-list extended NAT

permit ip 192.168.1.0 0.0.0.255 any

!

control-plane

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

Everyone's tags (3)
1 REPLY
Purple

Cisco 877w DHCP and routing problem

Hi,

1° your NAT statement references an inexistent ACL

--->

no ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list NAT interface Dialer1 overload

2° get rid of the DSL_DHCP pool and edit your first pool

--->

no ip dhcp pool DSL_DHCP

ip dhcp pool DHCPSERVER

no default-router 192.168.1.1 255.255.255.0

default-router 192.168.1.1

3° so your modem is not in bridged mode and you are connected to it with one of your switched port(L2 port) in vlan 1

and your internal leg of the modem is 192.168.1.x ?

if so then Vlan 1 is your outside leg and not your inside leg but vlan 2 is your inside leg.

you will also need to put a static IP to vlan 2 for DHCP to work and change your pool to lease you addresses in another subnet like 192.168.2.0/24 for example.

Tell me if I understood correctly and I'll post the changes to be made.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
134
Views
0
Helpful
1
Replies
CreatePlease to create content