Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 881 SDSL with ADSL bkup Configuration.

Hello community.

i'm looking for a cisco 881 configuration with SDSL line as nominal and ADSL as backup.

could someone of you help.

Best Regards

9 REPLIES

Cisco 881 SDSL with ADSL bkup Configuration.

Hi there,

IP SLA will work when both circuits are connected to same router, as you can see, there are two default-route but one has higher cost (i.e. route cost not the $ )

Here is the config below.

Try this out...

track 10 ip sla 1 reachability

delay down 10 up 10

ip route 0.0.0.0 0.0.0.0 172.16.2.2 name DEFAULT-ROUTE track 10

ip route 0.0.0.0 0.0.0.0 2.2.2.1 20 name BACKUP-DEFAULT-ROUTE

ip route 4.2.2.2 255.255.255.255 172.16.2.2 permanent

ip sla 1

icmp-echo 4.2.2.2 source-ip 172.16.2.1

timeout 20000

frequency 10

ip sla schedule 1 life forever start-time now

ip sla enable reaction-alerts

Hope that helps.

Thanks

Rizwan Rafeek.

New Member

Cisco 881 SDSL with ADSL bkup Configuration.

Hi Rizwan

thank you for the response that will serve me later ..

I'm destabilized by vlans in cisco 881 since I can not assign IP addresses to physical inrfaces ... as well as by the absence of the ATM interface. since my router does not XDSL.Pour card information, I have only RJ45 interfaces ..

I feel that it'll be a little hard before I can walk to everything.

if you had that case how will you configure the interfaces?

B regads

Cisco 881 SDSL with ADSL bkup Configuration.

I understand, there is a hardware limitation on your router but you still have one routable FastEthernet4 interface, which can be assign for PPPoE authentication for one ISP connection.

For the second ISP connection, I am not sure.

Sorry, I couldn't help you with hardware limitation.

Thanks

Pls rate any help tips.

Regards

New Member

Cisco 881 SDSL with ADSL bkup Configuration.

thank you Rizwan.

here is the begin of configuration i m starting

!

interface FastEthernet0

description -- To the LAN 1 --

switchport access vlan 2

no ip address

duplex full

speed 100

!

interface FastEthernet1

description -- To the LAN 2 --

switchport access vlan 3

no ip address

duplex full

speed 100

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

description -- To the ADSL Backup Line --

no ip address

shutdown

!

interface FastEthernet4

description --TO the SDSL Maine Line--

no ip address

no ip route-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan2

ip address 10.69.1.254 255.255.255.0

!

interface Vlan3

ip address 10.69.2.254 255.255.255.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

Cisco 881 SDSL with ADSL bkup Configuration.

Can you enable on "interface FastEthenet3" pppoe enable, doubt it? If you cannot then cannot host two circuit on this router.

interface FastEthernet3

description -- To the ADSL Backup Line --

New Member

Cisco 881 SDSL with ADSL bkup Configuration.

Hi Rizwan.

Here are the configuration to which I arrived. Once I have the definitve WAN IP address, I will put the IP SLA that you gave me.

but if you can look and tell me if there are errors.

I remind you that I will connect the router to two Box that will be responsible for authentication etc. ..

Thank you for advance.

!!

interface FastEthernet0

description -- To the LAN 1 --

no ip address

duplex full

speed 100

!

interface FastEthernet1

description -- To the LAN 2 --

switchport access vlan 2

no ip address

duplex full

speed 100

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

description -- To the ADSL Backup Line --

no ip address

pppoe enable

pppoe-client dial-pool-number 2

!

interface FastEthernet4

description --TO the SDSL Maine Line--

no ip address

no ip route-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Vlan1

ip address 10.69.1.254 255.255.255.0

ip helper-address 10.65.50.1

ip helper-address 10.65.50.88

no ip route-cache

!

interface Vlan2

ip address 10.69.2.254 255.255.255.0

ip helper-address 10.65.50.1

ip helper-address 10.65.50.88

!

interface Vlan3

no ip address

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap

crypto map vpn

!

interface Dialer2

mtu 1492

ip address negotiated

encapsulation ppp

dialer pool 2

dialer-group 2

ppp authentication chap

crypto map vpn

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2 250

ip route 10.65.0.0 255.255.0.0 Dialer1

ip route 10.65.0.0 255.255.0.0 Dialer2 250

ip route 10.254.0.0 255.255.0.0 Dialer1

ip route 10.254.0.0 255.255.0.0 Dialer2 250

Cisco 881 SDSL with ADSL bkup Configuration.

Hi there,

FYI...

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2 250

These two routes above highlighted includes everything, I mean everything and four below routes really not needed.

ip route 10.65.0.0 255.255.0.0 Dialer1

ip route 10.65.0.0 255.255.0.0 Dialer2 250

ip route 10.254.0.0 255.255.0.0 Dialer1

ip route 10.254.0.0 255.255.0.0 Dialer2 250

Were you able to test individually each DSL connection to make sure their PPPoE working fine? 

thanks

New Member

Cisco 881 SDSL with ADSL bkup Configuration.

youre right. 0.0.0.0 0.0.0.0 is enough. i just added it

i have not yet tested individually DSL..I ll telle you when did.

but what do you think about the rest of the configuration  ..specially the interfaces ??

Cisco 881 SDSL with ADSL bkup Configuration.

They look fines to me.

869
Views
0
Helpful
9
Replies
CreatePlease to create content