Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

cisco 881w and DHCP issue

Hello.

I have a cisco 881W. My ISP give me two subnet and gateway for them (Fa4 IP address in my configuration). There are three subnet in my company

- two subnets within real IP addresses (a.a.a.x and b.b.b.x in my configuration below)

- one subnet eithin private IP addresses (c.c.c.x in my configuration below)

And DHCP for each. I made configuration on my cisco 881:

WAN port was gateway

LAN ports was separate on thee VLANs

So port Fa0 was insert to  VLAN1 (IP a.a.a.a), port Fa1 was insert to VLAN2 (IP b.b.b.b), port Fa2 was insert to VLAN3 (IP c.c.c.c)

Also I was creare three DHCP pools: pools for subnet a.a.a.a, b.b.b.b and c.c.c.c

But I have issue. When I connected any client into any ports from Fa0 to Fa2 it get rendom IP address from any three pools what I have. Another words if I connected client DHCP into port Fa0 I can will get not only address from pool for c.c.c.0 subnet but and for a.a.a.a subnet and for b.b.b.b subnet.

What me to do?

#sh run

Building configuration...

Current configuration : 3470 bytes

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

boot-start-marker

boot-end-marker

!

!

enable secret ----

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

ip dhcp excluded-address c.c.c.1 c.c.c.100

!

ip dhcp pool pool

network c.c.c.0 255.255.255.0

default-router c.c.c.12

!

ip dhcp pool telephone

network a.a.a.208 255.255.255.248

default-router a.a.a.209

!

ip dhcp pool telephone1

network b.b.b.112 255.255.255.248

default-router b.b.b.113

!

interface FastEthernet0

switchport access vlan 1

no ip address

!

interface FastEthernet1

switchport access vlan 2

no ip address

!

interface FastEthernet2

switchport access vlan 3

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

ip address <IP address> 255.255.255.248

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

crypto map oldshcool

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip address 192.168.255.100 255.255.255.0

arp timeout 0

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

no ip address

!

interface Vlan1

ip address c.c.c.12 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Vlan2

ip address a.a.a.208 255.255.255.248

!

interface Vlan3

ip address b.b.b.112 255.255.255.248

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip nat inside source list 100 interface FastEthernet4 overload

ip route 0.0.0.0 0.0.0.0 <IP address>

!

logging esm config

access-list 100 permit ip c.c.c.0 0.0.0.255 any

!

end

3 REPLIES
New Member

cisco 881w and DHCP issue

Found error in my post (original cisco configuration correct, I'm mistake only here)

!

interface Vlan2

ip address a.a.a.209 255.255.255.248

!

interface Vlan3

ip address b.b.b.113 255.255.255.248

!

Purple

cisco 881w and DHCP issue

Hi,

could you post following outputs:

-sh vlan-sw br

-sh interface status

-sh ip dhcp bindings

- sh ip int br | i Vlan

Regards.

Alain

Don't forget to rate helpful posts.
New Member

cisco 881w and DHCP issue

#sh vlan-sw br

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0, Fa3

3    VLAN0002                         active    Fa1

4    VLAN0003                         active    Fa2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

#sh int status

Port    Name               Status       Vlan       Duplex Speed Type

Fa0                        connected    1          a-full   a-100 10/100BaseTX

Fa1                        connected    2          a-full   a-100 10/100BaseTX

Fa2                        connected    3          a-full   a-100 10/100BaseTX

Fa3                        notconnect   1            auto    auto 10/100BaseTX

Wl0     Internal switch in connected    trunk      a-full  a-1000 10/100BaseTX

#sh ip dhcp binding


Bindings from all pools not associated with VRF:

IP address          Client-ID/              Lease expiration        Type

                    Hardware address/

                    User name

c.c.c.101      0164.00f1.7776.c0       Dec 21 2011 07:15 PM    Automatic

c.c.c.102      0100.1676.0e18.5c       Dec 21 2011 07:15 AM    Automatic

c.c.c.104      0100.1676.d3c0.4c       Dec 21 2011 07:17 AM    Automatic

c.c.c.187      011c.6f65.49f6.8d       Dec 21 2011 07:49 AM    Automatic

b.b.b.117      0100.0e08.3a29.a3       Dec 21 2011 07:16 AM    Automatic

#sh ip int br | i vlan

725
Views
0
Helpful
3
Replies
CreatePlease to create content