Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 881W switch connection issue

I have a cisco 881W which seems to have an issue connecting to s 3COM Smart switch. Systems connected to the 3COM would not register an ip address. HOwever if i switch the 3COM to a unmanaged switch, the problems dissapears. I was wondering if there is a configuration that is needed to ensure than the cisco 881W can communicate with a smart switch. The WAM connection is coming from a modem with ADSL

This is my current configuration.

Any help would be gratefull.

version 15.2

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

!

!

ip dhcp excluded-address 10.10.10.51 10.10.10.254

!

ip dhcp pool ccp-pool

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 202.188.0.133 8.8.8.8

lease infinite

!

!

!

ip domain name yourdomain.com

ip name-server 202.188.0.133

ip name-server 8.8.8.8

ip cef

no ipv6 cef

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

switchport mode trunk

no ip address

!

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip directed-broadcast

no ip proxy-arp

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 199 interface FastEthernet4 overload

!

access-list 199 permit ip any any

no cdp run

!

!

!

line con 0

login local

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

Everyone's tags (4)
18 REPLIES

Cisco 881W switch connection issue

Hello Bryan.

It could be the interface going into err-disable, maybe the interface stays down due to spanning-tree or some kind of incompatibility.

Can you recreate the issue?

Can you post the output of the show interface command when the issue is happening?

Can you post the output of the show interface status err-disable ?

... Show log

Regards.

Wilson B.

New Member

Cisco 881W switch connection issue

Thanks for the reply Wilson.

Do you want the output from the 3COM switch or the Cisco Router.

And how do i go around showing these logs?

Sorry for these question. I am new to this.

Thanks

Bryan Looi

New Member

Cisco 881W switch connection issue

Bryan,

Wilson is asking you to run the commands show interfaces and show interfaces status err-disabled from the CLI and post the output. 

You might also make sure the 3COM switch does not have any conflicting VLAN configuration. 

Re:Cisco 881W switch connection issue

Hello,

It would be good if you also run a debug dhcp for the client process on that interface.

As a side note to the main discussion:

Using a permit ip any any for the NAT setup will cause way to many issues.

Be as specific as possible and never use any as the source.


Remember to rate all of our posts.

Regards.

Jcarvaja


Sent from Cisco Technical Support Android App

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Re:Cisco 881W switch connection issue

Thanks all.

Addressing wilson's request. When i try

show interface status err-disable nothing appears.

This is the show interface.

Here are the configurations.

FastEthernet0 is down, line protocol is down

  Hardware is Fast Ethernet, address is c067.af1c.4bc6 (bia c067.af1c.4bc6)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     1865454 packets input, 237913828 bytes, 0 no buffer

     Received 270 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1793228 packets output, 723463102 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     1 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

FastEthernet1 is up, line protocol is down

  Hardware is Fast Ethernet, address is c067.af1c.4bc7 (bia c067.af1c.4bc7)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

FastEthernet2 is up, line protocol is down

  Hardware is Fast Ethernet, address is c067.af1c.4bc8 (bia c067.af1c.4bc8)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

FastEthernet3 is up, line protocol is up

  Hardware is Fast Ethernet, address is c067.af1c.4bc9 (bia c067.af1c.4bc9)

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 4000 bits/sec, 7 packets/sec

  5 minute output rate 119000 bits/sec, 12 packets/sec

     850987 packets input, 83160538 bytes, 0 no buffer

     Received 1624 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1062568 packets output, 438702498 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

FastEthernet4 is up, line protocol is up

  Hardware is PQ3_TSEC, address is c067.af1c.4bca (bia c067.af1c.4bca)

  Internet address is 192.168.1.2/24

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 118000 bits/sec, 12 packets/sec

  5 minute output rate 3000 bits/sec, 7 packets/sec

     4347982 packets input, 2792086202 bytes

     Received 11 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     4338620 packets output, 945319234 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

NVI0 is administratively down, line protocol is down

  Hardware is NVI

  MTU 1514 bytes, BW 56 Kbit/sec, DLY 5000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation UNKNOWN, loopback not set

  Keepalive set (10 sec)

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

Vlan1 is up, line protocol is up

  Hardware is EtherSVI, address is c067.af1c.4bc6 (bia c067.af1c.4bc6)

  Description: $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

  Internet address is 10.10.10.1/24

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 7000 bits/sec, 10 packets/sec

  5 minute output rate 132000 bits/sec, 12 packets/sec

     4426572 packets input, 971501619 bytes, 0 no buffer

     Received 2916 broadcasts (660 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     4382063 packets output, 2794285378 bytes, 0 underruns

     0 output errors, 1 interface resets

     14 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

Wlan-GigabitEthernet0 is up, line protocol is up

  Hardware is WLAN Gigabit Ethernet, address is c067.af1c.4bca (bia c067.af1c.4bca)

  Description: Internal switch interface connecting to the embedded AP

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:19, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 2 packets/sec

  5 minute output rate 2000 bits/sec, 3 packets/sec

     1741190 packets input, 671924153 bytes, 0 no buffer

     Received 1071 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1858154 packets output, 1694495886 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     2496 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

wlan-ap0 is up, line protocol is up

  Hardware is wlan-ap

  Description: Service module interface to manage the embedded AP

  Interface is unnumbered. Using address of Vlan1 (10.10.10.1)

  MTU 1514 bytes, BW 8000000 Kbit/sec, DLY 5000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation LOOPBACK, loopback not set

  Keepalive set (10 sec)

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

Addressing Daniel's question. The VLAN on the switch is already at VLAn 1, untagged. I firts though this was the problem as well, however, i used this setup on my old 871W router and there was no problem. Also connecting the cable modem direct to the switch also works. Only when the cisco rouiter is placed in between the cable moem and switch problem occurs.

Addressing Julio.  How do i go about running a debug DHCP? and I was not to osure about tha NAT. So i used my old configurations which NAT was enabled for the WAN interface FE4 and also NAT for the inside traffic. How to i specify?

Thanks all for the help. Really appreciate it.

Re:Cisco 881W switch connection issue

Hello bud,

It seems it has an IP address.

So u are missing just thr route

Ip route 0.0.0.0 0.0.0.0 fasteth 0/4

For the nat

Ip access-list extended NAT
Permit ip inside_Subnet any

Ip nat inside source list NAT int fa 0/4 overload

Rate all of the helpful posts buddy

Sent from Cisco Technical Support Android App

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Cisco 881W switch connection issue

Hey Julio,

How to I enable the route?

But I can use an unmanaged switch and it will work fine. Only with this 3COM smart switch, the problem persist.

The NAT if i leave it it should be fine correct?

Thanks Julio for all the help. Really appreciate it

Re:Cisco 881W switch connection issue

Leave the nat the way it is for the moment.

For the route

Config te
Ip route 0.0.0.0 0.0.0.0 x.x.x.x
Where x.x.x.x is the IP address of the ISP modem.

If u do noy have it use
Ip route 0.0.0.0 0.0.0.0 fast 0/4


Sent from Cisco Technical Support Android App

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Cisco 881W switch connection issue

Hey Julio

But isnt this config for the ISP modem to the router? For the WAN interface?

Currently the issue isnt here. I can connect to the ISP modem.

Or is this the commands to speccify an IP for the lan interfaces. Currently all my interfaces have no ip address. But i think the VLAN is assignned to the ports. So thats how im getting internet and IP address.

Why is that when i use an unmanaged switch it works?

Thanks for all your help.

Re:Cisco 881W switch connection issue

Hello.

So I misunderstood ur post..

Thanks for the explanation.

Also share
Show interface fas x/x switchport

Where x/x is the interface connected to the switch

This a really fair and simple configuration.

I do not think the issue is on this device but

Then provide us

show interfaces status err-disabled

Show run interface fastethernet x/x

Where x/x is the interface going to the switch.

Sent from Cisco Technical Support Android App

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Re:Cisco 881W switch connection issue

Hello Julio

The commands above return an error. And the err-disabled command return a blnk screen. So im not too sure what is going on.

Thanks

Bryan Looi

Re:Cisco 881W switch connection issue

Hello,

so if you do show interface fast 0/x switchport you get an syntax error??

What's the interface connecting to the switch???

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Cisco 881W switch connection issue

Hello Julio

Yes, Running

show interface fast 0/x switchport

Gets me an error

Its connected to FA0 currently. This problem only occurs on this switch, On an unmanaged switch, no problem.

Cisco 881W switch connection issue

Hello Bryan,

Then share

show interface fas 0 switchport

show run interface fast 0

show interface fas 0

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Cisco 881W switch connection issue

Hey Julio

Do i do these commands with the switch connected or not, Because if I do it with the switch, I cannot get an IP and thus cannot get these commands and connect to the router. The current set up is cable modem > Switch > Router. The 3Com cannot get an IP from the router. So now ive removed the switch and is connected directly to the router.

Cisco 881W switch connection issue

Hello,

Hey bud you are making things to complicated

So network setup is

Comcast router---3com L2 switch---Router

When you connect the 3com the router does not get an Ip on it's Fa 0/4 interface??

but when you do not have the switch it does??

Is that right???????

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
New Member

Cisco 881W switch connection issue

Sorry for making it complicated. But you are absolutely correct. That is the setup.

That is correct. Absoulutely correct. If connected to the Switch i will not get an IP, but if i connect straight to the router, I will get an IP

Any ideas?

Thanks

Bryan Looi

Re:Cisco 881W switch connection issue

Then you are looking on the wrong place.



The issue is within the 3com switch.

Make sure the connection to the modem is up.

Check that both ports on the 3 com are access ports and connect to the same vlan.

That's all bud.

Do remember to rate all of our answers.

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
691
Views
20
Helpful
18
Replies
CreatePlease login to create content