Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cisco 887va qos for voip

I have a 887VA and i'm trying to config QOS for VoIP 


This is what I'm trying...

ip access-list extended VOIP
permit udp any any range 10000 20000
permit udp any any range 5060 5062
 


class-map match-any VoIP
match access-group name VOIP

 


policy-map VOIPQOS
class VoIP
priority percent 50
set dscp ef
class class-default
fair-queue

 


interface Dialer0

bandwidth 3000

ip nbar protocol-discovery

service-policy output VOIPQOS

 

after testing all setting i still have jitter and delay.

Are these settings correct?

Hope you can help.

thank you,

Michael

7 REPLIES
Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

I see a dialer interface with bandwidth set to 3K.  What's the physical WAN media and its bandwidth?  What's the physical port and its bandwidth?

 

Have you tried to match your VoIP traffic with NBAR?  Do you need NBAR protocol-discovery?

Hall of Fame Super Gold

It sure doesn't make any

It sure doesn't make any sense to configure QoS on a device with just 4 ports.

New Member

hello leo laohoo,I did not

hello leo laohoo,

I did not understand the context of 4 ports? i have 24 port switch.

New Member

Hello JosephDoherty and thank

Hello JosephDoherty and thank you for your response

this is the sh run, i hope it will help...


Current configuration : 2883 bytes
!
! Last configuration change at 13:28:23 UTC Tue Apr 29 2014 by bezeqnet
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mornex
!
boot-start-marker
boot-end-marker
!
!
enable password ******
!
no aaa new-model
!
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool Local_DHCP_Pool
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254
 lease 0 0 30
!
!
!
no ipv6 cef
!
!
license udi pid C887VA-W-E-K9 sn ********
!
!
username ******* password *******
!
!
!
!
!
controller VDSL 0
!
!
class-map match-any VoIP
 match access-group name VOIP
 match protocol rtp
 match protocol sip
!
policy-map VOIPQOS
 class VoIP
  priority percent 70
  set dscp ef
 class class-default
  fair-queue
!
!
!
!
!
!
!
!
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0
 description -WAN$
 no ip address
 pppoe enable group global
 pppoe-client dial-pool-number 2
 pppoe-client dial-pool-number 1
!
interface FastEthernet0
 switchport access vlan 20
 no ip address
!
interface FastEthernet1
 switchport access vlan 20
 no ip address
!
interface FastEthernet2
 switchport access vlan 20
 no ip address
!
interface FastEthernet3
 switchport access vlan 20
 no ip address
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 switchport mode trunk
 no ip address
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 192.168.168.2 255.255.255.0
!
interface Vlan1
 no ip address
!
interface Vlan20
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1412
!
interface Dialer0
 bandwidth 2100
 ip address negotiated
 ip mtu 1452
 ip nbar protocol-discovery
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username ******** password *******
 ppp ipcp dns request
 ppp ipcp address accept
 service-policy output VOIPQOS
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip access-list extended VOIP
 permit udp any any range 10000 20000
 permit udp any any range 5060 5062
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
snmp-server community highnet RO mgt
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 20000 1000
ntp server 172.23.3.241
!
end

 

Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Sorry, not enough.

New Member

The phisical bandwidth is 4k

The phisical bandwidth is 4k and . physical port and its bandwidth-do mean to vdsl controller 0 ?

Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Yes, that helps.

 

If you have 4 Kbps, what you'll should do is shape for that rate.  Your QoS only "triggers" when it sees congestion.  By default, that would be physical interface congestion.  However, you want your QoS to "trigger" relative to your upstream bandwidth limit.

 

PS:

BTW, is 4 Kbps correct?  On DSL?  Seems insufficient for even one VoIP call, even with a compressed codec.

Ref: http://www.cisco.com/c/en/us/support/docs/voice/voice-quality/7934-bwidth-consume.html?referring_site=smartnavRD

162
Views
0
Helpful
7
Replies