Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cisco 887w wireless

hi,

could anyone please post configuration for wireless on the cisco 887w? i would like wireless and wired users on the same vlan if possible

i am trying to bring the radio up but it says reset and down and cant get it to bring it up ( i have done vlan1, ip unmbered vlan1 bit and logged onto ap using service-module wlan-ap0 session command)                  

Also is wpa 2 enterprise possible on the cisco 887 w ( if possible i would like it to authenticate with our acs servers on our main site)

Thanks

Everyone's tags (2)
8 REPLIES
Hall of Fame Super Gold

cisco 887w wireless

New Member

cisco 887w wireless

thanks for this but please note this is 887 w and not 877.

i am getting the error message :

*Jan 13 02:57:09.703: %DOT11-4-NO_SSID_OR_NO_VLAN: No SSID configured. Dot11Radi

o0 not started.xi

*Jan 13 02:57:09.703: %DOT11-4-NO_SSID_OR_NO_VLAN: No SSID configured. Dot11Radi

o0 not started.xi

Hall of Fame Super Gold

cisco 887w wireless

It's the same thing.  Wireless is still wireless.  Configuration you require is does not discriminate what model of router you have unless you want, say 802.11n, nor not.

Silver

cisco 887w wireless

Check if you configured the SSID in Global config.

How its the interface radio? is admintravely down, or protocol down?

Configure the Wireless and the vlan using BVIs like this:

bridge irb

!

!

!

dot11 ssid Corporate

max-associations 64

authentication open

authentication shared

authentication key-management wpa

wpa-psk ascii PasswordKey

!

!

!

interface Dot11Radio0

no ip address

no ip unreachables

no ip proxy-arp

no logging event link-status

logging event subif-link-status

no dot11 extension aironet

!

encryption mode ciphers tkip

!

ssid Corporate

!

channel 2412

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

!

interface Vlan1

no ip address

load-interval 30

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

description == LAN ==

ip address 192.168.26.254 255.255.255.0

ip directed-broadcast

no ip proxy-arp

ip tcp adjust-mss 1412

!

bridge 1 route ip

!

This is a configuration with bridge interfaces, one SSID one VLAN on a bridged interface BVI.

If you want more ssids, use subinterfaces on the interface radio and multiple vlans and bridge it together.

Also this config is for wpa-psk, but try to change the encryption mode to your needs.

Cheers

Pedro

---

Posted by WebUser Pedro Seabra Ávila from Cisco Support Community App

New Member

Re: cisco 887w wireless

thanks for this

actually i found out what hthe issue is.

it first needs definining ssid on dot1radio and then ssid globally

https://supportforums.cisco.com/docs/DOC-4262

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

encryption vlan 1 mode ciphers tkip

!

ssid test

dot11 ssid test

  
!
encryption mode ciphers aes-ccm
!
encryption vlan 1 mode ciphers tkip
!
ssid test

then the radio comes UP and hten you can add ssid globally

dot11 ssid Test
   authentication open
   authentication shared
   authentication key-management wpa version 2

AND i cant create an vlan on the ap itselt - there is no command as int vlan 1 - the only possible thing  i can do is int vlan bvi 1

now second problem, is wpa2 enterprise (authentication with ACS servers on Main site) possible ?

Please let me know

Thanks

New Member

Re: cisco 887w wireless

any ideas please?    

New Member

cisco 887w wireless

Create subinterfaces both in dotradio0.x and fast0.x like this. So you can link the SSID to the vlan that you pretend.

Interface BVI1 is for management on vlan 1, and the SSID Corporate its on the VLAN2.

!

interface BVI1

no ip route-cache

no keepalive

arp timeout 60

ip address 192.168.1.1 255.255.255.0

exit

!

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname AP:2_XXXXX

!

logging buffered 16384 debugging

no logging console

no logging monitor

clock timezone Portugal 0

ip subnet-zero

no ip source-route

no ip gratuitous-arps

ip telnet hidden addresses

no ip domain lookup

!

aaa new-model

!

aaa authentication login default local

aaa session-id common

!

bridge irb

!

dot11 location isocc pt cc 351 ac 999

dot11 network-map 60

!

interface Dot11Radio0.1

description Rede Gestao

encapsulation dot1Q 1 native

no ip address

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

exit

!

interface Dot11Radio0.2

description Rede Users

encapsulation dot1Q 2

no ip address

ip access-group 101 in

no ip route-cache

no ip unreachables

no ip proxy-arp

bridge-group 2

bridge-group 2 port-protected

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

exit

!

interface FastEthernet0

no ip address

no ip unreachables

no ip proxy-arp

no ip route-cache

logging event subif-link-status

speed 10

full-duplex

no keepalive

arp timeout 60

no cdp enable

hold-queue 100 out

exit

!

interface FastEthernet0.1

description Rede Gestao

encapsulation dot1Q 1 native

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

exit

!        

interface FastEthernet0.2

description Rede Users

encapsulation dot1Q 2

no ip address

no ip unreachables

no ip proxy-arp

no ip route-cache

no keepalive

arp timeout 60

no cdp enable

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

exit

!

interface Dot11Radio0

no ip address

no ip unreachables

no ip proxy-arp

no ip route-cache

logging event subif-link-status

!

ssid Corporate

!

world-mode

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

rts threshold 2312

station-role root

rts retries 32

power local cck 50

power client 50

packet retries 32

channel 6

fragment-threshold 2338

payload-encapsulation dot1h

no keepalive

no cdp enable

no dot11 extension aironet

no short-slot-time

exit

!

dot11 ssid Corporate

    vlan 2

    max-associations 64

    authentication open

    guest-mode

    exit

!

ip default-gateway 192.168.1.254

control-plane

!

bridge 1 route ip

!

New Member

Re: cisco 887w wireless

thanks 4023672. its sorted now

5934
Views
0
Helpful
8
Replies