Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco DHCP Server Configuration for IP Phones

Hi

Please let me know if anyone ve successfully implemented DHCP server on a cisco Switch/Router for the IP Phones [Non cisco].

15 REPLIES
New Member

Re: Cisco DHCP Server Configuration for IP Phones

What all options are you looking for? I have done

ip dhcp pool VOICE

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

domain-name voice.local

dns-server 4.2.2.1 4.2.2.2

option 42 ip 192.168.10.1 (for NTP)

option 66 ip 192.168.10.10 (for TFTP)

lease infinite

New Member

Re: Cisco DHCP Server Configuration for IP Phones

Bansal .

Thanks for the post.

My problem is both phone and pc are getting same IP Range , ie Data VLAN .

I am using siemens optipoint phone and i know that there are some extra configurations in windows DHCP server .

will the phone get IP without the DHCP Option values set .

Re: Cisco DHCP Server Configuration for IP Phones

Your phone will get an ip from whatever vlan it's connected to. Generally, if you're going to run your DHCP scope on your router, you'll need to configure router-on-a-stick and put your phones in a separate vlan.

Example:

int fa0/0

no ip address

int fa0/0.1

desc data vlan

encapsulate dot1q 1 native

ip address 192.168.1.1 255.255.255.0

int fa0/0.10

desc voice vlan

encapsulate dot1q 10

ip address 192.168.10.1 255.255.255.0

Your dhcp scope will look like:

ip dhcp pool DATA

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

ip dhcp pool VOICE

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

You'll set your phone to talk on VLAN 10, and it *should* get an address from the VOICE pool.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco DHCP Server Configuration for IP Phones

Also make sure that the VLAN enable option on the phone is also enabled.

I know with Cisco phones, the phones automatically detects the VLAN and puts the lan port in the correct VLAN.

OJ

New Member

Re: Cisco DHCP Server Configuration for IP Phones

VLAN assignment is set to its default . DHCP.

New Member

Re: Cisco DHCP Server Configuration for IP Phones

that,s brilliant .

But , how will the switch get to know that the packet from the phone is the exact voice vlan ?

Scenario: c4500

int fa1/1

switchport access vlan 10

switchport voice vlan 100

auto qos trust dscp

vlan 10: 192.168.10.0/24

vlan 100: 192.168.100.0/24

scope 1 :

network 192.168.10.0/24

scope 2

network 192.168.100.0/24

exclude svi address .

when the phone boots up , its getting ip address in the range 192.168.10.0 which is the data side .

even the pc get the same range .

Re: Cisco DHCP Server Configuration for IP Phones

Vineesh,

I was under the impression that Voice vlans as in "switchport voice vlan" only works with Cisco phones. If you have a different type of phone, you may have to configure it as a trunked port and then set your phone to the correct vlan. I'm not a Cisco VoIP person though, but this is how Avaya phones are set up.

I would configure the port that your phone is connected to as a trunked port (if your pc connects to the phone) or as an access port of the particular vlan that you create for voice only (if your phone is directly connected to a port without a PC attached).

HTH,

John

*please rate if helpful*

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco DHCP Server Configuration for IP Phones

John

Thanks for the post .

TAC have tried this today , but no luck

Re: Cisco DHCP Server Configuration for IP Phones

TAC tried what?

The next thing I would do is put the phone directly to the port, set the port to access for the vlan that you want to get an address for, and see if it works that way. Can you post your config for your DHCP scope, your port that the phone connects to, and the interface for the VLAN that you've configured?

John

HTH, John *** Please rate all useful posts ***

Re: Cisco DHCP Server Configuration for IP Phones

I reread your OP, and I didn't see where you had a scope on your Windows server. Do you have a helper address configured on the interface for the vlan that the phone is coming in on?

What kind of equipment are you working with? Is it the 4500?

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco DHCP Server Configuration for IP Phones

its c4500 switch .

DHCP is configured in the same switch .

i haven't configured helper address

Re: Cisco DHCP Server Configuration for IP Phones

Can you post your config?

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco DHCP Server Configuration for IP Phones

The problem is due to not configuring option 43 .

please let me know if anyone ve configured option 43

eg

option 43 ascii "Siemens,VLAN"

the phone is not accepting this .

New Member

Re: Cisco DHCP Server Configuration for IP Phones

The link between the phone and the switch is mini-trunk. The phone will mark the packets on Vlan 100 with vlan tag and will not mark the packet from Vlan 10. That's how the switch will recognize the different VLAN packets.

OJ

New Member

Re: Cisco DHCP Server Configuration for IP Phones

The issue is resolved .

i had to put option 60 and 43 on the primary [data] dhcp scope .

986
Views
0
Helpful
15
Replies
CreatePlease to create content