Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco Layer 3 3560 switches.

Hi Everyone,

I have 05 Layer 3 Cisco 3560 Switches. They are connected to each other by microwave links with each switch hosting one subnet. I am also going to monitor the switches and the links from one of the sites.

I am a CCNA but new to layer 3 switching. I would like to enable routing on all the switches so that these subnets are accessible from the network, I am confused as how should I proceed to? Can someone tell me the basic configuration on 2 switches that I need to do. We are going to implement another 10 sites with each site hosting one 3560 and one subnet, How do I go about doing this? I have attached the network diagram, my confusion is each switch has 2 exit points and routable subnet. How do I define the routes? Thanks for all the great help..

  • LAN Switching and Routing
5 REPLIES
Hall of Fame Super Bronze

Re: Cisco Layer 3 3560 switches.

Sarfaraz,

Since you are going with Cisco equipments, I recommend implementing EIGRP.

On each 3560 just type the following in config mode:

router eigrp 10

network 192.168.0.0 0.0.255.255

no auto-summary

Wait for a minute or so and then type

show ip route eigrp

show ip eigrp ne

and you should be able to see routes from remote devices.

Hall of Fame Super Silver

Re: Cisco Layer 3 3560 switches.

sarfaraz

I agree with Edison that you will be better off running a dynamic routing protocol and that EIGRP is a good choice. But I believe that implementing this will be more complicated than Edison has indicated. His suggestion would work after you have configured layer 3 interfaces, assigned IP addresses to the interfaces, and possibly configured VLAN interfaces. Since the interfaces on the 3560 default to being layer 2 interfaces he has skipped over some essential steps. And you certainly will need to activate IP routing which is not activated by default.

Your drawing shows the switches as being connected to a neighbor on each side by something that looks like a serial connection but I am not sure that they really will be connected that way. Perhaps you can clarify a bit more about how they will be connected? And perhaps some more detail about the topology of your network.

Without knowing more about your topology I am guessing that you might want to configure a unique VLAN on each of the switches, configure a VLAN interface on the switch, assign an IP address in the proper subnet to the VLAN inteface. I guess that you may also want to configure an interface on the switch as the interface to connect externally. If the switch connections will really operate as point to point connections you probably need two external interfaces but if the connections will operate as multipoint then a single interface will do. You will need to decide on how the IP addressing of the external intefaces will work - if point to point then you want a unique subnet on each connection but if multipoint then a single subnet will do. Once you have those things worked out then you will be ready to run EIGRP.

HTH

Rick

Re: Cisco Layer 3 3560 switches.

Hi Sarfaraz,

In this case, you have to create 3 vlans on each switch or 1 subnet and 2 routed ports on each switch.

One vlan you will use of you subnet/host connectivity and the other 2 vlans/routed ports you will use for your adjacent wireless mircowave links. For example 3560A and you have a micorwave to 3560B and 3560C. Now what you have to do:

CONFIG ON 3560A

Conf t

IP routing

Int vlan 1

ip address 1.1.1.1 255.255.255.0

no shut

Int vlan 2 --> Vlan for 3560B Micro link

ip address 2.2.2.1 255.255.255.0

Int vlan 3 --> Vlan for 3560c Micro link

ip address 3.3.3.1 255.255.255.0

Router rip

Version 2

network 1.1.1.0

network 2.2.2.0

network 3.3.3.0

CONFIG 3560B

Conf t

IP routing

Int vlan 1

ip address 11.11.11.1 255.255.255.0

no shut

Int vlan 2 --> Vlan for 3560A Micro link

ip address 2.2.2.2 255.255.255.0

Int vlan 3 --> Vlan for 3560D Micro link

ip address 33.33.33.1 255.255.255.0

Router rip

Version 2

network 11.11.11.0

network 2.2.2.0

network 33.33.33.0

I think I have made myself clear on this.This should enable the proper routing among all the 3560's with you micor wave links enabled. You can go for any other routing protocl if you have an advanced service image on 3560.

HTH, Please rate if it does.

-amit singh

New Member

Re: Cisco Layer 3 3560 switches.

Dear All,

First of all thank you very much for all your help. All the switches are connected by Microwaves and not serial connection:-). Amit, I am thinking of using no switchport on the microwave ports assign a IP address and then create vlan subnet and start a routing protocol, how will that do?

Sarfaraz

Re: Cisco Layer 3 3560 switches.

That will work for you. Just check the config that I pasted above.It should be designed the same way. Check the IOS version that you have on the switch and based on that you can run your routing protocol as suggested by Edison and Rick also.

Please paste the "show version" and I will cehck it for you.

HTH,

-amit singh

603
Views
0
Helpful
5
Replies
This widget could not be displayed.