Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Nexus 7000 10/100/1000 interface with incrementing input discard counter

I have a Nexus 7K with a 10/100/1000 module connected to a 3560G switch used for management.  The Nexus interface has a constantly incrementing counter for input discard.  Does anybody know what it means?  The 3560 at the other end doesnt seem to report any errors...

Ethernet10/1 is up
  Hardware: 10/100/1000 Ethernet, address: c84c.7544.6b18 (bia c84c.7544.6b18)
  Description: * Cat3560G Mgmt & 10/100 *
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 1000 Mb/s
  Beacon is turned off
  Auto-Negotiation is turned on
  Input flow-control is off, output flow-control is off
  Auto-mdix is turned on
  Switchport monitor is off
  Last link flapped 10week(s) 0day(s)
  Last clearing of "show interface" counters never
  30 seconds input rate 792 bits/sec, 1 packets/sec
  30 seconds output rate 688 bits/sec, 1 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 584 bps, 1 pps; output rate 432 bps, 1 pps
  RX
    24002 unicast packets  10033586 multicast packets  368922 broadcast packets
    10426512 input packets  941161667 bytes
    0 jumbo packets  0 storm suppression packets
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  7044425 input discard
    0 Rx pause
  TX
    146173 unicast packets  5687447 multicast packets  1206230 broadcast packets
    7039850 output packets  909303799 bytes
    0 jumbo packets
    0 output error  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble
    0 Tx pause

Everyone's tags (7)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Cisco Nexus 7000 10/100/1000 interface with incrementing inp

Thanks for the response, but no both interfaces have exactly the same allowed vlan list:

N7K:

interface Ethernet10/1
  description * Cat3560G Mgmt & 10/100 *
  switchport mode trunk
  switchport trunk allowed vlan 300-301
  service-policy type queuing output EgressQueue1p3q4t

Cat3650G:

interface GigabitEthernet0/25
description * non vPC trunk *
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 300,301
switchport mode trunk

Any other ideas?

5 REPLIES
Cisco Employee

Re: Cisco Nexus 7000 10/100/1000 interface with incrementing inp

n.poole@prime-uk.com

I have a Nexus 7K with a 10/100/1000 module connected to a 3560G switch used for management.  The Nexus interface has a constantly incrementing counter for input discard.  Does anybody know what it means?  The 3560 at the other end doesnt seem to report any errors...

Ethernet10/1 is up
  Hardware: 10/100/1000 Ethernet, address: c84c.7544.6b18 (bia c84c.7544.6b18)
  Description: * Cat3560G Mgmt & 10/100 *
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 1000 Mb/s
  Beacon is turned off
  Auto-Negotiation is turned on
  Input flow-control is off, output flow-control is off
  Auto-mdix is turned on
  Switchport monitor is off
  Last link flapped 10week(s) 0day(s)
  Last clearing of "show interface" counters never
  30 seconds input rate 792 bits/sec, 1 packets/sec
  30 seconds output rate 688 bits/sec, 1 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 584 bps, 1 pps; output rate 432 bps, 1 pps
  RX
    24002 unicast packets  10033586 multicast packets  368922 broadcast packets
    10426512 input packets  941161667 bytes
    0 jumbo packets  0 storm suppression packets
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  7044425 input discard
    0 Rx pause
  TX
    146173 unicast packets  5687447 multicast packets  1206230 broadcast packets
    7039850 output packets  909303799 bytes
    0 jumbo packets
    0 output error  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble
    0 Tx pause

Is this a trunk interface? Make sure you have the same set of allowed VLANs on both ends. The usual reason for this counter to increment is when Nexus received tagged frames for VLANs not allowed on it's end.

Atif

New Member

Re: Cisco Nexus 7000 10/100/1000 interface with incrementing inp

Thanks for the response, but no both interfaces have exactly the same allowed vlan list:

N7K:

interface Ethernet10/1
  description * Cat3560G Mgmt & 10/100 *
  switchport mode trunk
  switchport trunk allowed vlan 300-301
  service-policy type queuing output EgressQueue1p3q4t

Cat3650G:

interface GigabitEthernet0/25
description * non vPC trunk *
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 300,301
switchport mode trunk

Any other ideas?

Cisco Employee

Re: Cisco Nexus 7000 10/100/1000 interface with incrementing inp

n.poole@prime-uk.com

Thanks for the response, but no both interfaces have exactly the same allowed vlan list:

N7K:

interface Ethernet10/1
  description * Cat3560G Mgmt & 10/100 *
  switchport mode trunk
  switchport trunk allowed vlan 300-301
  service-policy type queuing output EgressQueue1p3q4t

Cat3650G:

interface GigabitEthernet0/25
description * non vPC trunk *
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 300,301
switchport mode trunk

Any other ideas?

Not really ... hopefully someone else maybe able to help out. I do believe we can look at a couple of other things but that is usually better handled via TAC.

Atif

New Member

Re: Cisco Nexus 7000 10/100/1000 interface with incrementing inp

Hi, folks,

I'm having just the same problem.  I could reduce a lot number of discards just shutting down a subinterface (VLAN) that was not configured at N7K side.  However, discards insist to show up at nexus side.

I'm sending the outputs of the following commands for my two Nexus switches:

show interface ethernet 7/1 counters detailed all
show hardware internal errors module 7
show hardware internal statistics pktflow dropped
show interface ethernet 7/1 counters errors
show hardware internal statistics module 7 device mac all

Just for remembering you, I have two Nexus 7k switches connected, via gigabit ethernet, to two Cisco routers.

Best regards,

Mauricio Harley

New Member

Re: Cisco Nexus 7000 10/100/1000 interface with incrementing inp

Looks like the discards were from dropped BPDU frames.  The BPDUs were from a management network switch which was itself the root for the management VLAN.

12701
Views
10
Helpful
5
Replies
CreatePlease login to create content